Announcement

Collapse
No announcement yet.

Can't upload avatar?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Can't upload avatar?

    I have all the permission set for admin and usergroups for avatar upload

    When I go to upload my own I get

    vBulletin Message

    Imageinfo Failed:


    I have the customavatar folder permissions set to 777

  • #2
    Is this just with avatars or all pictures, try doing a test upload with the same image.

    Admin CP -> Maintenance -> Diagnostics -> Upload

    Comment


    • #3
      Originally posted by acwatts View Post
      Is this just with avatars or all pictures, try doing a test upload with the same image.

      Admin CP -> Maintenance -> Diagnostics -> Upload
      Ok, just tried that, heres the result I got..

      Pertinent PHP Settings file_uploads:Onopen_basedir:VIRTUAL_DOCUMENT_ROOT:/usr/local/lib/php:/usr/local/lib/ph:/smhhome/chroot_bind/php/php5/usr/local/lib/php/:/usr/local/bin/safe_mode:Offupload_tmp_dir:/tmp/php_uploadupload_max_filesize:5.00 MB

      Results PHP's open_basedir setting has been set to VIRTUAL_DOCUMENT_ROOT:/usr/local/lib/php:/usr/local/lib/ph:/smhhome/chroot_bind/php/php5/usr/local/lib/php/:/usr/local/bin/. The uploaded file was stored outside of this directory and is not readable. You will need to contact your host and ask them to specify upload_tmp_dir with a directory inside VIRTUAL_DOCUMENT_ROOT:/usr/local/lib/php:/usr/local/lib/ph:/smhhome/chroot_bind/php/php5/usr/local/lib/php/:/usr/local/bin/. Note that PHP must be able to read and write to this directory.

      I'm not quite sure what this means ?

      Comment


      • #4
        Have you got image settings set to use imagemagick ? if so try changing it to GD admincp > settings > options > Image Settings >

        If that does not work forward that error message to your hosts.

        As it says

        You will need to contact your host and ask them to specify upload_tmp_dir with a directory inside VIRTUAL_DOCUMENT_ROOT:/usr/local/lib/php:/usr/local/lib/ph:/smhhome/chroot_bind/php/php5/usr/local/lib/php/:/usr/local/bin/. Note that PHP must be able to read and write to this directory.

        Comment


        • #5
          Originally posted by acwatts View Post
          Have you got image settings set to use imagemagick ? if so try changing it to GD admincp > settings > options > Image Settings >

          If that does not work forward that error message to your hosts.

          As it says

          Yep, it was set to GD so that was fine

          Its another strange one, Ill try to contact my hosting mob

          Cheers
          Wayne

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X