Announcement

Collapse
No announcement yet.

4.0 upgrade - DON'T DO IT if you have any Mods - and probably, don't do it period!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MDawg
    replied
    I got the Suite upgrade and the problems disappeared for the most part. The incompatibility was with the Blog.

    However I still get some database errors, unknown why:

    Database error in vBulletin 4.0.0:

    Invalid SQL:

    SELECT
    count(*) as maxre
    FROM tagthread
    GROUP BY tagid
    ORDER BY maxre DESC
    LIMIT 0,1;

    MySQL Error : Table '_______forums.tagthread' doesn't exist
    Error Number : 1146
    Request Date : Thursday, December 31st 2009 @ 01:33:58 PM
    Error Date : Thursday, December 31st 2009 @ 01:33:59 PM
    Script : http://www._________.com/forums/cron...and=1262288031
    Referrer : http://www._______.com/forums/general-nonfiction/
    IP Address : 98.176.XXX.XX
    Username : Unregistered
    Classname : vB_Database
    MySQL Version :

    Leave a comment:


  • Ace
    replied
    Originally posted by MDawg View Post
    There is one "mod" that may be the issue - vbSEO 3.5.0
    vBSEO 3.5 won't be causing the fetch_template errors, maybe you have a stray Plugin (not a Product) that remained enabled when you disabled your Products?

    (At the time you posted this, there *was* an issue with Sitemap Generator and Blog/Albums, which might have been what you read to mean there was an incompatibility with vBSEO 3.5 and Blog).

    Leave a comment:


  • Zachery
    replied
    If the rest of you cannot take your bickering out of this thread, I'll do it for you.

    MDawg, the suite was a paid upgrade. If you're just trying to upgrade to the 4.0 forums you cannot use the 3.x blog product.

    Leave a comment:


  • Jafo
    replied
    Originally posted by vivamexico55 View Post
    You're the worst kind of support forum user. I too have received the "YOU'RE TOO DUMB" response, and I just hate it. So awful, I'd rather get no responses. I'm sorry I had to say it, I'll butt out now.
    How about "YOU'RE TOO RECKLESS".... And the user would probably get no response if he/she didn't make a statement in the title of this post telling people not to upgrade, like it is VB's fault for their problems. The user is having issues with vbSEO, which has NOTHING TO DO with Vbulletin. This post should be over on their site. The user says they have disabled all products on their site, yet we find out the real truth that they have plugins running: vbseo and "Thank You Post". I suppose that is VB's fault too that this user cannot even tell the truth?

    Thanks for "butting out"..

    Leave a comment:


  • MDawg
    replied
    According to vbSEO the incompatibility is with vbulletin's own Blog.

    Which comes back to my lament, which is that since I paid for a whole year of blog (just a few months ago, same time I bought vbulletin 3.8), why didn't vbulletin give me the suite instead of just the forum upgrade?

    Leave a comment:


  • vivamexico55
    replied
    Originally posted by Jafo View Post
    This thread is messed up lol..

    Here is how I see it. People who come here crying that their upgrade broke their forum and they have no backup adds about 1 month to my life per incident. I laugh so loudly that anyone would do such a thing. Laughter is good for the mind and body. You are the reason my box of laundry soap has this warning on it: "Do not eat"...
    You're the worst kind of support forum user. I too have received the "YOU'RE TOO DUMB" response, and I just hate it. So awful, I'd rather get no responses. I'm sorry I had to say it, I'll butt out now.

    To the original poster, if you can, I would indeed suggest paying someone at vb.org to try and fix your forum for you, if possible.

    Leave a comment:


  • Lynne
    replied
    vbseo is not related to vbulltin solutions at all. It is it's own product not in anyway put out by vBs.

    Disable all your plugins/products except the Blog and CMS. And when I say disable them ALL, I mean all the products on the Manage Products page (except the Blog and CMS products) AND all the plugins in the Plugin Manager (except those associated with the Blog and CMS). You must do BOTH (I can't emphasize that enough). Now see if you still have the same problem.

    Leave a comment:


  • MDawg
    replied
    The only hack I still have enabled is Thank You Post, but this was upgraded to work with 4.0 today. Also, whether I turn this mod on or off makes no difference.

    I still have this error at the top of each forum page:
    Warning: fetch_template() calls should be replaced by the vB_Template class in [path]/includes/functions.php on line 3895

    And of course, no blogs. :-(


    There is one "mod" that may be the issue - vbSEO 3.5.0 but vbSEO is sold by vbulletin's other arm, and is supposed to work with vbulletin.

    I do have some modifications in my templates that I have not yet reverted, but it seems that my forum is running completely off the 4.0 style templates anyway.

    header
    Default Template Updated in vBulletin 4.0.0 Release Candidate 1 by Jelsoft
    Your Custom Template Last Edited in vBulletin 3.8.3 by ____
    The attempted merge failed due to conflicts [Edit Template]
    [View Highlighted Changes]
    [Revert]
    navbar
    Default Template Updated in vBulletin 4.0.0 Release Candidate 2 by Jelsoft
    Your Custom Template Last Edited in vBulletin 3.8.3 by _____
    The attempted merge failed due to conflicts [Edit Template]
    [View Highlighted Changes]
    [Revert]
    postbit
    Default Template Updated in vBulletin 4.0.0 Release Candidate 2 by Jelsoft
    Your Custom Template Last Edited in vBulletin 3.8.4 by ____
    The attempted merge failed due to conflicts [Edit Template]
    [View Highlighted Changes]
    [Revert]
    postbit_legacy
    Default Template Updated in vBulletin 4.0.0 Release Candidate 4 by Jelsoft
    Your Custom Template Last Edited in vBulletin 3.8.4 by _____
    The attempted merge failed due to conflicts

    Leave a comment:


  • Zachery
    replied
    Originally posted by MDawg View Post
    After about a week of no response, I finally got on the phone with vbulletin tech support.

    I have at this point given up on reverting to 3.8.4 because, yes - I don't have a back up made prior to updating to 4.0. Is there a way to revert given that I never backed up?

    HOWEVER, the forum still is pretty much dead. I have disabled all hacks (no one recommends deleting them - just disabling). After disabling, I have removed the code
    define('DISABLE_HOOKS', true);
    from the config.php

    Forum still doesn't work.

    I still get the error:
    Warning: fetch_template() calls should be replaced by the vB_Template class in [path]/includes/functions.php on line 3895
    at the top of the forum

    and

    when I click on any post or thread I get a blank page and this:

    Warning: fetch_template() calls should be replaced by the vB_Template class in [path]/includes/functions.php on line 3895

    Parse error: syntax error, unexpected T_STRING in /home/_______/public_html/forums/includes/class_core.php(3900) : eval()'d code on line 130

    In the meantime my main forum, with lots of traffic, is working just fine with 3.8.4 I see no benefit to 4.0 quite yet, especially for someone with a lot of mods installed.
    MDawg your issues are either related to 3.8 files or plugins still being active. Do you have any plugins active that are attached to the vBulletin product? AdminCP > Products & Plugins > Plugin Manager >

    Leave a comment:


  • Jafo
    replied
    This thread is messed up lol..

    Here is how I see it. People who come here crying that their upgrade broke their forum and they have no backup adds about 1 month to my life per incident. I laugh so loudly that anyone would do such a thing. Laughter is good for the mind and body. You are the reason my box of laundry soap has this warning on it: "Do not eat"...

    Ahh me..

    Anyway, with that being said, after I backed up all my data on a small site and tried my first attempt at upgrading, I must admit, I forgot to disable the products even though I read that instruction numerous times. There is a lot to do to ensure you have backed everything up and with the nervous excitement, it totally slipped my mind.. Fortunately, my products are light (and custom) so they did not affect the upgrade. I do think it would be wise for the VB team to include some kind of warning on step 1..

    And if you thought your 3.8 products would work with 4.0, you obviously know too little about that area of VB and should either pay someone to upgrade for you, or stick with a productless VB...

    Leave a comment:


  • MDawg
    replied
    After about a week of no response, I finally got on the phone with vbulletin tech support.

    I have at this point given up on reverting to 3.8.4 because, yes - I don't have a back up made prior to updating to 4.0. Is there a way to revert given that I never backed up?

    HOWEVER, the forum still is pretty much dead. I have disabled all hacks (no one recommends deleting them - just disabling). After disabling, I have removed the code
    define('DISABLE_HOOKS', true);
    from the config.php

    Forum still doesn't work.

    I still get the error:
    Warning: fetch_template() calls should be replaced by the vB_Template class in [path]/includes/functions.php on line 3895
    at the top of the forum

    and

    when I click on any post or thread I get a blank page and this:

    Warning: fetch_template() calls should be replaced by the vB_Template class in [path]/includes/functions.php on line 3895

    Parse error: syntax error, unexpected T_STRING in /home/_______/public_html/forums/includes/class_core.php(3900) : eval()'d code on line 130

    In the meantime my main forum, with lots of traffic, is working just fine with 3.8.4 I see no benefit to 4.0 quite yet, especially for someone with a lot of mods installed.

    Leave a comment:


  • Loco.M
    replied
    sounds like user error to me

    I've updated forums and installed mods and the owners are very happy.

    nice thread title, especially the last part..lol

    remember to backup your site next time like is preached 100's of times a day on the .com

    Leave a comment:


  • messengermatt
    replied
    I upgraded from 3.8.4 to V4 and had little to no problems, yes i had to rerun the upgrade twice due to some table thing in a Beta version but since GOLD no issues at all and most of the mods i used to use are now being ported to v4 already so in a short time they will all be workable on there hopefully as there is already 5 pages of them at the .org

    Leave a comment:


  • molieman
    replied
    Works

    Originally posted by cerberuz
    This does make me laugh, (not the fact that your forum is down!) Just all these threads saying DONT INSTALL / UPGRADE TO VB4..

    I just upgraded from 3.8.4 pl2, I didn't use the define('DISABLE_HOOKS', true); as i disabled all plugins myself, I also had vbseo installed and i had no problems at all with the upgrade, I feared the worst prior to upgrading because of the many threads like this one that i've read on here, and even though im a noob (only been using vb since May) ive upgraded to VB4 Gold PL1 and VBSEO 3.5 RC1 and had no issues other than one database issue caused by a conflict from a new vb4 mod on vb.org.. One thing i did do was revert all templates as i was using vbseostyle 2.0.. No problems at all during the upgrade, Yet if i were to believe these types of threads i'd still be on 3.8.4 with the dated vbadvanced instead of the better designed & better looking vbcms from the publishing suite.. My site had quite a few plugins and template mods prior to the upgrade to vb4..

    Im just glad i took the plunge and went ahead with the upgrade.. I hope you get your problems sorted out though as i know what its like to have a site and wait for support..
    That worked for me Thanks again
    Last edited by molieman; Wed 30 Dec '09, 9:48am. Reason: misquote

    Leave a comment:


  • cbiweb
    replied
    Originally posted by AntonLargiader View Post
    ...wore out a mouse on the upgrade script...
    That made me LOL.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X