Announcement

Collapse
No announcement yet.

4.0 upgrade - DON'T DO IT if you have any Mods - and probably, don't do it period!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #76
    Originally posted by worldwidereefer View Post
    so what you saying is I have to do take out the V4 and do a fresh install of V3.8.4, but I don't have to create a new DB ?
    You do not have to...but safer that way.
    If you don't create one:
    Drop all the tables from your existing vB4 database.
    Install vB 3.8.4 with that database.
    Import your database backup into that database.

    (That backup has to be 3.8.4 !)


    vB5 is unequivocally the best forum software, but not yet...

    Comment


    • #77
      Originally posted by beishe8 View Post
      You do not have to...but safer that way.
      If you don't create one:
      Drop all the tables from your existing vB4 database.
      Install vB 3.8.4 with that database.
      Import your database backup into that database.

      (That backup has to be 3.8.4 !)
      Aren't the attachments handled differently in 4.0?, and who knows what else will break.

      Edit: Oh nevermind, install backup. <chuckle>
      Have you heard of one person who ran into problems who actually backed up their database first?
      And to add to that, tested their backup?
      I'll rephrase that, who ran into problems and ranted about it.
      ...steven
      www.318ti.org (vB3.8) | www.nccbmwcca.org (vB4.2)
      bmwcca.org/forum | m135i.net
      "I tried to clean this up but this thread is beyond redemption." - Steve Machol

      Comment


      • #78
        LOL I am just not happy with V4, too much issue. Thank you for all your help.

        Comment


        • #79
          Anyone know how to fix this ?

          copy and paste issue
          I am using fresh installed B4 and I ran into issue with copy and paste. I copy a link or a picture link from www.socaltropicalfishoutlet.com to my site at www.freshwaterkeepers.com

          I pasted onto my forum but for some reason it changes the url address. For example link was http://www.socaltropicalfishoutlet.com/picture1.jpg

          now I pasted in my forum it changes to:

          http://www.freshwaterkeepers.com/picture1.jpg

          any help ? Thanx

          Comment


          • #80
            I have seen a lot of threads, including this one, advising people to forget about 4.0

            What about a thread somewhere that explains the benefits of 4.0 over a heavily modified 3.8.4 ?

            Maybe plain jane 4.0 verus plain 3.8.4 is good - but I don't know anyone who does not modify his forum.

            Comment


            • #81
              Not making a Backup is For The Loss.

              Comment


              • #82
                Originally posted by MDawg View Post
                I have seen a lot of threads, including this one, advising people to forget about 4.0

                What about a thread somewhere that explains the benefits of 4.0 over a heavily modified 3.8.4 ?

                Maybe plain jane 4.0 verus plain 3.8.4 is good - but I don't know anyone who does not modify his forum.

                I agree fully. Not only is it hard enough to convert all your mods to 4.0, but it's like pulling teeth just to style the thing. Any plain installation of vBulletin is not enough for anyone who is trying to "wow" their customers or just plain users. The modifications are where it's at.. with me anyway.

                Off topic: comparing vBulletin to Microsoft, vB3 was definitely the perfected version of XP.. vB4 is like Vista in its early stage (straight crap). Hopefully they redeem themselves with a 7 pretty soon.

                Not saying I don't appreciate the team's hard work, but this version of vB is just unbelievably unorganized.. in my opinion.

                Comment


                • #83
                  I had an extremely hard time upgrading, was not doing it on a live site just using a cloned database. Finally got it going, switched over to it, and the users pretty much hated it. I went back to 3.8.4 and have no plans on going to 4.0, naturally I see no need to renew my license. I will run 3.8 as long as possible then see what my options are then.

                  The only real benefit for me was the built in ad system, other than that I agree with my users.

                  Comment


                  • #84
                    What was so hard about the upgrade?

                    Comment


                    • #85
                      The fact that the stylevars are scattered all over the place, some stylevars control 2-3-4 different things that some of us would like to use different settings for, most of the site is controlled by the stylevars, other parts are hard coded and we pretty much have to spend sometimes hours trying to figure out what goes to what. It's very frustrating. I really hope the next release has fixes as I've read are promised.

                      As far as modding, I'm waiting to see if everything smooths out.

                      Until then, I'm sticking with 3.8 along with xsquid.
                      Last edited by Conner; Fri 1 Jan '10, 12:23pm.

                      Comment


                      • #86
                        Yes for example right now with 4.0 I am having a really hard time figuring out how to just change the colors of the bars and so on on my forum. There are so many pages that come up that have the word Obsolete and "for reference only" on them.

                        Then it talks about the Style Variable Editor, but does this mean the StyleVars?

                        A 4.0 online manual would probably help.

                        Comment


                        • #87
                          Originally posted by Zachery View Post
                          What was so hard about the upgrade?
                          Database errors. Disabling plugin did not work, I had to create a clone of my forum and database and uninstall everything and revert templates. I then had to use the comparison plugin and find out what database tables did not belong to 3.8, including the ones created by 4.0 during the failed install and drop them all. Then I had to dump the database, use a text editor to find and replace charsets and collations to make sure they were all the same. I then created a 3rd database and managed an upgrade that only had a couple of errors where I had to create a couple od fields. I figured all of this out with trial and error and I don't know how many installs, just so everyone could see a forum they did not like at all. If I ever switch to 4.0, which I doubt, I will have to jump through the same hoops but at least I will know where the hoops are now.

                          Comment


                          • #88
                            Originally posted by MDawg View Post
                            Yes for example right now with 4.0 I am having a really hard time figuring out how to just change the colors of the bars and so on on my forum. There are so many pages that come up that have the word Obsolete and "for reference only" on them.

                            Then it talks about the Style Variable Editor, but does this mean the StyleVars?

                            A 4.0 online manual would probably help.
                            You don't use the Main CSS page anymore, you use the stylevars page. Read Don's blog entries and download the StyleVar Dictionary and the Skinning guide: vB4: Skinning Your Forum in 10 Easy Steps and StyleVar Visual Dictionary for Forum, Blog, and CMS (PDF Documents)

                            Also, this should help - HOW TO Find what Stylevar you need to edit

                            Please don't PM or VM me for support - I only help out in the threads.
                            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                            Want help modifying your vbulletin forum? Head on over to vbulletin.org
                            If I post CSS and you don't know where it goes, throw it into the additional.css template.

                            W3Schools &lt;- awesome site for html/css help

                            Comment


                            • #89
                              xsquid is there any reason you didn't start a support ticket to get help with our issues? We're here to help and get you though issues you're having.

                              Comment


                              • #90
                                Another thing.. the pdf guides and firebug are almost ALWAYS referenced when someone has a problem. No one ever gives any real help here anymore. It's very rare if they do. I'm not saying the references don't help, because they do. But not with every single problem 100 other people are having and can't find an answer to. I've used firebug and I've used the pdf files. Any problem I've ever posted has been one that none of those resources have helped me with. So now, any time I make a post, I have to start it with "Yes, before anyone says another thing about firebug, the search feature and the pdf manuals.. I've used them". Some things you just can't find on your own. Which is why there are tech support and moderators. I'm tired of people posting links to the same stuff over and over, which I have read and didn't find an answer. When I post some sort of code I'm having a problem with, I'd expect someone to point out what I'm doing wrong, not post a link. And no, I don't want everything done for me. If someone has an answer, it'd just be easier to give it instead of taking the "this will put you on the right path.. find it on your own" approach. I've even seen people say "Refer to this link. This user is having the same problem as you are", and it just leads me to a post where they posted a link for that user to click and read. It's a vicious circle trying to find an answer, and it's even almost hard to explain because I'm so frustrated.

                                Sorry to hijack the topic on a different note, but it isn't only just the mods and style issues that should be used to explain why not to upgrade. It's also some of the tech support and lack of resources.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X