Announcement

Collapse
No announcement yet.

Fix for Sitemaps (easy way)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    it dosent work for me.
    www.hostsaller.com Hosting Service
    www.forum4phone.com Gsm Community
    http://kholamon.com Bangla Blog

    Comment


    • #17
      Sorry Has this problem been resolved for gold with the new patch 1
      Thanks

      Comment


      • #18
        Originally posted by mrt123 View Post
        Sorry Has this problem been resolved for gold with the new patch 1
        Thanks
        No, but the problem has been solved per David. I am guessing in the next release we will see this fixed and working. The next release is scheduled for the 7th of January.

        Comment


        • #19
          Thanks For the response

          Comment


          • #20
            Thank you -- desordeiro. Your code fix above fixed it for our site, too! -- Rik

            Comment


            • #21
              Awesome, works for me. File is created

              BUT

              when I submit to Google Webmaster Tools it indexes none of the urls. Get a bunch of these errors:
              "URL not allowed. This url is not allowed for a Sitemap at this location"


              Doh!

              What gives?
              Attached Files
              Last edited by petermclane; Thu 31st Dec '09, 10:32am.

              Comment


              • #22
                Originally posted by petermclane View Post
                Awesome, works for me. File is created

                BUT

                when I submit to Google Webmaster Tools it indexes none of the urls. Get a bunch of these errors:
                "URL not allowed. This url is not allowed for a Sitemap at this location"


                Doh!

                What gives?
                Something's wrong with the URLs. Google wants to see them all in the same domain as the sitemap. Maybe your URLs should be under /forum/ ?

                See here: http://www.google.com/support/forum/...55349795&hl=en
                -Andy.
                http://www.checkcheckonetwo.com
                http://www.mindplacesupport.com

                Comment


                • #23
                  Yeah, I just get the red X from Google. Hmm. Good to hear it works for some though.

                  Comment


                  • #24
                    What should these options be set to?

                    Comment


                    • #25
                      i think vbulletin team should fix this problem

                      Comment


                      • #26
                        the question is: When?

                        Comment


                        • #27
                          The VB Team has fixed this problem and it's due to release in the next maintenance release which is on the 7th of January I believe.

                          Comment


                          • #28
                            Originally posted by desordeiro View Post
                            settings > options > XML Sitemaps > Sitemap File Path .. define path with sitemaps.. example: /home/site/forums/sitemaps .... Save.. is ok
                            I do not understand this path, what does "home" represent and what does "site" represent?
                            Romans 5:8 But God commendeth his love toward us, in that, while we were yet sinners, Christ died for us.

                            Comment


                            • #29
                              I thought this was fixed in the 4.0.1? I had problems with Google and the sitemaps since I upgraded to 4.0.1. I looked in the class_sitemaps, and it still reads like it did before. I make the chang that's shown at the beginning of this thread, and now it works fine.

                              At the top of the class_sitemaps files it does say

                              vBulletin 4.0.1 - Licence Number xxxxxxxxxxx
                              || # ---------------------------------------------------------------- # ||
                              || # Copyright 2000-2010 vBulletin Solutions Inc. All Rights Reserved. ||

                              So I know it's a new file


                              The sitemaps were being generated with this
                              http://www.mysite.com/forum/vbulleti...um_0_25.xml.gz
                              instead of
                              http://www.mysite.com/forum/sitemaps/vbulletin_sitemap_forum_0_25.xml.gz

                              I made the change to the file and now it works fine.
                              Last edited by saj716; Thu 14th Jan '10, 6:03am.

                              Comment


                              • #30
                                I didnt change anything.Just set clientscript/sitemap as a Sitemap File Path.submit in webmaster www.mysite.com/forum/
                                clientscript/sitemap/vbulletin_sitemap_forum_0_170.xml.gz and www.mysite.com/forum/
                                clientscript/sitemap/vbulletin_sitemap_thread_1_3817.xml.gz


                                It works nice for me.
                                www.hostsaller.com Hosting Service
                                www.forum4phone.com Gsm Community
                                http://kholamon.com Bangla Blog

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X