Announcement

Collapse
No announcement yet.

Fancy URLs and special characters, ,, don't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Andreas View Post
    This is a known issue and will be fixed in future versions - http://www.vbulletin.com/forum/entry...-and-Character
    This is good way to another disaster.
    Character conversion table would be great for most of non-english latin alphabet based languages (full ASCII, latin 2, etc). Converting ->e ->ae ->u ->n ą->a etc. could satisfy more than 400 millions of European citizens and another half of bilion of South Americans.
    It is simple, still informative (people are used to live with such simplifications) and allow vB to stay away from URL encoding. This is not global workaround, but satisfies a lot. It is easier to split this problem, to cope with really different needs of asian/arabic-languages and latin-characters based sites. To be honest - URL encoded characters of my Polish language will force me to drop vB FURLs, do not need such obscufication. Bet, a lot of other admins will agree with me.

    Comment


    • #17
      Originally posted by terabyte View Post
      Could you just point me to the right php file with the clean-function and I will take a look at it myself. Thanks.
      The modification I made in order to get it working was in /includes/class_friendly_url.php
      I will post a guide later.
      while(true){
      if(
      $someone->needsHelp() && $i->canHelp()) $post->help();
      if(
      $i->findBug()) $post->bug();
      }

      Comment


      • #18
        Originally posted by RadioErewan View Post
        Bet, a lot of other admins will agree with me.
        I do!


        Dody; Thanks for the link Dody. WIll try to take a look at it.

        Comment


        • #19
          Doddy, could you post your way to fix this?

          Comment


          • #20
            Originally posted by terabyte View Post
            Doddy, could you post your way to fix this?
            4.0.1 is around the corner, if it doesn't fix this issue, I will post how to fix it in vbulletin.org
            while(true){
            if(
            $someone->needsHelp() && $i->canHelp()) $post->help();
            if(
            $i->findBug()) $post->bug();
            }

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X