Announcement

Collapse
No announcement yet.

Serious issue: No CMS custom style on home page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Serious issue: No CMS custom style on home page

    It seems that the Gold Release (which I've just installed on our test server) has not fixed vB 4.0's most serious flaw: the fact that the CMS cannot be customised, and won't use custom styles/templates on the 'home' page (though it will elsewhere).

    This has been reported in a bug report: http://www.vbulletin.com/forum/proje...?issueid=33554

    It seems utterly inconceivable that this wouldn't have been sorted before a Gold release, since it makes the CMS entirely unusable in anything but the default vB style; is there a fix to this problem hidden away somewhere?

  • #2
    AFAIK, the style has to be set to default and it shows up then on the CMS - this may be old info tho.

    Comment


    • #3
      You need to manually edit each page/section and set the style to inherit.

      I'm currently using a customized style on the front page at my forum with no problems (http://apertureforums.com/content.php)

      Comment


      • #4
        On my RC4 install the section style setting has to be "Inherit".

        Comment


        • #5
          That doesn't do it, nforums. Sub pages in the CMS do display with custom styling. The Home page never does.

          Comment


          • #6
            Thats strange then and sorry I can't be of any more help.

            vB4 is a supported product now though so I'd submit a support ticket

            Comment


            • #7
              Sorry: none of the above suggestions seems to sort the problem as reported in the bug issue report. Setting the default style across the whole system in AdminCP has no effect; nor any editing of specific areas. It simply never seems to display the Home page in customised styling.

              Comment


              • #8
                When you edit the home page itself using the pencil icon beside your home page title, what do you get once you edit the style dropdown there?
                Vote for:

                - *Admin Settable Paid Subscription Reminder Timeframe*
                -
                *PM - Add ability to reply to originator only*
                - Add Admin ability to auto-subscribe users to specific channel(s)
                - "Quick Route" Interface...

                Comment


                • #9
                  that make's it work here.....

                  Comment


                  • #10
                    For whatever reason, my Home page on the CMS defaults to vBulletin v3 style. When I click on the pencil icon, I change the page style to v4.0 and the logo appears.

                    Comment


                    • #11
                      I had exactly the same issue and spent more than 2 hours (as I created a new style and trying to configure the board).
                      Found the problem (and lead from this thread) that the frontpage section's style is set to "Default Style" where as other sections (with the default data loaded during installation), the style was set to "Board Defaults". Changing default style to board default fixed the logo issue for me and can vb team make the style to "Board Default" for the frontpage section too? thx

                      Comment


                      • #12
                        Originally posted by War.Frog View Post
                        For whatever reason, my Home page on the CMS defaults to vBulletin v3 style. When I click on the pencil icon, I change the page style to v4.0 and the logo appears.
                        This helped heaps, thanks!

                        Comment


                        • #13
                          Originally posted by handiyman View Post
                          I had exactly the same issue and spent more than 2 hours (as I created a new style and trying to configure the board).
                          Found the problem (and lead from this thread) that the frontpage section's style is set to "Default Style" where as other sections (with the default data loaded during installation), the style was set to "Board Defaults". Changing default style to board default fixed the logo issue for me and can vb team make the style to "Board Default" for the frontpage section too? thx
                          That's brilliant: it's sorted things.

                          vB 4.0, on a new install of the Suite, defaults to this setting (inappropriately). It has to be shifted manually in the manner you describe.

                          The default setting for the style on the CMS main page should be 'Board Default', rather than 'Default Style' -- particularly as this is not at all obvious on a new system.

                          Hopefully vB will fix this in future versions.

                          Many thanks for the guidance.

                          Comment


                          • #14
                            The bug report says its fixed in 4.0.1 but I still face the same issue. Do I have to change a setting before this will work?

                            Comment


                            • #15
                              Originally posted by Easific View Post
                              The bug report says its fixed in 4.0.1 but I still face the same issue. Do I have to change a setting before this will work?
                              Yes.. you need to define what style to use (or use Inherit), when you are editing the Front Page. Click the pencil that appears when you hover near the end of the CMS Page name.
                              My Live vB5 Site - NZEating.com
                              vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X