Announcement

Collapse
No announcement yet.

How to Backup before Upgrading to 4.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by assaf View Post
    Fatal error when upgrading to vb4

    Step 7) Merge template changes
    Merged template successfully: memberinfo_css (style: 1)
    Merged template successfully: ad_navbar_below (style: 2)

    Fatal error: Out of memory (allocated 53739520) (tried to allocate 2140 bytes) in /home/user/public_html/upload/includes/class_diff.php on line 146

    how i fix this ?
    Ok I found it (should have bookmarked but forgot )

    Give this a try

    http://www.vbulletin.com/forum/showt...=1#post1838455

    Special thanks to Carnage for that


    Former vBulletin Support Staff
    Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
    Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!
    Need a Host? - I recommend URLJet

    Comment


    • I'm in the process of upgrading my site to VB R2 (I'm currently VB 3.8.4). I've made an exact copy of my 'live' site in a new directory. And will be working on that, to ensure my live site is okay I'm at the stage of uploading the contents of the VB R1 .zip file. But I don't know what to upload, or where to upload it too?

      I don't want to be hasty and upload the entire folder, for risk of overwriting what's already there. Could you please help me?

      Comment


      • Originally posted by 04wayne View Post
        I'm in the process of upgrading my site to VB R2 (I'm currently VB 3.8.4). I've made an exact copy of my 'live' site in a new directory. And will be working on that, to ensure my live site is okay I'm at the stage of uploading the contents of the VB R1 .zip file. But I don't know what to upload, or where to upload it too?

        I don't want to be hasty and upload the entire folder, for risk of overwriting what's already there. Could you please help me?
        Check your PM's on vB.org but here it is regardless

        Originally posted by TheLastSuperman
        Originally posted by 04wayne
        Hiya there, I'm Wayne (I stumbled across your profile via this fabulous guide of yours over at VBulletin.com! Anyway, after clicking on your profile, and seeing that you don't log in that much over there, I decided to PM you over here. Is that okay? Obviously, if not, then just tell me where to go!

        ====

        I'm in the process of upgrading my site to VB R2 (I'm currently VB 3.8.4). I've made an exact copy of my 'live' site in a new directory. And will be working on that, to ensure my live site is okay I'm at the stage of uploading the contents of the VB R1 .zip file. But I don't know what to upload, or where to upload it too?

        I don't want to be hasty and upload the entire folder, for risk of overwriting what's already there. Could you please help me? You can contact me here, or preferably at VBulletin.com. But whatever suits your needs!

        Wayne
        Wayne,

        Honestly I'm actually terribly busy with clients, a failed 4.0 upgrade that a previous client thought she could do she's crying on the phone to me to fix it... terrible tbo.

        REMOVED see your PM on vb.org

        So you made a new folder on your server?

        Well lets make it simple...

        www.yoursite.com/forums

        Is it something similar now? If so make a new one like this...

        www.yoursite.com/forums2

        Now it's in another folder!

        Now simply upload ALL the copied files from your live site into the files inside the new forums2 folder. Now connect it to the database via the config file, also disable the mods in the admincp AND the config file then if your using a custom style revert it to the vB default style then turn off the copied site.

        Now upload the vB 4 files i.e. everything in the UPLOAD folder should be copied over to the forums2 folder and run the upgrade script!

        Let me know how it goes!

        Mike
        Wayne, make sure you make a copy of the database to test the upgrade on too otherwise your upgrading the live databse if you don't specify the new database credentials in the new forums2/includes/config.php


        Former vBulletin Support Staff
        Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
        Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!
        Need a Host? - I recommend URLJet

        Comment


        • its only letting me upgrade to 3.8.4. but i'm already 3.8.4! What have I not done?

          Comment


          • Originally posted by 04wayne View Post
            its only letting me upgrade to 3.8.4. but i'm already 3.8.4! What have I not done?
            Check you pm's on vb.org it seems you might have just uploaded your 3.8 copied files now you need to disable mods in admincp, disable via config and revert to default style then close the forum upload the new files including config with mods disabled in it too via the code in step 3 here and then upgrade to 4.0 by uploading the files and running the upgrade script.

            The 4.0 upgrade files have to be present in order to update to 4.0

            Mike


            Former vBulletin Support Staff
            Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
            Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!
            Need a Host? - I recommend URLJet

            Comment


            • Well I decided to give this a bash tonight too. Backed up my entire site and SQL so it's a quick and easy reupload to bring it back so that's fine, but what I did was this:
              • Forums installed on: [domain]/forums
              • index of vBA installed on: [domain]

              I deleted the index of vBA, in fact everything (except for the directories of course) in root so that's clear, I then uploaded the entire publishing suite, disabled all mods and the forums, then went ahead with the upgrade. That all went smoothly and then when going into the site I come across pretty much an unusable site. Maybe I should try the Impex option?

              Comment


              • You have old plugins still active. Disable all your plugins/products except the Blog and CMS. And when I say disable them ALL, I mean all the products on the Manage Products page (except the Blog and CMS products) AND all the plugins in the Plugin Manager (except those associated with the Blog and CMS). You must do BOTH (I can't emphasize that enough). Now see if you still have the same problem.

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools <- awesome site for html/css help

                Comment


                • Originally posted by Varsh View Post
                  Well I decided to give this a bash tonight too. Backed up my entire site and SQL so it's a quick and easy reupload to bring it back so that's fine, but what I did was this:
                  • Forums installed on: [domain]/forums
                  • index of vBA installed on: [domain]

                  I deleted the index of vBA, in fact everything (except for the directories of course) in root so that's clear, I then uploaded the entire publishing suite, disabled all mods and the forums, then went ahead with the upgrade. That all went smoothly and then when going into the site I come across pretty much an unusable site. Maybe I should try the Impex option?
                  Lynne has you covered so listen to her... 1000x better @ all of this then me she most certainly is

                  And only reason I decided to reply was the fact you mentioned impex.... if Lynne would not have posted nor I the following day would patience have been a virtue? What I mean by that is IMPEX has not been re-written for 4.0 so it is in fact a last resort and some members have ASSUMED their forums were beyond hope when one coder could fix the issue I know I have done it several times even the admincp db errors some thought it was hopeless.. this poor member had no clue the solution was posted before RC2 release... see he posted here: http://www.vbulletin.com/forum/showt...hlight=tcustom but it is in the projects/bug reports already with a fix so was a fix by Carnage for GoDaddy to import the style in pieces pretty much.

                  All I'm saying is you need to look around or at least ask around instead of becoming impatient, some of you are fine and wait but others are worse than a geek waiting on his new custom $10,000 dollar gaming rig... sometimes it's overkill and pointless to be so hasty, the answer could be right in front of you or so simple but yet you just spent an entire night doing something simply uncalled for because you could not be patient. Please be patient when working on your forum otherwise you might make a mistake... we would rather be helpful and post guides all the time for you to learn instead of trying to coach you on recovering your forum. I told 2 others to leave their site alone, do not do impex and wait for a new release as it might fix their problems and sure enough it did with the release of RC2 so their patience paid off.. yes they might have lost a few members but losing all attachments and other pertinent data was not an option for them so being down less than 2 weeks was all it needed. Situations will differ so judge accordingly but if I see impex mentioned once more in haste I'll ask for that thread to be deleted so it won't lead to wrong impressions or false hopes.

                  Sincerely,
                  Mike


                  Former vBulletin Support Staff
                  Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
                  Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!
                  Need a Host? - I recommend URLJet

                  Comment


                  • I had already disabled them before I upgraded, "disabled all mods and the forums, then went ahead with the upgrade". I have though added the "disable hooks" just now and it appears to be now working. Like I said though, this was more of a test on a live site as I can easily just put everything back. If it works straight off then all is fine, if it doesn't then again all is fine. How about you actually read first that I backed everything up first in case of a problem instead of calling me out on being impatient, when I wasn't and was simply testing knowing I have no problem reverting back in a literal 1 click. I'm not stupid to do something this big and not backup.
                    Last edited by Varsh; Tue 15th Dec '09, 5:46am.

                    Comment


                    • Originally posted by Varsh View Post
                      I had already disabled them before I upgraded, "disabled all mods and the forums, then went ahead with the upgrade". I have though added the "disable hooks" just now and it appears to be now working. Like I said though, this was more of a test on a live site as I can easily just put everything back. If it works straight off then all is fine, if it doesn't then again all is fine. How about you actually read first that I backed everything up first in case of a problem instead of calling me out on being impatient, when I wasn't and was simply testing knowing I have no problem reverting back in a literal 1 click. I'm not stupid to do something this big and not backup.
                      Yes please read... touche' as I directed the latter part of my post towards the entire community not you, all I said about you was I agreed with Lynne and mentioned Impex should be a last resort which made me realize I need to make it known yet again before OTHERS get the wrong impression.

                      As long as your good now that's all that matters.


                      Former vBulletin Support Staff
                      Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
                      Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!
                      Need a Host? - I recommend URLJet

                      Comment


                      • Originally posted by TheLastSuperman View Post
                        Yes please read... touche'
                        No offense mate but your entire wording had "you" and you quoted me, even if you meant to direct that at everyone, the way you put it across it certainly looked fully directed at myself.

                        Comment


                        • Originally posted by Varsh View Post
                          No offense mate but your entire wording had "you" and you quoted me, even if you meant to direct that at everyone, the way you put it across it certainly looked fully directed at myself.
                          I know just the way I tend to think and type lol and habits are hard to break. I knew you were not being like that either it just caught you off guard that's when I said ohh no he took what I said the wrong way I just wanted to emphasize that point to everyone about impex as a last resort until it's re-written to handle the attachments and other changes related to vB4 properly etc .

                          Mike


                          Former vBulletin Support Staff
                          Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
                          Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!
                          Need a Host? - I recommend URLJet

                          Comment


                          • I know what you mean, it's just like sarcasm, it's not that easy to pick up and can be confusing unless conversing in person.

                            On another note I removed the hook disabler from the config file and obviously got the problem back, had a look in my plugins and realised that I forgot to disable 1 single custom plugin I made... d'oh! I can finally use the Blogs and CMS now properly.

                            To be fair that had to of been the easiest upgrade ever, and totally painless, only thing I had to change was having my sub domain redirect.

                            Comment


                            • Hello Everybody,
                              I have made the upgrade to RC 2 on a test board, on a dedicated server. I have made it, several times (8 times), always the same outcome. The test board, is not running any custom style. And the very few mods are all disabled before the update.
                              Here are the results, better described with images than words.

                              When I disable the plugins through the addition of " define('DISABLE_HOOKS', true); " into the config.php file every thing works just fine, except the sidebar that never shows even if enabled in the ACP options.



                              When I enable the plugins through the config.php and I am still logged in, here is what I get:



                              But if I try to log out or log in here is what I get:


                              So any help would be appreciated and Good Luck to everybody. And greetings to the VB team for this great board software.

                              Comment


                              • My upgrade wasn´t a great success... I have now restored my database. There is still some 4.0 files at my forum. It seems that i have to overwrite some blog files to get that work, but the question is that do I REALLY have to run upgrade script? Is that mandatory procedure after restore? Normal forum functions seems to work right now.

                                If I have to run upgrade script is it enought if I delete all files from install -folder, upload 3.8.4 files and then run that upgrade script?

                                What that update script is really doing if I have old 3.8.4 database and old 3.8.4 files?

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X