Announcement

Collapse
No announcement yet.

Specified key was too long

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Specified key was too long

    I'm doing a clean install of vB 4.2.5, into an empty database. I've uploaded the files and set up config.php. When starting the install, I've got this error message:

    An error has occurred with your database. Please contact vBulletin Support for assistance.
    Module: install, Step 2 Database Error:1071
    Specified key was too long; max key length is 767 bytes

    Query:
    CREATE TABLE vB_adcriteria ( adid INT UNSIGNED NOT NULL DEFAULT '0', criteriaid VARCHAR(250) NOT NULL DEFAULT '', condition1 VARCHAR(250) NOT NULL DEFAULT '', condition2 VARCHAR(250) NOT NULL DEFAULT '', condition3 VARCHAR(250) NOT NULL DEFAULT '', PRIMARY KEY (adid,criteriaid) )

    Can you point me in the right direction please? I have PHP 7.0 on Debian9 with 10.1.41-MariaDB

  • #2
    I should add that MariaDB was started with the following options set in mysql.cnf:
    --innodb-file-format=barracuda
    --innodb-file-per-table=ON
    --innodb-large-prefix=ON
    --innodb_default_row_format=DYNAMIC
    --default-character-set=utf8mb4
    --default-character-set=utf8mb4

    Comment


    • #3
      OK, I've found the options had not been loaded into MariaDB. I forced them in and I was able to complete the install. So really, this thread could be deleted.

      Comment

      Related Topics

      Collapse

      Working...
      X