Announcement

Collapse
No announcement yet.

Error doing upgrade from 4.2.3 to 4.2.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • garridge
    replied
    The problem was in the VSa module - Auto Birthday Greeter

    Leave a comment:


  • garridge
    replied
    I restored the blog, installed the version of php 7.1, it turned out to be updated, but now such errors appeared in the forum header

    PHP Warning
    : mktime() expects at most 6 parameters, 7 given in ..../includes/class_bootstrap.php(564) : eval()'d code on line 24

    PHP Warning: mktime() expects at most 6 parameters, 7 given in ..../includes/class_bootstrap.php(564) : eval()'d code on line 25

    Leave a comment:


  • garridge
    replied
    My ptoblem https://i.ibb.co/7XL3zYp/vbscreen3.jpgClick image for larger version  Name:	vbscreen3.jpg Views:	0 Size:	225.4 KB ID:	4423492

    Leave a comment:


  • MrCaspan
    replied
    Actually the problem was that the Blog was disabled and enabling it allowed me to do the upgrade!

    Leave a comment:


  • Mark.B
    replied
    Originally posted by Mattwhf View Post
    I am hoping vB team will update this version to run with PHP 7.2 because I am running on this version and it made some plugins error and I had to fix them.
    That won't happen I'm afraid. No further updates are planned for vB4, it is now end of life from a development perspective.

    Leave a comment:


  • Mattwhf
    replied
    vB 4.2.5 is designed for PHP 7.1 and it should run on this version.
    I am hoping vB team will update this version to run with PHP 7.2 because I am running on this version and it made some plugins error and I had to fix them.

    Leave a comment:


  • Wayne Luke
    replied
    You need to run at least PHP 5.6.30 to run 4.2.5. We recommend PHP 7.1.

    Leave a comment:


  • MrCaspan
    started a topic Error doing upgrade from 4.2.3 to 4.2.5

    Error doing upgrade from 4.2.3 to 4.2.5

    This is the error I get

    Code:
    Unexpected Text:
    <?xml version="1.0" encoding="windows-1252"?>
    <br />
    <b>Warning</b>:  mysqli_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' )
                )
                WHERE ipid IS NULL' at line 6 in <b>/home/mainnu/www/pf.main.nu/includes/class_core.php</b> on line <b>1386</b><br />
    <?xml version="1.0" encoding="windows-1252"?>
    <errors>
        <error><![CDATA[<p>Database Error</p>
    
    Invalid SQL:
    
                SELECT bt.userid, bt.dateline, blogtextid, ipaddress, firstblogtextid
                FROM blog_text bt
                JOIN blog bl USING (blogid)
                LEFT JOIN ipdata ip ON (
                    bt.ipaddress = ip.ipid AND bt.blogtextid  = ip.contentid
                    AND bt.userid = ip.userid AND ip.contenttypeid IN (, )
                )
                WHERE ipid IS NULL;
    
    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' )
                )
                WHERE ipid IS NULL' at line 6]]></error>
        <error_html><![CDATA[<p>Database error in vBulletin 4.2.5</p>
    <p>Invalid SQL:
    
                SELECT bt.userid, bt.dateline, blogtextid, ipaddress, firstblogtextid
                FROM blog_text bt
                JOIN blog bl USING (blogid)
                LEFT JOIN ipdata ip ON (
                    bt.ipaddress = ip.ipid AND bt.blogtextid  = ip.contentid
                    AND bt.userid = ip.userid AND ip.contenttypeid IN (, )
                )
                WHERE ipid IS NULL;<p>
    <p>
    <strong>MySQL Error</strong>   : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' )
                )
                WHERE ipid IS NULL' at line 6<br />
    <strong>Error Number</strong>  : 1064<br />
    <strong>Request Date</strong>  : Thursday, May 9th 2019 @ 07:11:18 PM<br />
    <strong>Error Date</strong>    : Thursday, May 9th 2019 @ 07:11:19 PM<br />
    <strong>Script</strong>        : http://pf.main.nu/install/upgrade.php<br />
    <strong>Referrer</strong>      : http://pf.main.nu/install/upgrade.php<br />
    <strong>Classname</strong>     : vB_Database_MySQLi<br />
    <strong>MySQL Version</strong> : 5.6.43<br />
    </p>]]></error_html>
    </errors>


    Any help would be appreciated and this is on a dev site

Related Topics

Collapse

Working...
X