Announcement

Collapse
No announcement yet.

Upgrade error from 4.2.2 to 4.2.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • user918
    replied
    Hi

    I have found the solution for my problem.
    From the www.vbulletin.com page I downloaded the tar archive.
    There are differences between the two files, the zip file is smaller, the tar archive is larger.
    The tar archive contains all necessary files to start the upgrade.
    On the first attempt the upgrade worked.
    That was the solution, so the thread is solved here
    After the upgrade, I can unfortunately not be lied into the admin area, but this is a theme for a new post in the forum.

    Leave a comment:


  • Paul M
    replied
    That warning must be coming from modified code as 4.2.5 doesnt use Split(), so you need to get it looked at by a developer, and fixed.

    Hiding warnings isnt a great idea as it will hide other errors as well.
    Split() has been removed completely in PHP 7, so if you upgrade, it will fail completely.

    Leave a comment:


  • Wayne Luke
    replied
    Turn off the display of Warnings in your PHP configuration.

    Leave a comment:


  • user918
    replied
    I enter my address http://die_domain.de/forum425/admincp And my admin login data and get the following message
    Code:
    [B]Warnung[/B]: Function split() is deprecated in [B]..../login.php[/B] (Zeile [B]177[/B])
    Can you help me?

    Leave a comment:


  • Mark.B
    replied
    If you are upgrading a test mirror, you need to make sure the URL settings in the AdminCP are updated before you start the upgrade. They need to point to the actual location of the forum you are upgrading.
    Last edited by Mark.B; Wed 31 May '17, 5:34am.

    Leave a comment:


  • user918
    started a topic [Forum] Upgrade error from 4.2.2 to 4.2.5

    Upgrade error from 4.2.2 to 4.2.5

    Hi,

    the zip file unpacked locally, all files uploaded from the "upload" folder.
    From Formu vb 4.2.2 the database is copied, in the /include/config.php the address is set to the copied database 4.2.2.
    The following Ardesse is called

    http://die_domain.de/forum425/install/upgrade.php

    When I call I get the following message:

    Code:
    Warning: require_once(/vb.php): failed to open stream: No such file or directory in /var/www/die_domain_de/html/forum425/includes/class_bootstrap_framework.php on line 99
    Fatal error: require_once(): Failed opening required '/vb.php' (include_path='.:/var/www/die_domain_de/php_includes:/usr/share/php:/var/www/globale_php_includes') in /var/www/die_domain_de/html/forum425/includes/class_bootstrap_framework.php on line 99
    At the end in the /forum425/includes/config.php the following code is added

    PHP Code:
    define('DISABLE_HOOKS'true); 
    How do I fix this? Your help is most welcome!
    Kind regards,



    Code:
    php --version
    PHP 5.6.30-1~dotdeb+7.1 (cli) (built: Jan 21 2017 14:50:59)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies
    
    mysql --version
    mysql Ver 14.14 Distrib 5.5.53, for debian-linux-gnu (x86_64) using readline 6.2
    
    
    apache2 -v
    Server version: Apache/2.2.22 (Debian)
    Server built: Feb 22 2017 15:50:12
    Best regards
    Last edited by user918; Wed 31 May '17, 10:43pm.

Related Topics

Collapse

Working...
X