Announcement

Collapse
No announcement yet.

upgrade from 4.2.4 to 4.2.5 problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oren Avraham
    replied
    thanks wayne adding mbstring in the host control pannel PHP Selector | extensions . fixed the problem .

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by Oren Avraham View Post
    this is the error i get . after upgrading


    Fatal error: Call to undefined function mb_detect_encoding() in /home/mydirectory/public_html/includes/functions.php on line 729
    You need to install the mb_string library in PHP. With a default installation of PHP, this is not installed. You need to contact the host.

    http://php.net/manual/en/mbstring.installation.php

    If you are using cPanel and the host allows you to switch your PHP Version, you can select this module on the PHP Version screen.

    Leave a comment:


  • Oren Avraham
    replied
    this is the error i get . after upgrading


    Fatal error: Call to undefined function mb_detect_encoding() in /home/mydirectory/public_html/includes/functions.php on line 729

    Leave a comment:


  • Mark.B
    replied
    Originally posted by Oren Avraham View Post
    for some how the error logs dont show anyting . when i upgrade . i can ssee the forum only when its set to off . when i turn it on . and try log in . it logs and then show blank page on firefox . and on explorer and other browsers will give 500 http server error .
    Have you uploaded ALL the 4.2.5 files? It's important to make sure they overwrite what is already there.
    It may also be worth downloading a fresh copy of the files.

    Leave a comment:


  • Oren Avraham
    replied
    for some how the error logs dont show anyting . when i upgrade . i can ssee the forum only when its set to off . when i turn it on . and try log in . it logs and then show blank page on firefox . and on explorer and other browsers will give 500 http server error .

    Leave a comment:


  • Mark.B
    replied
    4.2.5's main function is to provide php 7 compatibility. There are one or two minor bugfixes in it besides that, but nothing security related. 4.2.4 would still be patched in the event of a relevant security update anyhow.

    So the short answer is, no, you don't need to upgrade if you are on php 5.6, but you should probably set up a test mirror at some point and try to upgrade that, to see if you can nail the problem.

    Leave a comment:


  • Oren Avraham
    replied
    there only errors they sent me is
    client denied by server configuration: /home/xxxx/public_html/includes/vfchh/js/thanks_hide.js, referer: http://mysite.net/showthread.php/47633-xxx-com-x-x

    i dont think so its the right one .

    i will try to upgrade agian and check the error logs in the same time

    btw is
    is it necessary to upgrade from 4.2.4 to 4.2.5 ?

    does 4.2.5 has security updates that 4.2.4 dont have . thanks in advance

    Leave a comment:


  • Mark.B
    replied
    Originally posted by Oren Avraham View Post
    when i upgraded month back from 4.2.3 to 4.2.4 i didnt face any problems . only with this update . i face such issue . do i need to chang anyting in the config.php file or the htaccess file .

    since i had to restore back the 2.2.4 version back . not sure about the error logs . one error that keep showing there non stop is :


    [Mon May 29 17:20:12.805861 2017] [access_compat:error] [pid 82554] [client 171.233.198.76:49793] AH01797: client denied by server configuration: /home/mysitename/public_html/includes/vfchh/js/thanks_hide.js, referer: some posts


    vBulletin 4 does not use an .htaccess file unless you are using mod rewrite URLs.

    We need an error that specifically matches up to a time when you have seen the 500 error on the front end.

    Leave a comment:


  • Oren Avraham
    replied
    when i upgraded month back from 4.2.3 to 4.2.4 i didnt face any problems . only with this update . i face such issue . do i need to chang anyting in the config.php file or the htaccess file .

    since i had to restore back the 2.2.4 version back . not sure about the error logs . one error that keep showing there non stop is :


    [Mon May 29 17:20:12.805861 2017] [access_compat:error] [pid 82554] [client 171.233.198.76:49793] AH01797: client denied by server configuration: /home/mysitename/public_html/includes/vfchh/js/thanks_hide.js, referer: some posts



    Leave a comment:


  • Mark.B
    replied
    4.2.5 is not a buggy update. If it was, we'd have hundreds of customers reporting this issue.

    A 500 error is a server error. We would need to know the full error in order to investigate your issue further. This will be in your server logs (ask you host if unsure).

    Leave a comment:


  • Oren Avraham
    started a topic upgrade from 4.2.4 to 4.2.5 problem

    upgrade from 4.2.4 to 4.2.5 problem

    i did try today upgrade my forum from 4.2.4 to 4.2.5

    my current host info
    PHP Version 5.6.30
    MySQL Version 5.6.35
    after the installatin . page of my site looks fine . but when i enter my user name and pass . i am getting blank page . or 500 Internal Server Error

    depends the browsers i use . i can log in to control pannel . but i cant realy much function there as well .

    i did disable plug ins via admin cp and via config file . it didnt help at all . i did had to restore back my 4.2.4 version . 4.2.5 seems to be a buggy update . or i am just stupid . waiting for any suggestions . thanks

Related Topics

Collapse

Working...
X