Announcement

Collapse
No announcement yet.

Cannot upgrade Vbulletin 4.2.5 from php 5.6 to 7.0 or 7.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mark.B
    replied
    mod_security is nothing to do with firewalls and not something you can disable in config.php. It is server security software, and is not a part of vBulletin.

    As I said, you will need to speak to your host.

    Leave a comment:


  • roiarthur
    replied
    I can disable the firewall in my panel control, we will try it tomorrow
    Thanks

    Leave a comment:


  • roiarthur
    replied
    Yes i do have a firewall so if i had the line under <?php
    <?php
    define('DISABLE_HOOKS', true);
    I deactivate the firewall that should do it ?

    I will try that

    Leave a comment:


  • Mark.B
    replied
    You'll need to check with your host about mod_security.

    Leave a comment:


  • roiarthur
    replied
    I have this at the root of the server

    .ovhconfig

    app.engine=php
    app.engine.version=5.6
    http.firewall=security
    environment=production
    container.image=legacy
    I tried to replace it with

    app.engine=php
    app.engine.version=7.1
    http.firewall=security
    environment=production
    container.image=legacy
    Otherwise i don't see anything else

    Leave a comment:


  • Mark.B
    replied
    Do you have mod_security running on the server? You will need to ask your hosts.
    If they do, ask them to turn it off temporarily and see if that fixes the problem.
    Last edited by Mark.B; Sun 14th May '17, 2:03pm.

    Leave a comment:


  • roiarthur
    replied
    Not working still have the problem

    Leave a comment:


  • roiarthur
    replied
    OK i will try

    Leave a comment:


  • Mark.B
    replied
    Probably a modification that's not compatible with php 7.

    Please try the following:

    To disable the plugin/hook system completely, edit includes/config.php and add the following code:
    Just below
    Code:
    <?php
    enter
    Code:
    define('DISABLE_HOOKS', true);
    Do you still have the same problem?

    Leave a comment:


  • roiarthur
    started a topic Cannot upgrade Vbulletin 4.2.5 from php 5.6 to 7.0 or 7.1

    Cannot upgrade Vbulletin 4.2.5 from php 5.6 to 7.0 or 7.1

    I receive that message after updating php 5.6 to 7.1

    Method Not Implemented

    GET to /forum.php not supported.

    What can i do to upgrade PHP please ?

Related Topics

Collapse

Working...
X