Announcement

Collapse
No announcement yet.

upgrading 4.2.2 pl4 blew my website

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • upgrading 4.2.2 pl4 blew my website

    getting error after upgrading
    Warning: require_once(./includes/functions_navigation.php) [function.require-once]: failed to open stream: No such file or directory in ..../includes/functions.php on line 39

    Fatal error: require_once() [function.require]: Failed opening required './includes/functions_navigation.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/narisak1/public_html/includes/functions.php on line 39

    please help. Thanks in advance.


  • #2
    What version were you running before?
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.6 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      I'm getting the same error. We were running PL 2 and went to PL 4. Should I have done PL3 first and THEN PL 4?

      Fatal error: require_once() [function.require]: Failed opening required './includes/functions_navigation.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/oldtime/public_html/vb/includes/functions.php on line 39

      Comment


      • #4
        Were you already running 4.2.2? This is important.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.6 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Please download a full set of 4.2.2PL4 files and upload them to your site and run the upgrade.php script. Then see if you still have the same issue.

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools <- awesome site for html/css help

          Comment


          • #6
            Originally posted by Mark.B View Post
            Were you already running 4.2.2? This is important.
            Yes, been running 4.2.2 for about a year or so. We were on PL2 before copying up the PL4 files.

            Lynne, the PL4 files contained no upgrade.php script. The instructions stated that all that was needed was to copy the files up the server... after a backup of course.

            Comment


            • #7
              Did you download the full vb4.2.2pl4, or the patch? For some reason you seem to be missing at least one file that you should have already if you were running 4.2.2pl2. In any case, if you get the full 4.2.2pl4 and upload all the files, you should be able to fix that problem (assuming you have not made any changes to the vbulletin script files, of course).

              Comment


              • #8
                From the Members Area in the Patches/Security Patches area I downloaded and copied to the site the Security patch: 4.2.2 Suite PL4.

                Comment


                • #9
                  Originally posted by ProvokeMeOTG View Post
                  From the Members Area in the Patches/Security Patches area I downloaded and copied to the site the Security patch: 4.2.2 Suite PL4.
                  Download the full 4.2.2PL4 files not the patch from the members area and upload all the files except the install folder, see if that fixes things.

                  Comment


                  • #10
                    As I already said, please upload the FULL set of 4.2.2PL4 files and run the upgrade script. The upgrade script is NOT in the patch files, only in the full set.
                    Originally posted by Lynne View Post
                    Please download a full set of 4.2.2PL4 files and upload them to your site and run the upgrade.php script. Then see if you still have the same issue.

                    Please don't PM or VM me for support - I only help out in the threads.
                    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                    Want help modifying your vbulletin forum? Head on over to vbulletin.org
                    If I post CSS and you don't know where it goes, throw it into the additional.css template.

                    W3Schools <- awesome site for html/css help

                    Comment


                    • #11
                      Did this ever get resolved? I have a 4.2.2.PL1 site and want to go to PL4 to be current. I'm not going to do this unless I can feel reasonably safe that applying a simple patch will not crater the system.

                      Comment


                      • #12
                        I would say that not applying security patches is more likely to crater your system.

                        Just upload the files, it's no big deal.

                        You should always open your own thread as the OP was probably on version prior to 4.2.2 and you are not, so please ignore advice given to OP and just upload the patch files overwriting the existing ones.
                        Last edited by donald1234; Sun 14th Jun '15, 5:49am.

                        Comment


                        • #13
                          Originally posted by jnissen View Post
                          Did this ever get resolved? I have a 4.2.2.PL1 site and want to go to PL4 to be current. I'm not going to do this unless I can feel reasonably safe that applying a simple patch will not crater the system.
                          Your probably safe. I don't see the harm if you create a backup.

                          It seems that this guy was trying to upgrade his system and not just apply a patch. If your only applying a patch you'll be alright just make a backup anyway.
                          Last edited by Brad Padgett; Tue 16th Jun '15, 12:17am.

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X