Announcement

Collapse
No announcement yet.

Upgrading VBulletin from 4.2.0 to 4.2.2 level 4 Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrading VBulletin from 4.2.0 to 4.2.2 level 4 Problem

    Ive tried to upgrade my site last night and I've ran into this Problem when i started to run the upgrade.php

    nvalid SQL:

    SELECT value
    FROM ‘vb3_’setting
    WHERE varname = 'upgrade_from';;

    MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '€˜vb3_’setting
    WHERE varname = 'upgrade_from'' at line 2
    Error Number : 1064
    Request Date : Sunday, February 15th 2015 @ 08:10:29 PM
    Error Date : Sunday, February 15th 2015 @ 08:10:29 PM
    Script : http://www.*********/forums/install/upgrade.php
    Referrer :
    IP Address : ********
    Username :
    Classname : vB_Database
    MySQL Version : 5.5.40-36.1

  • #2
    Any Help!!!!! ????????

    Comment


    • #3
      Your table name is invalid as far as I can tell: FROM ‘vb3_’setting

      You shouldn't use UTF-8 in your table prefix in the config.php file.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API

      Comment


      • #4
        how can i fix this ?

        Comment


        • #5
          Change the table prefix in the config.php file so it is using ASCII characters.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #6
            Hi,
            patching up to 4.2.2 Patch 4 failed, backed off the patch to bring the forum online.

            I'm sure it's possible but if I keep my databases and tables etc, can't I rename the old forum directory and install 4.2.2. PL4 and use the same database?

            Can't find it on the forum but that would be optimal to keep all my user-generated data.

            Hoping for a response.
            Greg
            jfkrew.com

            Comment


            • #7
              Upgrading from 4.2.0 to 4.2.2 is not a patch. You need to download the FULL 4.2.2 PL4 package, upload ALL the files to the server, and run the upgrade script.
              You cannot just use the patch files, that is for people already running 4.2.2.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.6.3 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #8
                Sorry I got your terminology wrong.

                I am intending to do a clean install and restore my data because the patching process crashes the forum.
                Are you aware of a guide to restore forum content?

                Comment


                • #9
                  It's not about getting terminology wrong, it's about establishing whether you've gone through the right processes. As not doing so can easily cause the issues you're having.

                  If you are doing a clean install then that removes all content.

                  This is not the solution. Our patching/upgrade processes do not cause this issue, if they did we'd have thousands of customers reporting it.

                  I would recommend doing as I suggested in post number 7:
                  Download the FULL 4.2.2 PL4 package, upload ALL the files to the server, and run the upgrade script.
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.6.3 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #10
                    And we're done. Apologies for my inexperience. The upgrade went smoothly and thanks for your time.

                    jfKrew.com - a COD forum.

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X