Announcement

Collapse
No announcement yet.

Trouble with upgrading

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble with upgrading

    Hi, I seem to be unable to upgrade from 4.2.2 PL1
    I tried upgrading to PL3 about a week ago but was unsuccessful and am now having the same problem with PL4.

    I have uploaded the install directory as it says in the documentation and then visit /install/upgrade.php - enter my vB License and am then confronted with the following errors:

    Following is a list of files that are either missing or contain unexpected contents. The most likely cause is that all of the files from this release have not been properly uploaded. You should resolve this error before continuing.
    /includes/class_core.php - File does not contain expected contents
    /includes/init.php - File does not contain expected contents
    /install/functions_installupgrade.php - File version mismatch: found 4.2.2 Patch Level 4, expected 4.2.2 Patch Level 1
    etc etc etc.

    There is a file version mismatch on every file in the install directory, is this normal? Surely it should be expecting the PL4 files not PL1...

    The class_core.php and init.php error is also more concerning though as I have no idea what might be wrong with them? I have tried disabling all addons.

    Any ideas?

  • #2
    You just need to upload the patch files you don't need install folder

    Comment


    • #3
      The mismatched files, I believe are the patched files, that is because it is a security patch not an upgrade. Delete the install.
      Last edited by donald1234; Mon 12 Jan '15, 8:10am.

      Comment


      • #4
        Ok thank you that makes sense now!

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X