Announcement

Collapse
No announcement yet.

Permission issues after upgrading

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Permission issues after upgrading

    I upgraded from 4.1.x to 4.2.0 patch 2 and after overwriting my old forum files with the upgrades versions I instantly got internal error 500. Baffled by this I contacted my host and they told me the error logs stated something regarding the permission of multiple files where group was writable 755 instead of 775. After changing a bunch of the files to 775 I got the forum partially working however there are some features that just don't work such as mark forums read. Is there any reason the package had all incorrect permissions on pretty much every file and directory or am I missing something? I did nothing different when upgrading as I have done for the past 4 years.

  • #2
    Files permission have no relation to the package. It could be related to your server or the client FTP you use to upload these files.
    We always ask to make sure you upload these in ASCII format. Test the functionality in your default style, if you don't have one, then create it with no parent.
    Please feel free to contact me if you have any questions or concerns

    Links: vBulletin Manual - Code Documentation - FAQ - Bug Tracker - Lemon Juice
    vBulletin 5 Connect: Extensions - Articles - Features - Purchases

    Comment


    • #3
      Hi Abdulla, thanks for the reply. I'm not sure how I would upload in ASCII format, I did what I usually do and that is to download from here to my windows 7 based computer, and then I upload them through the file control panel on my webhost. I have always done this and never had this issue.

      Comment


      • #4
        It could be that your web host changed the default permission for uploading files to 755. Unusual, but it could happen.
        The better is to use 755 for folders and 644 for your files except of your style css files if you have store them as files make them 777

        Now you still can't mark forums as read? It could be a style issue.
        Please feel free to contact me if you have any questions or concerns

        Links: vBulletin Manual - Code Documentation - FAQ - Bug Tracker - Lemon Juice
        vBulletin 5 Connect: Extensions - Articles - Features - Purchases

        Comment


        • #5
          I'm not professional in this, but it did happen to me when I upload my forum files zipped/compressed using my control panel of my website and then uncompress them, the folders and fies permissions become incorrect.

          I don't remember the incorrect numbers now but every time I had to change the permissions individually it is a hard and tiresome work but I have to do it to continue the installation correctly. I would prefer uploading files through FTP console. Best wishes.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X