Announcement

Collapse
No announcement yet.

Help! - Error While Upgrading to 4.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Help! - Error While Upgrading to 4.2

    I received this error while upgrading 3.8 to 4.2.

    When it got to 4.1.10 alpha. I got this error. What does this mean? what do I do?

    PHP Code:
    Unexpected Text:

    <?xml version="1.0" encoding="windows-1252"?>
    <?xml version
    ="1.0" encoding="windows-1252"?>
    <errors>
        <error><=!=[=C=D=A=T=A=[<p>Database Error</p>

    Invalid SQL:
    DELETE FROM xxxxcnavigation WHERE productid = 'vbapi';

    Table 'xxxx_boards.xxxxcnavigation' doesn't exist]=]=></error>
        <error_html><=!=[=C=D=A=T=A=[<p>Database error in vBulletin 4.1.9</p>
    <p>Invalid SQL:
    DELETE FROM xxxxcnavigation WHERE productid = 'vbapi';<p>
    <p>
    <strong>MySQL Error</strong>   : Table 'xxxxc_boards.xxxxcnavigation' doesn't exist<br />
    <strong>Error Number</strong>  : 1146<br />
    <strong>Request Date</strong>  : Friday, May 25th 2012 @ 08:52:33 PM<br />
    <strong>Error Date</strong>    : Friday, May 25th 2012 @ 08:52:34 PM<br />
    <strong>Script</strong>        : http://forums.xxxx.com/install/upgrade.php<br />
    <strong>Referrer</strong>      : http://forums.xxxx.com/install/upgrade.php<br />
    <strong>Classname</strong>     : vB_Database<br />
    <strong>MySQL Version</strong> : 5.0.95-community-log<br />
    </p>]=]=></error_html>
    </errors>
    The upgrade has since been aborted automatically.

    PHP Code:
    Upgrading to 4.1.8Upgrading to 4.1.9 Beta 1Upgrading to 4.1.9Upgrading to 4.1.10 Alpha 1Step 1 Updating xxxcsetting table
    Step 2 
    Updating xxxxcsettinggroup table
                                          Status
    Aborted 

  • #2
    It looks like the cnavigation table does not exist. There is no default cnavigation table in vb 4.1.10 so it is added by a custom mod. Try to disable your plugins at the config.php file and see if that would make any difference.

    Comment


    • #3
      What happens if you run the upgrade again ?
      Baby, I was born this way

      Comment


      • #4
        If you are still getting this error, edit your includes/adminfunctions_plugin.php and find:
        PHP Code:
                $vbulletin->db->query_write("DELETE FROM " TABLE_PREFIX "navigation WHERE productid = '$productid'"); 
        Comment that line out, like so:
        PHP Code:
                // $vbulletin->db->query_write("DELETE FROM " . TABLE_PREFIX . "navigation WHERE productid = '$productid'"); 
        After running the upgrade, you should re-upload a fresh copy of that file from your 4.2.0 package.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X