Announcement

Collapse
No announcement yet.

HELP product uninstall has taken site down

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mark.B
    replied
    There is often more than one way to fix a problem....support staff will suggest what they consider to be the most suitable, that opinion may vary between support staff.

    Leave a comment:


  • Mary303
    replied
    I am confused that although the response was slower on the support ticket, this solution was not suggested. I'm confused that support gurus are not on the same page with the same problem.

    I think this thread was probably not the best idea I had to help find some good suggestions as quickly as possible.

    But thanks to those that made the effort, it's appreciated.

    Leave a comment:


  • Riasat
    commented on 's reply
    Go to phpmyadmin and select repair database. If you don't know what that is, ask your host.

  • Zachery
    replied
    We wouldn't tell you to run the upgrade script if it wasn't safe. It will reimport the default products, and reimport the master settings/files. It won't cause any harm.

    Leave a comment:


  • Mary303
    commented on 's reply
    ???

    If I've already upgraded to my current version, is it wise to run the same upgrade script again? What will it do?

    What do you think happened with the Panjo uninstall that needs the vB upgrade script run again?

  • Mark.B
    replied
    Download a fresh copy of the files from the member area, upload these to the server, and run the upgrade script again.

    Leave a comment:


  • Mary303
    replied
    Originally posted by Mark.B View Post
    Panjo is part of the default vBulletin installation and should not be uninstalled. If you don't wish to use it, leave it disabled.

    Where is this information in any instructions? No user is going to magically know this when they need to know it if the information hasn't been given to them ahead of time. The vB Manual instructions for uninstalling a product would be a place to include that, as well as the Panjo instructions, and neither says this.

    Also, I DO wish to use it. You seem to have missed a critical point that I thought I had uploaded the WRONG xml file. I never said I didn't want to use it, I said the opposite.

    Leave a comment:


  • Mark.B
    replied
    Panjo is part of the default vBulletin installation and should not be uninstalled. If you don't wish to use it, leave it disabled.

    Leave a comment:


  • Mary303
    replied
    Site went down again this morning on a database error. Has been referred to the server host, hopefully they can resolve it.

    Again, the FORUM url is not the .com, it's http://www.modelhorseblab.com/forums/forum.php
    If you access it and it appears to be working, I certainly hope so as with luck the host will be able to have it back online.

    Still need to understand why this is happening. I'm wondering if yesterday's outage happened at the uninstall out of coincidence, wasn't actually related. Was not in the admin cp when this outage occurred.

    I was able to capture this db error detail from the url web page ... right now that page is not providing this detail, though.

    Database error in vBulletin 4.2.1:

    Invalid SQL:
    REPLACE INTO ipdata
    (rectype, userid, contentid, contenttypeid, ip, altip, dateline)
    VALUES
    ('view', 600, 160297, 2, '107.77.64.23', '107.77.64.23', 1405772141);

    MySQL Error : Table './mary_mhb/ipdata' is marked as crashed and should be repaired
    Error Number : 145
    Request Date : Saturday, July 19th 2014 @ 01:15:41 PM
    Error Date : Saturday, July 19th 2014 @ 01:15:41 PM
    Script : http://www.modelhorseblab.com/forums...DIED&p=2513746
    Referrer : http://www.modelhorseblab.com/forums/usercp.php
    IP Address : 107.77.64.23
    Username : Mary
    Classname : vB_Database
    MySQL Version : 5.0.95


    == another db error ====================


    Database error in vBulletin 4.2.1:

    Invalid SQL:
    REPLACE INTO ipdata
    (rectype, userid, contentid, contenttypeid, ip, altip, dateline)
    VALUES
    ('view', 600, 160331, 2, '107.77.64.23', '107.77.64.23', 1405772122);

    MySQL Error : Table './mary_mhb/ipdata' is marked as crashed and should be repaired
    Error Number : 145
    Request Date : Saturday, July 19th 2014 @ 01:15:22 PM
    Error Date : Saturday, July 19th 2014 @ 01:15:22 PM
    Script : http://www.modelhorseblab.com/forums...is-a-new-thing
    Referrer : http://www.modelhorseblab.com/forums/usercp.php
    IP Address : 107.77.64.23
    Username : Mary
    Classname : vB_Database
    MySQL Version : 5.0.95

    Leave a comment:


  • Mary303
    replied
    Uninstalled product-panjo-v4.2.2.0.7.xml

    If someone is about to say that's the wrong version, let me pre-empt you by saying DOH. Because I already said I realized that and that's why I uninstalled.

    Here's a bit of the code ... I don't see edit icons to put quote brackets around it, too lazy to do vb's work for it and type it out.

    Panjo
    Classifieds integration that increases engagement, grows membership, and generates a new stream of revenue.
    4.2.2.0.7
    http://panjo.com

    if (($enthusify = $vbulletin->db->query_first(sprintf('SELECT `productid` FROM `%1$sproduct` WHERE `productid` = "%2$s"', TABLE_PREFIX, "enthusify"))) != false) { $queries = array( 'ALTER TABLE `%1$suser` CHANGE `enthusify_selling` `panjo_selling` TINYINT(1) NULL', 'ALTER TABLE `%1$susergroup` CHANGE `enthusify_can_sell` `panjo_can_sell` TINYINT(1) DEFAULT "1"', 'ALTER TABLE `%1$susergroup` CHANGE `enthusify_transaction_fee` `panjo_transaction_fee` DECIMAL(10, 2) NULL', 'ALTER TABLE `%1$susergroup` CHANGE `enthusify_listing_fee` `panjo_listing_fee` DECIMAL(10, 2) NULL', 'ALTER TABLE `%1$sthread` CHANGE `enthusify_listing_id` `panjo_listing_id` VARCHAR(255) NULL', 'ALTER TABLE `%1$slanguage` CHANGE `phrasegroup_enthusify` `phrasegroup_panjo` MEDIUMTEXT' ); if (version_compare(FILE_VERSION, '4.2.0', '>=') && version_compare(FILE_VERSION, '4.9.9', '<=')) { $queries[] = 'UPDATE `%1$snavigation` SET `productid` = "panjo" WHERE `productid` = "enthusify"'; } foreach ($queries as $query) { $vbulletin->db->query_write(sprintf($query, TABLE_PREFIX)); } require_once DIR . '/includes/functions_databuild.php'; build_forum_permissions(); if (($keys = preg_grep('/^(enthusify|panjo)_/', array_keys($vbulletin->options))) != false) { foreach ($keys as $key) { $vbulletin->options[str_replace('enthusify_', 'panjo_', $key)] = $vbulletin->options[$key]; } } delete_product('enthusify'); } if (true) { if (isset($arr)) { $src =& $arr; } else if (isset($document)) { $src =& $document; } if ((isset($src['navigation']) && !empty($src['navigation'])) && (version_compare(FILE_VERSION, '4.2.0', '>=') && version_compare(FILE_VERSION, '4.9.9', '<='))) { if (($navigation = $vbulletin->db->query_first(sprintf('SELECT * FROM `%1$snavigation` WHERE `productid` = "panjo"', TABLE_PREFIX))) != false) { foreach (array('displayorder', 'url', 'scripts') as $column) { $src['navigation']['tab'][$column] = $navigation[$column]; } if (version_compare(FILE_VERSION, '4.2.0', '<=')) { $active = NAV_ACTIVE; } else { $active = $vbulletin->bf_misc_navstate['active']; } $src['navigation']['tab']['active'] = intval

    Leave a comment:


  • Mark.B
    replied
    The actual error indicates that the MySQL server is unavailable at that point. What was the modification you uninstalled?

    Leave a comment:


  • donald1234
    replied
    I am sorry if my advice cased you to lose some posts but in my defence I did emphisise a recent backup. As for your database error, I relate that to the database not being able to connect due to incorrect password username/database name in config.php which is strange as some parts of your forum were accessable and some were not, anyway it seems I am not qualified to give advice on this forum so just ignore what I said and wait for expert advice.

    Leave a comment:


  • Mary303
    replied
    The .com url is NOT the forums. The forums are at http://www.modelhorseblab.com/forums/forum.php , as posted above.

    It seems the advice here is getting very confused, and that is not helpful to me. However, the feedback was certainly faster and more on point than the support ticket I opened. The support ticket responses are not on point ... that individual is also lost in events and urls, and not focusing on the real issues. Instead of reading the details of my ticket she seems to be trying to show me I am an idiot who doesn't even know my forum status. No help so far there.

    This site has over 2.5 million posts and the db is large. It is not a quick restore. The loss of a day's activity can be significant (as it is in this case).

    Events are moving forward - the site is not in the same state it was after the uninstall so looking at the url isn't going to tell anyone anything at this point.

    - The database has been restored and the site is back online.
    - I have lost Thursday's activity (and it was important) as part of the uninstall problem, due to doing the restore.

    It probably is a simple problem and I thought a few things I might try. But this site is very active and the users are grumbling. I have no experience with the Products & Plugins ... but it did look fairly point-and-shoot so I didn't anticipate this. So no idea exactly why it went bad.

    Here's the db error, now that I once again have access to the email (I didn't for awhile)
    Database error in vBulletin :

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    /var/www/vhosts/modelhorseblab.com/httpdocs/forums/includes/class_core.php on line 317

    MySQL Error :
    Error Number :
    Request Date : Friday, July 18th 2014 @ 03:36:28 PM
    Error Date : Friday, July 18th 2014 @ 03:36:28 PM
    Script : http://www.modelhorseblab.com/forums/forum.php
    Referrer : http://www.modelhorseblab.com/forums/forum.php
    IP Address : 173.96.92.38
    Username :
    Classname : vB_Database
    MySQL Version :
    from earlier


    Database error in vBulletin :

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    /var/www/vhosts/modelhorseblab.com/httpdocs/forums/includes/class_core.php on line 317

    MySQL Error :
    Error Number :
    Request Date : Friday, July 18th 2014 @ 02:52:36 PM
    Error Date : Friday, July 18th 2014 @ 02:52:36 PM
    Script : http://www.modelhorseblab.com/forums...-Finish-Corral
    Referrer :
    IP Address : 12.48.129.10
    Username :
    Classname : vB_Database
    MySQL Version :

    Leave a comment:


  • donald1234
    replied
    Originally posted by Paul M View Post

    Sorry, but that's terrible advice for what is almost certainly a very simple problem.
    I respect that you like to help, but please dont go telling people to take such drastic action without any firm evidence its necessary.

    I just visited the site and it seems to be running just fine, but as Wayne says, you need to post the actual database error before anyone can really help you.
    It only takes a couple of minutes to restore a backup to undo an obvious mistake as opposed to an error and if it's recent? but yea I take the hint.

    Leave a comment:


  • Paul M
    replied
    Originally posted by donald1234 View Post
    restoring a recent backup would be the easiest thing to do.
    Sorry, but that's terrible advice for what is almost certainly a very simple problem.
    I respect that you like to help, but please dont go telling people to take such drastic action without any firm evidence its necessary.

    I just visited the site and it seems to be running just fine, but as Wayne says, you need to post the actual database error before anyone can really help you.

    Leave a comment:

Related Topics

Collapse

Working...
X