Announcement

Collapse
No announcement yet.

503 Service Unavailable after upgrading to 4.2.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 503 Service Unavailable after upgrading to 4.2.2

    Edit: Ignore everything else after this post and skip straight to the end for what worked for me. Good luck!

    After upgrading to 4.2.2 earlier today, I attempted to edit an article, but every time I try to "save" or "apply" I get the following error message:

    503 Service Unavailable
    The server is temporarily busy, try again later! Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!

    I've tried to Google what this means and find a solution for it... but I admit, I'm lost.
    Last edited by dugchugger; Wed 30 Oct '13, 12:15am. Reason: to let other members looking for a fix to this same solution to skip to the end
    ~ duggy

  • #2
    Talk to your webhost about this..
    Simple Straight Forward EU cPanel vBulletin Web Hosting Provider.

    Comment


    • #3
      Was afraid of that. I've submitted a ticket. If they can help resolve this, I'll post the solution here as it may help someone else. Thanks for the quick reply WEBDosser.
      ~ duggy

      Comment


      • #4
        Was wondering if you could give me any tips on exactly what we're looking for here (me and the web host). We both came across the old post on these forums about switching from cookies to database for thread marking... but I'm already using that option so that doesn't really help. Any other suggestions would be greatly appreciated.
        ~ duggy

        Comment


        • #5
          The fact that I didn't have this issue until updating to 4.2.2 has me concerned. Do I really need to revert back to the previous version to get my forums up and running again?
          Last edited by dugchugger; Fri 25 Oct '13, 11:45pm.
          ~ duggy

          Comment


          • #6
            Could I please hear from someone from vBulletin on this comment made in this thread: http://www.vbulletin.com/forum/forum...-upgrade-error

            Originally posted by WEBDosser View Post
            What version PHP you got?. version vb4 is made for PHP 5.4
            I'm running PHP 5.3.14
            It's my understanding that vBulletin is being made more compatible with 5.4 but that previous versions (5.3x) should work fine. Pretty sure this was confirmed in the feedback thread by someone in the know.

            Like the member in the aforementioned post, I thought about trying to run the upgrade script again to see if this would resolve my issue. I'm reaching... but I'm at a loss as my host is telling me to contact vBulletin support about this.
            ~ duggy

            Comment


            • #7
              http://www.vbulletin.com/forum/forum...m-requirements

              Comment


              • #8
                First thing I would check is your PHP Error Logs- are any errors being recorded at the times you get the 503 message.

                It's saying the server is too busy - are there some sort of restrictions in place by your host on cpu or memory allowed? If so perhaps these restrictions are too low- perhaps they can relax them, even if only temporarily to confirm if that is the issue or not.

                Comment


                • #9
                  Thanks for the link tambo. I see that Wayne updated the file almost 2 weeks ago, so I'm confident this info is up to date. I am, however, a little concerned that the comment was made about vb4 being made for php5.4 and the vbulletin staff member who replied in that thread did not address this misinfo.

                  What concerns me more though, is that my forums were running fine with 4.2.1 and it wasn't until updating to 4.2.2. that this issue arose... and the reply from vBulletin Support this morning tells me that if I want any help fixing what 4.2.2 broke, I have to pay for it.

                  My host service has been trying to help me with this, but they've reached a dead-end and advised me to contact vBulletin Support. Any direction at all would have been greatly appreciated. I made the mistake of pre-purchasing vb5 Connect, but with all the bugs and complaints I've seen on these forums, I've been reluctant to install it. What a total waste of money. I wonder if vBulletin Support would consider reimbursing me for vb5 Connect in the form of support for vb4.

                  I've googled this issue until my eyes bled. It's beyond me. Totally disappointed with this product.
                  ~ duggy

                  Comment


                  • #10
                    Hi Joe!

                    I wasn't getting any logs as I think I had it set up incorrectly. Initially "Log PHP errors to a file" was set up with:

                    http://myforumname.com/errors/

                    I changed it to:

                    http://myforumname.com/errors/phperrors.log

                    The log file hasn't changed even though I've replicated the 503 Service Unavailable error. I've forwarded your advice to my host regarding restrictions. We looked into this a while back, but perhaps it's time to take a look at it again.
                    ~ duggy

                    Comment


                    • #11
                      Do you have any other sites on the server and are they up, have tried your site here http://www.downforeveryoneorjustme.com ? Generally 503 error means server is overloaded and us usually temporary. php 5.3 is ok with 4.2.2 although always best to upgrade if poss but most hosts wont as they have other sites that wont run on it.

                      Comment


                      • #12
                        Hi Donald.

                        No other sites are running on my end, and my site for all intents and purposes is running smoothly... with the exception of this "503 Service Unavailable" message whenever I try to edit an article. My host has advised that they do plan on upgrading to 5.4 in the not-too-distant future and that the only reason they haven't done this yet is, as you suggested, that their other customers would have issues. I'm waiting to hear back from them regarding Joe's suggestion.
                        ~ duggy

                        Comment


                        • #13
                          Was it a massive article you were trying to edit, mabye it's a php memory issue.

                          Comment


                          • #14
                            I've tried it with all size of articles, as well as in different browsers... cleaning cookies, cache, etc. in between. If I could just put my finger on what's changed since the update that might affect this, I might be able to get on the right track.
                            ~ duggy

                            Comment


                            • #15
                              As requested by support, I opened up another thread here regarding this same matter: 503 Service Unavailable after upgrading to 4.2.2

                              Here's the end result...

                              Originally posted by dugchugger View Post
                              This worked for me: http://www.vbulletin.com/forum/forum...-been-released

                              Honestly didn't think it was related. It was never suggested for my particular issue. Dammit... so it WAS a vbulletin issue from the 4.2.2 update and NOT my server.

                              Thanks to all who attempted to help.
                              *shakes head*
                              ~ duggy

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X