Announcement

Collapse
No announcement yet.

Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() ... on page domain.com/search.php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dominic
    replied
    Please see this post:
    http://www.vbulletin.com/forum/forum...66#post4000466

    Leave a comment:


  • semprot
    commented on 's reply
    i've updated my post... you can see it.

  • Swollen_Cranium
    commented on 's reply
    What "exactly" did you add or edit.

  • pretty.witch
    replied
    Originally posted by axefx View Post
    Same here after upgrade from 4.2.1 to 4.2.2 when calling search.php:

    Code:
    Warning: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupmessage.php on line 261
    
    Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupdiscussion.php on line 337

    Another one with the same problem:

    Tipo de Servidor Linux
    Servidor Web Apache (cgi-fcgi)
    PHP 5.3.26
    Versión de MySQL 5.0.96-community

    Leave a comment:


  • semprot
    replied
    So what is actually the solution for now? Using PHP 5.4?

    Edit: nvm i do file edit on class_core.php such as described here
    http://www.vbulletin.com/forum/forum...-been-released

    In class_core.php locate lines 5683-5685 (class_core.php is in the 'includes' folder)

    Code:
    case E_NOTICE:
        // Just ignore these completely //
    break;
    Add lines for Deprecated and/or Strict errors as required ;
    Code:
    case E_NOTICE:
    case E_STRICT:
    case E_DEPRECATED:
        // Just ignore these completely //
    break;
    This will bypass the additional error reporting.
    Last edited by semprot; Fri 11th Oct '13, 7:29pm.

    Leave a comment:


  • weave
    replied
    I am on 4.2.2, and 5.3 and I am not seeing this. Did I just get lucky?

    Leave a comment:


  • axefx
    replied
    Originally posted by Dominic View Post
    The issue is already logged in JIRA and will be fixed in the next version, which is dedicated to all PHP compatibility issues raised after 4.2.2.
    Perfect! Thanks for response!

    Leave a comment:


  • Dominic
    replied
    The issue is already logged in JIRA and will be fixed in the next version, which is dedicated to all PHP compatibility issues raised after 4.2.2.

    Leave a comment:


  • axefx
    replied
    No statements from the official support to this issue??? C`mon ... please ...

    Leave a comment:


  • axefx
    replied
    Originally posted by Pocket Aces View Post
    Is this a conflict between vb4.2.2 and PHP 5.3?
    Does anyone using PHP 5.4 experience this?
    Maybe, the problem is: My provider do not let me select a higher version ....IF this will be the problem ...

    Leave a comment:


  • Pocket Aces
    replied
    Is this a conflict between vb4.2.2 and PHP 5.3?
    Does anyone using PHP 5.4 experience this?

    Leave a comment:


  • axefx
    replied
    Same here after upgrade from 4.2.1 to 4.2.2 when calling search.php:

    Code:
    Warning: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupmessage.php on line 261
    
    Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupdiscussion.php on line 337
    PHP 5.3.10-1ubuntu3.8
    MySQL-Version 5.5.32-0ubuntu0.12.04.1

    Warning stays when set all plugins off.

    Not funny ... Is there a solution?

    Leave a comment:


  • Pocket Aces
    replied
    We have the same getLoadQuery() warnings from search.php or advanced search after upgrdaing form v4.2.1 to v4.2.2

    =====================================================

    Warning: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in /home/user
    /public_html/packages/vbforum/item/socialgroupmessage.php on line 261
    Date: Thursday 10th of October 2013 03:07:38 AM

    =====================================================

    Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in /home/user
    /public_html/packages/vbforum/item/socialgroupdiscussion.php on line 337
    Date: Thursday 10th of October 2013 03:07:38 AM

    =====================================================

    vbulletin 4.2.2 | PHP 5.3.27 | MySQL 5.5.32

    Leave a comment:


  • Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() ... on page domain.com/search.php

    on page http://example.com/search.php give this error after upgrade from 4.2.1 to 4.2.2 ..

    Code:
    Warning: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupmessage.php on line 261
    
    Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupdiscussion.php on line 337
    any solution for this problem ..?
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X