Announcement

Collapse
No announcement yet.

Warning: Only vaiables should be passed by reference in ..../newreply.php on line 389

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    I can't find the "$newpost['htmlstate'] = array_pop($array = array_keys(fetch_htmlchecked($vbulletin->GPC['htmlstate'])));" phrase on our site.
    The Vegan Forum

    Comment


    • #32
      Having the same issue with my newly upgraded forum...

      Comment


      • #33
        Originally posted by Goofy1 View Post
        We're having the exact same issue since upgrading to 4.2.2 this morning, has anyone found a fix for it yet?

        Edit - It only seemed to be happening in one forum section so i turned off HTML in there and it's fixed the issue for the time being. Be nice to get a 'real' fix though God i hate 'upgrades', they always seem to screw something up :lol:
        Try here....

        http://tracker.vbulletin.com/browse/VBIV-15858 and scroll down..


        Comment


        • #34
          After patching to 4.2.2 pl1, i now have this warning appearing constantly.

          suggestions of looking at the post http://tracker.vbulletin.com/browse/...#action_190615 are on the money - i needed to edit the newreply.php, replacing the line in the "if ($foruminfo['allowhtml'])" section to make the error messages go away.

          Notes on the error show it will be included in 4.2.3 version of vBull.

          Comment


          • #35
            Another issue since changing from 4.2.1 to 4.2.2 pl1 has emerged.

            now when i edit a post i get:

            Code:
            Database error in vBulletin 4.2.2:
            
            Invalid SQL:
            
                                REPLACE INTO subscribethread (userid, threadid, emailupdate, folderid, canview)
                                VALUES (21, 2818, , 0, 1);
            
            MySQL Error   : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 0, 1)' at line 2
            Error Number  : 1064
            Request Date  : Friday, July 4th 2014 @ 04:38:53 PM
            Error Date    : Friday, July 4th 2014 @ 04:38:53 PM
            Script        : http://www---/vbulletin/editpost.php?do=updatepost&p=10121
            Referrer      : http://www---/vbulletin/editpost.php?p=10121&do=editpost
            IP Address    : --.--.--.162
            Username      : a
            Classname     : vB_Database
            MySQL Version : 5.5.37-cll
            although the edit sticks, users get the full-on SQL error screen.

            following instructions to supress error messages by editing the config.php does not fix this.

            anyone?

            Comment


            • #36
              What did you actually do to "patch"?

              You cannot use the patch files to move from 4.2.1 to 4.2.2.

              If you were on 4.2.1, you must download the FULL 4.2.2 package, upload it to the server, and run the upgrade script.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.6.3 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #37
                I downloaded the 4.2.2 pl1 installation archive, and followed the usual procedure for an upgrade.. during the upgrade the script took me thru' the various stages between the 4.2.1 and latest 4.2.2 pl1 as per a normal upgrade - i say 'patch' to discriminate between moving from 4.2.1 to 4.2.2 non pl1. I'm aware of the difference between a patch and a full installation, having been using and modding vBulletin since v2. I Really regret moving from 3.x for this - it's been a constant battle to attain & sustain the reliability and functionality of 3.x.

                Also: supressing error messages is *not* a fix.

                Comment


                • #38
                  Originally posted by spring View Post
                  I downloaded the 4.2.2 pl1 installation archive, and followed the usual procedure for an upgrade.. during the upgrade the script took me thru' the various stages between the 4.2.1 and latest 4.2.2 pl1 as per a normal upgrade - i say 'patch' to discriminate between moving from 4.2.1 to 4.2.2 non pl1. I'm aware of the difference between a patch and a full installation, having been using and modding vBulletin since v2. I Really regret moving from 3.x for this - it's been a constant battle to attain & sustain the reliability and functionality of 3.x.

                  Also: supressing error messages is *not* a fix.
                  You are aware that vBulletin 2, and 3, both suppressed the errors right?

                  Comment


                  • #39
                    You are aware that vBulletin 2, and 3, both suppressed the errors right?
                    This information does not help - the problem exists now after moving from 4.2.1 to 4.2.2 pl1. It was not a problem before the change, now it is.

                    I'm going to go ahead and assume that the path now is to retrograde to 4.2.1 - is that fair?

                    Comment


                    • #40
                      It is not possible to "retrograde" ( I had to google that ) unless you have a backup to restore from.

                      It would be a lot easier to suppress php warnings (I assume that's what you are referring to) I know it is not a fix for the actual issue but it does hide them just as 4.2.1 does by default.

                      Comment


                      • #41
                        All you have to do is add one line to your config file:
                        define('SKIP_ALL_ERRORS', true);


                        Problems are solved.

                        Comment


                        • #42
                          As stated a few posts back - I already edited the config.php and added the line setting SKIP_ALL_ERRORS to true, this did not fix the 'invalid sql' database error bombs when editing a post.

                          Also, on an unrelated note given this instance is Ver 5, and not my server or whatever, while making *this* very reply (after switching to advanced editor), i get popup/overlays saying "Invalid server response.Please try again." - this is on vBulletin's OWN install of it's OWN product..

                          Comment


                          • #43
                            Originally posted by donald1234 View Post
                            It is not possible to "retrograde" ( I had to google that ) unless you have a backup to restore from.

                            It would be a lot easier to suppress php warnings (I assume that's what you are referring to) I know it is not a fix for the actual issue but it does hide them just as 4.2.1 does by default.
                            I do have a full backup, both of the file tree and the database as snapshots, so i can easily downgrade in that case, but i lose the activity since the backup ofc.

                            I should be clear on this, i _did_ make the edits to suppress the error messages, and the '...only variables should be passed...' error flash _did_ go away as expected, but then came the 'invalid sql' bombs when editing a post as seen here.. keep in mind, these bombs are fullscreen static errors, the board stops loading the thread with the post just edited - it does not flash up an error and keep going like the OT of this thread - it STOPS. If You reload the page it goes back to the editing state just before you posted the edit, and if you just go back to the forum index and open the thread again, you can see the edit was actually made properly after all.. kinda bizzare.
                            Last edited by spring; Fri 11 Jul '14, 2:11am.

                            Comment


                            • #44
                              Try disabling your plugins by adding this line to config.php and see if that helps.

                              Code:
                               
                               define('DISABLE_HOOKS', true);

                              Comment


                              • #45
                                Originally posted by spring View Post
                                As stated a few posts back - I already edited the config.php and added the line setting SKIP_ALL_ERRORS to true, this did not fix the 'invalid sql' database error bombs when editing a post.
                                Skip all errors only refers to non fatal php errors, fatal errors and any sql errors will still fail as normal.


                                Originally posted by spring View Post
                                Also, on an unrelated note given this instance is Ver 5, and not my server or whatever, while making *this* very reply (after switching to advanced editor), i get popup/overlays saying "Invalid server response.Please try again." - this is on vBulletin's OWN install of it's OWN product..
                                Not entirely sure what your point is here, we dont have some special magic version, an error can occur on this site just the same as on any other.

                                Baby, I was born this way

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X