Announcement

Collapse
No announcement yet.

Upgrading to 4.2.2 Alpha 1 Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrading to 4.2.2 Alpha 1 Issues

    Just finished upgrading and after the upgrade when I try to go to the forums or AdminCP I received the error below.

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../includes/functions.php on line 4912

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../includes/functions.php on line 5104

    Im running
    5.2.17 (which I cannot upgrade) so what would I need to add to the php.ini if needed?
    Last edited by scroush; Mon 23rd Sep '13, 10:13am.

  • #2
    I fixed the time issue by adding this date.timezone="America/New_York" to the PHP.ini file however now Im getting the errors below

    Warning: Declaration of vBCms_Item_Content::setItemId() should be compatible with that of vB_Model::setItemId() in ..../packages/vbcms/item/content.php on line 26

    Warning: Declaration of vBCms_Collection_Content::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbcms/collection/content.php on line 23

    Warning: Declaration of vBCms_Item_Widget::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbcms/item/widget.php on line 0

    Warning: Declaration of vBCms_Collection_Widget::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbcms/collection/widget.php on line 0

    Comment


    • #3
      Nothing you can add to php.ini, display_errors = Off wont get rid of that error either, report it as a bug with your version of php, apparently they missed some backward compatibility fixes.
      Gentoo Geek

      Comment


      • #4
        Found in another thread, I added:
        date.timezone="America/New_York"

        to my php.ini file and started apache and the error when away.
        Running php 5.2.17

        Comment

        Related Topics

        Collapse

        • geovadim
          Update errors
          by geovadim
          I am trying to update my forum vb3.7 to vb5 connect. I've copied the files from vb5 in a test forum and created a copy of the live database.

          PHP Version 5.4.38

          I went to upgrade...
          Mon 2nd Mar '15, 3:18am
        • avitor
          sitemap not shows
          by avitor
          why i get this when i try to view sitemap after build sitemap ?
          this message shows just after completed sitemap build
          Sitemap built successfully. You may view the XML here.
          and when
          ...
          Wed 3rd Feb '16, 4:57pm
        Working...
        X