Announcement

Collapse
No announcement yet.

config.php problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] config.php problems

    I am doing an initial installation of the latest version on a new domain, I keep getting this error and I dont know why:

    Due to the following errors, the install/upgrade can not continue:
    • The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the includes/config.phpfile
    • Error description: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) /home/content/41/8372941/html/forum/includes/class_core.php on line 314


    I only modified the four basic settings, including my email address, the username and password, and the database name which is the same as the username for GoDaddy accounts.

    Any tips?

  • #2
    looks like you have put in the wrong info

    Comment


    • #3
      You need to adjust the server for GoDaddy accounts as well. localhost does not work. You need a value like p23x.secureserver.net and different databases can be on different servers. In your GoDaddy control panel go to the section for your databases and click on the pencil icon to get the server information.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        use godaddy myself if u need help pm me

        Comment


        • #5
          So I went to the Hosting Control Center, clicked Databases, hit the pencil to get info, but it still tells me the database name and user name are the same, so I think they want something else for database name in config.php

          Comment


          • #6
            maybe i modded the wrong area let me check

            Comment


            • #7
              Yea so I fixed it, I worked on the right side of the equation, but I still get the error, let me ask you this, what is the difference between the database name and the master database username?

              Comment


              • #8
                A database name is the name of a server... either "localhost" an IP Address or something like xxx.myserver.com.

                Master database username is a Username you create to login to the database server and execute mysql queries.

                You also need to set a password for the username.

                Comment


                • #9
                  Originally posted by fredclarkjr View Post
                  So I went to the Hosting Control Center, clicked Databases, hit the pencil to get info, but it still tells me the database name and user name are the same, so I think they want something else for database name in config.php
                  Database name and user name are always the same on GoDaddy's servers.

                  You're looking for the Server Name or Host Name.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment


                  • #10
                    Thanks, so I got install to run, its been on 'Status: Processing XML, Step 4 of 6' for like 8 hours now. Should I do something, is it stuck?

                    Comment


                    • #11
                      Yes, better refresh the page and restart/continue the install. If it freezes for more than 15 minutes I'd say you should retry the install. Honestly on GoDaddy servers freeze ups during the install are pretty common in my experience.

                      Comment


                      • #12
                        Originally posted by Wayne Luke View Post
                        You need to adjust the server for GoDaddy accounts as well. localhost does not work. You need a value like p23x.secureserver.net and different databases can be on different servers. In your GoDaddy control panel go to the section for your databases and click on the pencil icon to get the server information.
                        Hi Wayne,
                        I have the same problem, but when trying to get the p23xsecureserver.net through the pencil ico appears something with different format: mydbname.db.xxxxxxx.hostedresource.com
                        I have tried whis this code without success.

                        Any help would be appreciated.

                        Comment


                        • #13
                          Make sure that your name of your database is correct. As what Wayne and BirdsofPrey5 have already said check that you have got your host's domain name is where localhost is.
                          Egosilentis don't put your database name as though it's an url. Just put the name of your host where localhost is and your database name (mydbname) where it says database
                          Aussiefootyforums

                          New Site New forum
                          Come and talk sports all day long


                          Comment


                          • #14
                            Originally posted by carntheroos4eva View Post
                            Make sure that your name of your database is correct. As what Wayne and BirdsofPrey5 have already said check that you have got your host's domain name is where localhost is.
                            Egosilentis don't put your database name as though it's an url. Just put the name of your host where localhost is and your database name (mydbname) where it says database

                            That´s exactly what I´ve done and does not work. Same error over and over again...
                            The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.



                            // ****** TECHNICAL EMAIL ADDRESS ******
                            // If any database errors occur, they will be emailed to the address specified here.
                            // Leave this blank to not send any emails when there is a database error.
                            $config['Database']['technicalemail'] = '[email protected]';

                            // ****** DATABASE NAME ******
                            // This is the name of the database where your vBulletin will be located.
                            // This must be created by your webhost.
                            $config['Database']['dbname'] = 'calipo';



                            // ****** MASTER DATABASE SERVER NAME AND PORT ******
                            // This is the hostname or IP address and port of the database server.
                            // If you are unsure of what to put here, leave the default values.
                            $config['MasterServer']['servername'] = '46.252.497.1';
                            $config['MasterServer']['port'] = 3306;


                            (I´ve tried everything on this, ´localhost´ , ´IP´ (as stated above) , this :mydbname.db.xxxxxxx.hostedresource.com (appears when I click the pencil to get information) etc...

                            // ****** MASTER DATABASE USERNAME & PASSWORD ******
                            // This is the username and password you use to access MySQL.
                            // These must be obtained through your webhost.
                            $config['MasterServer']['username'] = 'calipo';
                            $config['MasterServer']['password'] = 'XXXXXXXX';



                            Still does not work.

                            Comment


                            • #15
                              Unless GoDaddy lists an IP as the hostname, then you shouldn't use one. Especially if you're on a Windows server on GoDaddy's network. You should paste the exact string that they list for the hostname.
                              Translations provided by Google.

                              Wayne Luke
                              The Rabid Badger - a vBulletin Cloud demonstration site.
                              vBulletin 5 API - Full / Mobile
                              Vote for your favorite feature requests and the bugs you want to see fixed.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X