Announcement

Collapse
No announcement yet.

Mobile issue in 4.1.6 - forum home blank

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Suite] Mobile issue in 4.1.6 - forum home blank

    I upgraded to 4.1.6 and I'm having an issue with the mobile style. I deleted the old mobile style and installed the new 3 new mobile syle xml's.

    On my computer, I can view the mobile style but on my iPhone (3g), I can cannot view the main page but I can view everything else. The CMS, blog and I can view posts, search, etc... but not the homepage. I even turned off all my plugins globally and I still can't view on my iPhone.

    Also, If I do a diagnostic, I get...

    DD_belatedPNG_0.0.8a.js - File does not contain expected contents
    John
    diet support at diettalk.com

  • #2
    Does Safari show any errors?

    On your iPhone go to the Settings App. Tap Safari in that app. Scroll to the bottom. Tap Developer. Turn on the Debug Console.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      2x - Error on line 656 ... Unmatched </center> encountered. Ignoring tag.


      and a JavaScript Error line 17 - 1.61.min.js?v=416

      Which is this.
      <script type="text/javascript" src="http://www.diettalk.com/forums/clientscript/jquery/jquery-1.6.1.min.js?v=416"></script>
      John
      diet support at diettalk.com

      Comment


      • #4
        Hmm that isn't a file that we edit. Have you tried reimporting the mobile XML files? Weird that only the front page is blank.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          Yes, I removed them and reinstalled them 3 times without any luck.

          Sorry, I didn't finish the error before I posted. doh!


          JavaScript Error line 17 - 1.61.min.js?v=416
          JavaScript excution exceeded timeout.
          Last edited by diettalk; Wed 14th Sep '11, 12:35pm. Reason: doh
          John
          diet support at diettalk.com

          Comment


          • #6
            Bump.
            John
            diet support at diettalk.com

            Comment


            • #7
              That is the standard javascript file that we get from jQuery. We don't edit it.

              Do you have a link to your site?
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #8
                http://www.diettalk.com

                Why would I have an issue with 4.1.6 but not 4.1.5 mobile style with that javascript?
                John
                diet support at diettalk.com

                Comment


                • #9
                  4.1.6 includes a new version of the javascript than 4.1.5 did.

                  I am not getting any errors on your site when I select the mobile style. It appears you have it resolved or are you still seeing problems? If you are, than it is most likely caused by some modification that guest users don't have access to.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment


                  • #10
                    I'm still getting it whether or not I'm signed or not. Maybe it's a iPhone 3g issue? I've asked my users to check it with their phones to see if they what they get.
                    John
                    diet support at diettalk.com

                    Comment


                    • #11
                      Is your phone on iOS 4.3.4?
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud demonstration site.
                      vBulletin 5 API - Full / Mobile
                      Vote for your favorite feature requests and the bugs you want to see fixed.

                      Comment


                      • #12
                        No. 4.2.1.

                        I can view the mobile style on this forum.
                        Last edited by diettalk; Mon 19th Sep '11, 1:11pm.
                        John
                        diet support at diettalk.com

                        Comment


                        • #13
                          Same problem on my forum, users with iphone 3Gs told me about a blank page on the forum home page only.

                          I noticed on my android phone that the page is displaying ok, but is taking a long time to load, there is a kind of pause at some point and then the page finishes its loading process. So I suspect a problem with one of the script.

                          Comment


                          • #14
                            I get a blank page with Blackberry (latest OS version) as well.

                            If I connect with IE9 from my desktop and select the mobile style, it displays intermittently.

                            Not very impressive...

                            Also:

                            1. I don't understand why there are three separate mobile styles. What's that about and how are they used?

                            Found answer at: https://www.vbulletin.com/docs/html/...mobile_install but it still doesn't work

                            2. Should I be loading the mobile styles as child styles of the default or as independent "no parent" styles? I've tried it both ways and it didn't seem to make a difference - I get a blank page when mobile style is enabled either way.
                            Last edited by djbaxter; Sat 24th Sep '11, 7:53pm.
                            Psychlinks Web Services Affordable Web Design & Site Management
                            Specializing in Small Businesses and vBulletin/Xenforo Forums

                            Comment


                            • #15
                              Added: my Blackberry correctly loads the mobile style here at vbulletin.com so what am, I doing wrong in installing the mobile styles on my forum? It's installed on a subdomain in case that makes a difference.
                              Psychlinks Web Services Affordable Web Design & Site Management
                              Specializing in Small Businesses and vBulletin/Xenforo Forums

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X