Announcement

Collapse
No announcement yet.

Error Upgrading to 4.2.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bradynapier
    replied
    This makes me even more upset:
    Does vBulletin support PHP 5.4?


    vBulletin versions 3, 4 and 5 all support PHP version 5.4

    What are the system requirements for vBulletin?


    For vBulletin 5 Connect:

    Minimum Requirements: vBulletin is designed to run on every server that has PHP 5.3 or greater and MySQL 5.1.5 or greater installed. You must also have mod_rewrite, URL Rewrite or equivalent and you must upload the included .htaccess to your server.
    It is recommended to use PHP 5.4, or later and MySQL 5.5 or later.
    For vB4 Forum and vB4 Suite products:

    Minimum Requirements: vBulletin is designed to run on every server that has PHP 5.2 or greater and MySQL 4.1.0 or greater installed.
    It is recommended to use PHP 5.2.6, or later and MySQL 5.0.19 or later.
    The software has been successfully installed on several different flavors of UNIX, as well as Windows 98/NT/2000/XP, and the Mac.
    Note: We recommend you contact your hosting provider to verify that they have the correct versions of PHP and MySQL installed. If you administrate your own server, PHP and MySQL are available for free download from PHP.net and MySQL.com.
    Also you will need full permissions to the database in order to install and run vBulletin




    From your own FAQ: http://www.vbulletin.com/faq/#faq-125

    I will be requesting a refund. Where do you state ANYWHERE officially before I purchased this product that you do not support PHP 5.4?
    Last edited by bradynapier; Sat 10th Aug '13, 2:11pm.

    Leave a comment:


  • bradynapier
    replied
    Wow any updates on this? You really can't support 5.4? Have you guys spent ANY time on fixing this?

    This is so stupid... 5 is NOT ready for mainstream and you make 4 not compatible with all the amount of bugs in it ! My users can't even do line breaks... now I do the upgrade only to get tons of errors.... I PAID FOR THIS SOFTWARE - SUPPORT IT

    No wonder XenForo is taking all your business and you guys are suing... because you can't support your own product enough to keep your users...



    How about you guys update your compatibility information on the download page so I don't screw up my community of 50,000 customers when trying to fix the basic things that should be working in the first place:
    Note: vBulletin 3.6 - 3.8.x requires PHP 4.3.3 or greater and MySQL 4.0.16 or greater
    vBulletin 4.x requires PHP 5.2.0 or greater and MySQL 4.1.0 or greater
    vBulletin 5.x requires PHP 5.3.0 or greater and MySQL 5.1.5 or greater



    Where do I read "Not compatible with PHP 5.4" it simply says OR GREATER - this is B.S!
    Last edited by bradynapier; Sat 10th Aug '13, 1:28pm.

    Leave a comment:


  • wolfey
    replied
    I did this easy edit and it worked fine....just finished after previous php errors


    >>open ./includes/config.php
    add to top on next line after <?php
    PHP Code:
    // try to force display_errors off
    @ini_set('display_errors', false);


    >>open ./includes/class_core.php
    find
    $this->shutdown = vB_Shutdown::instance();

    replace with
    $this->shutdown [email protected] vB_Shutdown::instance();

    Leave a comment:


  • wswd
    replied
    Originally posted by Moshe1010 View Post
    OP, you need to edit the upgarde files in order for this to work. If you don't know how to, or have nobody to do it for you (try Elance.com), just ask from your host provider to downgrade you to PHP 5.3
    I am the hosting provider. Honestly, I'm just not in the mood for editing the upgrade files and working out the errors, when PHP 5.4 has been out now for almost 14 months. It's completely unacceptable and I've looked into other forum alternatives, to be honest. At this point, I don't really care if they fix it or not. I'm done.

    Leave a comment:


  • Calystos
    replied
    Any tips on what needs to be edited? Or a rough idea/guide?

    An yeah, I was thinking the same thing in regards to vb5 an so on. Anyone know if that even installs on PHP 5.4, lol. If not then thats yet another fail in their belt.

    I'd upgrade to 5 but we can't afford it just yet. And if this is the way things are going we may not bother.

    Leave a comment:


  • DoDeH1
    replied
    Let's hope we will get an update soon from vbulletin in order to address this matter. Especially if it gives us more then 30% boost.

    Leave a comment:


  • Moshe1010
    replied
    Originally posted by DoDeH1 View Post
    Are there many modifications to be done inside the upgrade files for the forum to work with php 5.4?
    It depends how many modifications you have done previously. It doesn't end with the upgrade files, you would probably get some errors later on. Editing upgrade files took about 3 minutes. Correcting PHP errors later on, took about 2 hours (but my board is heavily modified and most of the errors were because of that).

    Leave a comment:


  • DoDeH1
    replied
    Are there many modifications to be done inside the upgrade files for the forum to work with php 5.4?

    Leave a comment:


  • Moshe1010
    replied
    Originally posted by Calystos View Post
    Seriously? WHY? 5.4.x has been out for OVER A YEAR (March 2012, its now nearly May 2013!), and is by now pretty much standard. With 5.5.x being in beta since at least January. Our site has got vB 4.2.0 PL3, and has been running PHP 5.4 for ages without any problems. So whats the issue exactly? Why haven't you bothered supporting 5.4 yet? You've had over a year.
    Because they don't care for VB4 anymore and put all their resources in VB5. I also run PHP 5.4 with VB4 for a couple of months, and I just needed few adjustments to work it out. The speed difference is noticeable (~40%) and I would suggest everybody to change to PHP 5.4.

    OP, you need to edit the upgarde files in order for this to work. If you don't know how to, or have nobody to do it for you (try Elance.com), just ask from your host provider to downgrade you to PHP 5.3

    Leave a comment:


  • Calystos
    replied
    Seriously?

    WHY?

    5.4.x has been out for OVER A YEAR (March 2012, its now nearly May 2013!), and is by now pretty much standard. With 5.5.x being in beta since at least January.

    Our site has got vB 4.2.0 PL3, and has been running PHP 5.4 for ages without any problems. So whats the issue exactly? Why haven't you bothered supporting 5.4 yet? You've had over a year.

    Leave a comment:


  • wswd
    replied
    Okay, thanks.

    Leave a comment:


  • Trevor Hannant
    replied
    Compatibility is still planned, yes - I don't have a date for it though I'm afraid.

    Leave a comment:


  • wswd
    replied
    Originally posted by Trevor Hannant View Post
    No it doesn't.

    Yikes! I wasn't aware of that. Any chance compatibility will be happening anytime soon, considering 5.4 was released 13 months ago?

    Leave a comment:


  • Trevor Hannant
    replied
    No it doesn't.

    Leave a comment:


  • wswd
    replied
    No, I stand corrected. It's 5.4.10. Not sure when that update happened. Does the latest update not work with 5.4 yet?

    Leave a comment:

Related Topics

Collapse

Working...
X