Announcement

Collapse
No announcement yet.

Error Upgrading from 3.8.7 pl2 to 4.1.4 PL 2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Suite] Error Upgrading from 3.8.7 pl2 to 4.1.4 PL 2

    Trying to run a test upgrade on a copy of my live db and I'm getting what I think is a "duplicate entry for key 1" error. Addons are turned off and disabled. I have the error message in a file, but not sure if there is any sensitive data in it and would rather send it to someone privately if possible. I just checked and I am able to get into my admin cp, but I don't think the upgrade completed. If I try to rerun the upgrade, I keep getting the same error message

    Regards

  • #2
    Run Repair/Optimize on the database tables and see if the error goes away.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      tried that and it's still the same.

      It seems as if the upgrade did not complete. It was either up to the part with skimlinks or right after it. Everytime I try to rerun it I get an "action required" window with a long error message in it. I can forward it to you if it would help.

      When I go into my vbulletin options, the only settings choices in there are content management, mobile api and 6 different vbulletin blog: options

      Comment


      • #4
        You should be able to just post the message (do you see your password or something like that in there? I can't recall seeing an error that has personal information in it). But, if there is, feel free to PM it.

        Have you checked your error_logs from the time you did the upgrade to see if anything is in there?

        Have you made sure all the files are uploaded?

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help

        Comment


        • #5
          Hi Lynne,

          Yes, uploaded all files. I'll copy and paste the bottom of the "action required" window. I think there may be some api key's in the full text. I tried to pm it to you but it was too big. Lots of phrases seem to be missing and the default style looks like something from vb2.

          <strong>MySQL Error</strong> : Duplicate entry 'apikey' for key 1<br />
          <strong>Error Number</strong> : 1062<br />

          Comment


          • #6
            Can you try re-downloading the ZIP file from the Members Area and re-upload all files (except install/install.php and includes/config.php.new) making sure you overwrite all files currently on your server. Then re-run the upgrade script.

            Does this resolve the problem?
            Vote for:

            - *Admin Settable Paid Subscription Reminder Timeframe*
            -
            *PM - Add ability to reply to originator only*
            - Add Admin ability to auto-subscribe users to specific channel(s)
            - "Quick Route" Interface...

            Comment


            • #7
              it did not alleviate the problem. got the same error. I was trying to post it here, but the formatting keeps getting stripped when I use the code tags and it's unintelligible.

              Comment


              • #8
                Here's a copy of the error message that it keeps spitting back at me.

                error_edited.txt

                Comment


                • #9
                  The same error

                  I have the same error upgrading in my test installation!

                  Could it be something related with the mobile suite wich i have installed (but deactivate) in my 3.8.7 PL1?

                  Comment


                  • #10
                    You need to take a note of your API Key* then uninstall the Mobile API (not deactive - uninstall) then perform the upgrade.

                    *Very important...

                    Once you've upgraded, you'll need to replace the new key with the old API Key
                    Last edited by Trevor Hannant; Thu 28 Jul '11, 2:48am.
                    Vote for:

                    - *Admin Settable Paid Subscription Reminder Timeframe*
                    -
                    *PM - Add ability to reply to originator only*
                    - Add Admin ability to auto-subscribe users to specific channel(s)
                    - "Quick Route" Interface...

                    Comment


                    • #11
                      Before you do that, make a note of your apikey.
                      Baby, I was born this way

                      Comment


                      • #12
                        Maybe something that should be added to the readme file for upgrading? Just a thought...

                        edit: OMG, these smilies are horrible, it looks like someone hit that one in the head with a hammer.....repeatedly.....

                        Comment


                        • #13
                          Originally posted by mrderanged View Post
                          Maybe something that should be added to the readme file for upgrading? Just a thought...
                          Its an issue that needs addressing.
                          The upgrader needs to take into account if the vb3 api is installed, it should just do this silently, no need for any readme.
                          Baby, I was born this way

                          Comment


                          • #14
                            Everything is ok now.

                            Thanks!

                            Comment


                            • #15
                              Oh, I agree Paul It's just that in the meantime, maybe there should be a little note? As it is now, I need to restore my db and files so I can uninstall the api and retest the upgrade because this wasn't mentioned....

                              Originally posted by Paul M View Post
                              Its an issue that needs addressing.
                              The upgrader needs to take into account if the vb3 api is installed, it should just do this silently, no need for any readme.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X