Announcement

Collapse
No announcement yet.

How does one upgrade from vBulletin 3.8.7 to the latest version of 4.1?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] How does one upgrade from vBulletin 3.8.7 to the latest version of 4.1?

    I can't seem to find any tutorials or information! I'm aware I'll need to get new plugins and themes although I want to keep my forums, users, threads, posts, usergroups, paid subscriptions etc.

  • #2
    Note: vBulletin 4.x.x uses a new Template and Stylevar engine. This means your previous styles are not compatible with vBulletin 4.x.x. When you upgrade, they will be disabled and a new style will be created and set as the default style.

    Close your board via the Admin Control Panel.

    Upload all files from the 'upload/' folder in the zip, with the exception of 'install/install.php'. Then open the 'upload/includes/' folder.

    Open your browser and point the URL to http://www.example.com/forum/install/upgrade.php (where www.example.com/forums/ is the URL of your vBulletin). You should now be automatically forwarded to the appropriate upgrade script and step.

    If any errors occur, copy the error and please contact support. DO NOT continue with the upgrade. Doing so may cause irreversible damage to the database.

    Follow the instructions on the screen. Make sure you click next step or proceed until you are redirected to your Admin Control Panel. Here, you can reopen your board.

    For a complete description of how to upgrade from a previous version of vBulletin to the latest version, see the upgrade section of the vBulletin Manual.
    from the vb readme file

    Comment


    • #3
      Here is all the documentation we have regarding upgrading vBulletin:

      http://www.vbulletin.com/forum/conte...rade-Procedure
      http://www.vbulletin.com/forum/conte...e-Instructions
      http://www.vbulletin.com/forum/conte...-vBulletin-4-0
      http://www.vbulletin.com/docs/html/upgrade/
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment

      Related Topics

      Collapse

      Working...
      X