Announcement

Collapse
No announcement yet.

Aborted Upgrade 3.8.7>4.1.3 "Could not create file system directory to hold your att

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • parm775
    replied
    Originally posted by Steve Machol View Post
    That is a relative directory, not the full path. As I said if you did this with the correct directory, then the problem is a server issue. Next step is to contact your host.
    Which is the correct directory? if its not standard with every forum then how do I find out which directory I need to change permissions for. I have read every single thread related to this issue and everything ends with your staff doing it via ssh but none of you have ever posted about what you exactly do.
    I have alse created a ticket a few hours ago which is yet to be replied to but wouldnt it be nice to have this issue included in the manual somewhere or list out the requirements? I screwed up my live forum last night and had to roll back and now I am trying to upgrade using a test forum which I had to create thanks to no info on how to sort this out. Unfortunately not all of us are techies and some of us need more detailed instructions to go about our business.

    Leave a comment:


  • Steve Machol
    replied
    That is a relative directory, not the full path. As I said if you did this with the correct directory, then the problem is a server issue. Next step is to contact your host.

    Leave a comment:


  • Ocean44
    replied
    According to the AdminCP of my active forum.
    "Attachments are currently being stored in the filesystem at ./attachments"
    (I'm working a test site for the upgrade which started as a copy of my active site.)

    Leave a comment:


  • Steve Machol
    replied
    Are you sure you did this to the correct directory? If so, then the next step is to contact your and ask them to look into this. It's a system error.

    Leave a comment:


  • Ocean44
    replied
    I was able to do chmod -R 777 attachments by SSH.

    When I look at the /attachments directory it shows as 777 and every sub-directory and every file also shows as 777.
    I have also toggled from 777 to 755 and back to 777 (/attachments and all subs)
    but still when I run the Upgrade System, it stops at Step 89 with the error:
    <error>Could not create file system directory to hold your attachment.</error>

    Is there anything else I can check or try?

    Leave a comment:


  • Steve Machol
    replied
    Not that I'm aware of, no. This will probably require shell access.

    Leave a comment:


  • Ocean44
    replied
    Is there any way to do the -R with my FTP (ws_ftp) or Control Panel (plesk)?

    I see no option for that, only the ability to set permissions by ### or checkboxes.

    Leave a comment:


  • Steve Machol
    replied
    You need to chmod that directory recursively, i.e.,

    chmod -R 777 attachment_directory

    Leave a comment:


  • Aborted Upgrade 3.8.7>4.1.3 "Could not create file system directory to hold your att

    Hi -

    During the upgrade it aborted at step 89 with the error:
    <?xml version="1.0" encoding="windows-1252"?>
    <?xml version="1.0" encoding="windows-1252"?>
    <error><![CDATA[Could not find phrase 'upload_file_system_is_not_writable_path'.]]></error>

    So I set the /attachments directory and all sub-dirs to 777 and then refreshed the upgrade system.

    Again it stopped at step 89 with a slightly different error:
    <?xml version="1.0" encoding="windows-1252"?>
    <?xml version="1.0" encoding="windows-1252"?>
    <error>Could not create file system directory to hold your attachment.</error>

    I double checked the 777, it is OK.

    How do I proceed?

    Thanks.

Related Topics

Collapse

Working...
X