Announcement

Collapse
No announcement yet.

Can you upgrade older vB3 directly into vB4?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Can you upgrade older vB3 directly into vB4?

    I'm currently running vB3.6.7, but have a license for vB4 CMS. Given that my vB3 is a few versions behind, is there a recommended upgrade order in order to best upgrade to vB4? Should I upgrade to the most current vB3 first or can I upgraded directly into vB4?

  • #2
    You can still upgrade to vB 4 the same way you would any other version. Make sure you disable any and all modifications though, and you vB 3 styles will not be compatible with vB 4
    "Our greatest weakness lies in giving up. The most certain way to succeed is always to try just one more time!"
    "It's important to only think about what you desire, not what you fear to achieve your ultimate goal!!"
    "When doors close, tear down the walls. Never give up!"

    Comment


    • #3
      Take a backup, and run the upgrade sripts. The should carry you to 4.1.2 by themselfs. If you run into any problems, contact support.

      PLEASE backup, there is no "downgrade" script . The only way to go back if something bad happens is if you restore a backup.

      Comment


      • #4
        Regarding this process, my host is currently running PHP4. I've tested PHP5 and this older version of vB doesn't run on that. So should I upgrade up to the latest vB3 install, throw the switch for PHP5, and then upgrade to vB4?

        Otherwise, if I move to PHP5 now, my current vB3 install won't work. Does that matter in the upgrade process?

        Comment


        • #5
          the vB4 upgrader won't run if the version of PHP is insufficient. Backup your database and files, upgrade to 3.8.7, backup again then upgrade PHP. Once this is done, do the upgrade to vB4.
          Vote for:

          - *Admin Settable Paid Subscription Reminder Timeframe*
          -
          *PM - Add ability to reply to originator only*
          - Add Admin ability to auto-subscribe users to specific channel(s)
          - "Quick Route" Interface...

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X