Announcement

Collapse
No announcement yet.

3.8.4 -> 4.1.2 Upgrade Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] 3.8.4 -> 4.1.2 Upgrade Problems

    Today I upgraded my forum from 3.8.4 to 4.1.2.

    Before the upgrade I closed my forum and disabled the plugin/hook system. I ran the upgrade system and it worked its magic. Now on my forum there are many errors.

    Code:
    Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: cv_ffl_rss_button_in_footer in [path]/includes/functions.php on line 4097
    
    Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: welcome_headers in [path]/includes/functions.php on line 4097
    
    Parse error:  syntax error, unexpected T_STRING in /home/webtalkf/public_html/includes/class_core.php(4430) : eval()'d code on line 102
    
    Parse error:  syntax error, unexpected '<' in /home/webtalkf/public_html/includes/class_core.php(4430) : eval()'d code on line 255
    And when I try to login to the admin panel, I get this:

    Code:
    vBulletin Message
     
                               Unable to add cookies, header already sent.
    My site is
    Code:
    www.WebTalkForums.com
    Any help is appreciated.

    Edit: If this helps. This is what is on line 4097 of my functions.php file:

    Code:
        trigger_error('fetch_template() calls should be replaced by the vB_Template class. Template name: ' . htmlspecialchars($templatename), E_USER_WARNING);
    The only thing on line 255 of my class_core file is a *
    Last edited by Reizar; Thu 17 Feb '11, 3:02am.

  • #2
    eval()'d code errors come from modificatiosn or incompatible styles. Make sure you still have the plugin system disabled via config.php then disable all plugins via AdminCP > Plugins & Products > Manage Products. Also check the Plugin Manager for anything that's been added there that isn't part of a Product.

    Once you've disabled everything, you can remove the line from the config.php file. Then you need to upgrade any add-ons you have to versions that are compatible with vB4.
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      Thanks,

      I added
      define('DISABLE_HOOKS', true);

      to my config.php file and its seemed to clear all my errors up.

      Comment


      • #4
        I re enabled plugins and of course was swamped with errors on the homepage. I started disabling and uninstalling plugins and now have all my plugins disabled. But yet have this error on the main page.


        Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: squares_and_text_links in [path]/includes/functions.php on line 4097

        Parse error: syntax error, unexpected T_STRING in /home/webtalkf/public_html/includes/class_core.php(4430) : eval()'d code on line 33

        No plugins are activated, but yet its still giving this error. Any idea how to fix it?

        Comment


        • #5
          You have a Style that's not compatible with vB4. Line 4430 of class_core.php is this:

          Code:
                      eval($template_code);
          So something in a template is causing this. Delete all incompatible styles and make sure you're only using the default style. Do you still have these errors?
          Vote for:

          - *Admin Settable Paid Subscription Reminder Timeframe*
          -
          *PM - Add ability to reply to originator only*
          - Add Admin ability to auto-subscribe users to specific channel(s)
          - "Quick Route" Interface...

          Comment


          • #6
            Originally posted by Trevor Hannant View Post
            You have a Style that's not compatible with vB4. Line 4430 of class_core.php is this:

            Code:
                        eval($template_code);
            So something in a template is causing this. Delete all incompatible styles and make sure you're only using the default style. Do you still have these errors?
            I deleted my custom theme and on the default vb4 theme I am still getting these errors.

            I am also getting these errors when I try to view a thread:

            Code:
            Parse error:  syntax error, unexpected T_STRING in /home/webtalkf/public_html/includes/class_core.php(4430) : eval()'d code on line 102
            
            Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: drink in [path]/includes/functions.php on line 4097
            
            Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: beer in [path]/includes/functions.php on line 4097
            The drink and beer errors I think are coming from a buy me a drink plugin. However that plugin is not active on the site which is whats weird.

            All plugins are currently disabled, ( plugin system is enabled though ).

            Comment


            • #7
              If these are old vB3 plugins, I'd recommend that you either:

              - upgrade them to vB4 versions or
              - uninstall them and then remove all the relevant files from your server

              Sometimes the files still get called causing these errors.
              Vote for:

              - *Admin Settable Paid Subscription Reminder Timeframe*
              -
              *PM - Add ability to reply to originator only*
              - Add Admin ability to auto-subscribe users to specific channel(s)
              - "Quick Route" Interface...

              Comment


              • #8
                Heres a list of things I just recently did.

                - Deleted custom style.
                - Made Default vb4 theme default style.
                - Uninstalled ALL plugins.
                - Double checked in my DB and dropped tables of plugins that were still there.
                - Deleted all files and then uploaded the generic vb4 files from a fresh download from members area.

                - My forum is using the default vb4 theme, has no plugins installed and has only the core vbulletin files.

                Yet im still getting these errors. ( 1 error has changed. The errors I am now getting are: )

                FORUMHOME:
                Code:
                Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: squares_and_text_links in [path]/includes/functions.php on line 4097
                
                Warning: array_merge() [function.array-merge]: Argument #1 is not an array in [path]/includes/class_bootstrap.php(1312) : eval()'d code on line 13


                View Thread:

                Code:
                Warning: array_merge() [function.array-merge]: Argument #1 is not an array in [path]/includes/class_bootstrap.php(1312) : eval()'d code on line 13
                
                Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: drink in [path]/includes/functions.php on line 4097
                
                Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: beer in [path]/includes/functions.php on line 4097

                Comment


                • #9
                  Thers is no fetch_template function in vB4. Those errors are either from add-ons or bad files. You cannot get that error if you followed alll the steps you outlines.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    This thread can now be closed. I hired someone to fix the problems and he managed to do so. Turns out it was some problems with PHP5.

                    Comment


                    • #11
                      I can promise you, you had third party addons or bad vBulletin 3 files, it was not a PHP 5 problem.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X