Announcement

Collapse
No announcement yet.

Error After Upgrade, 3.8.6 to 4.1.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • reefland
    replied
    Glad to hear you got it worked out. Good luck with the rest of your upgrade!

    Leave a comment:


  • ★Jigsaw
    replied
    @Lynne that's what I have just done for the config.php (post 6) and I did say I could not access my AdminCP nor the Forum (post 10).

    @reefland Couldn't find plugins in phpMyAdmin but you're second answer did help, the config.php file was from 3.8.x and i guess it needed the one from the download package and did successfully disable the modifications via config.php. So very big thanks to you +1 Rep.

    Thanks for the help Steve, Lynne and reefland I appreciate it .

    Leave a comment:


  • reefland
    replied
    You could use phpmyadmin to edit the plugins. In the plugin table, set active = 0 for any modification plugins. Or you could set them all to 0 and then re-enable the default ones via the admincp.

    Seems like a long way around though. Did you use a new config file? Grab the one from the download package, make the normal edits and then add the disable hooks line as described.

    Leave a comment:


  • Lynne
    replied
    If you use a plain text editor and edit the config.php file to add that line, then you should not be having any problems.

    You can try disabling the plugins via AdminCP > Settings > Options > plugins & products > enable plugins > no, if you can login to your admincp.

    Leave a comment:


  • ★Jigsaw
    replied
    So how can I remove/upgrade the modifications I don't have access to the forum nor admincp.

    Leave a comment:


  • Steve Machol
    replied
    Yes, eval() errors are always due to modifications - templates, add-ons or plugins.

    Leave a comment:


  • ★Jigsaw
    replied
    I have upload all vBulletin files via cPanel but I recieved the same error, I then uploaded via FTP and encountered the same error again. The error is showing because I added define('DISABLE_HOOKS', true); in config.php but when I remove it i recieve the error
    Code:
    array_merge() [function.array-merge]: Argument #1 is not an array in [path]/includes/class_bootstrap.php(1309) : eval()'d code on line 29
    
    array_merge() [function.array-merge]: Argument #1 is not an array in [path]/includes/class_bootstrap.php(1309) : eval()'d code on line 40
    
    
    so it must be a modification error right?, Is there anyway I can disable the modifications via root folder?

    Leave a comment:


  • Lynne
    replied
    Usually when it says call to undefined this-or-that, it's because the file containing that item is not uploaded correctly. So, make sure you uploaded all your files correctly and completely.

    Leave a comment:


  • ★Jigsaw
    replied
    Well the problem is to do with the modifications, I can't seem to access my forum never-mind the AdminCP so am unable to update/remove the modifications. I just added define('DISABLE_HOOKS', true); directly below <?php in the config.php file and removed any unnecsiry spaces on line 1, it seems to have worked however I am now reciving the error message 

    Code:
    Call to undefined method stdClass::set() in /home/wa/public_html/includes/functions.php on line 7326

    Leave a comment:


  • Steve Machol
    replied
    That error means you have a problem in your config.php file, either a blank space or line at the beginning of the file or it was not saved correctly as a text file.

    Leave a comment:


  • Lynne
    replied
    Did you use a plain text editor?

    Leave a comment:


  • ★Jigsaw
    replied
    Originally posted by Mark.B View Post
    That's from a 3.8 modification. You'll need to disable all modifications and get the vb4 versions of them (if they have been converted). Or attempt the conversion yourself.
    I added
    PHP Code:
    define('DISABLE_HOOKS'true); 
    in config.php just directly below <?php But i then got a blank page saying....
    Code:
    Unable to add cookies, header already sent.
    File: /home/wa/public_html/includes/config.php
    Line: 1

    Leave a comment:


  • Mark.B
    replied
    That's from a 3.8 modification. You'll need to disable all modifications and get the vb4 versions of them (if they have been converted). Or attempt the conversion yourself.

    Leave a comment:


  • ★Jigsaw
    started a topic [Forum] Error After Upgrade, 3.8.6 to 4.1.1

    Error After Upgrade, 3.8.6 to 4.1.1

    The upgrade did go as plan but now on the header of my forum it shows,
    Code:
    Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: waresub_display_inc in [path]/includes/functions.php on line 4055
    
    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in [path]/includes/class_bootstrap.php(1309) : eval()'d code on line 29
    
    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in [path]/includes/class_bootstrap.php(1309) : eval()'d code on line 40
    
    Unable to add cookies, header already sent.
    File: /home/wa/public_html/includes/class_core.php
    Line: 5317
    Fatal error:  Call to a member function hide_errors() on a non-object in /home/wa/public_html/includes/class_bootstrap.php(412) : eval()'d code on line 264
    How can i fix this problem?
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X