Announcement

Collapse
No announcement yet.

Upgrade to 4.1 PL2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Suite] Upgrade to 4.1 PL2

    I'm getting this below. I've tried disabling all plugins, specifically vBSEO, still get this:

    Code:
    internal error on line 426 in /u/sites/ftg/webroot/includes/class_upgrade_product.php
    #0 /u/sites/ftg/webroot/includes/class_upgrade_product.php(488): vB_Upgrade_Product->import_dependencies()
    #1 /u/sites/ftg/webroot/install/includes/class_upgrade_vbblog.php(78): vB_Upgrade_Product->verify_install('vbblog')
    #2 /u/sites/ftg/webroot/install/includes/class_upgrade.php(358): vB_Upgrade_vbblog->__construct(Object(vB_Registry), Array, '4.1.0')
    #3 /u/sites/ftg/webroot/install/includes/class_upgrade_ajax.php(312): vB_Upgrade_Abstract->load_script('vbblog')
    #4 /u/sites/ftg/webroot/install/includes/class_upgrade_ajax.php(176): vB_Upgrade_Ajax->begin_upgrade('410b1', 0)
    #5 /u/sites/ftg/webroot/install/includes/class_upgrade.php(298): vB_Upgrade_Ajax->init(NULL)
    #6 /u/sites/ftg/webroot/install/includes/class_upgrade_ajax.php(80): vB_Upgrade_Abstract->__construct(Object(vB_Registry), Array, 'upgrade')
    #7 /u/sites/ftg/webroot/install/includes/class_upgrade.php(49): vB_Upgrade_Ajax->__construct(Object(vB_Registry), Array, 'upgrade', NULL)
    #8 /u/sites/ftg/webroot/install/upgrade.php(44): vB_Upgrade::fetch_library(Object(vB_Registry), Array, '', true)
    #9 /u/sites/ftg/webroot/vbseo.php(1392): require('/u/sites/fgt...')
    #10 {main}
    
    
    Fatal error: internal error on line 426 in /u/sites/fgt/webroot/includes/class_upgrade_product.php in /u/sites/fgt/webroot/vb/vb.php on line 287

  • #2
    This may be a server time and/or memory limit. To increase your limits edit your includes/config.php file and add these lines right under the <?php line:

    ini_set('memory_limit', -1);
    ini_set("max_execution_time", "2880");


    Then try again.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Just tried that, got the same message.

      Comment


      • #4
        Also, I have my site offline and the offline page isn't showing. Just says:
        This webpage is not available.

        Comment


        • #5
          For the upgrade, try reuploading all the original files again.

          The latter issue is something you need to contact your host about.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Okay I will try to upload the files again.

            I re-uploaded the 4.0.8 files so the forum would go back online, so right now it's running 4.0.8 fine. I will try the upgrade again.

            Comment


            • #7
              I've just attempted the upgrade again and got the same message. Where should I go from here?

              Comment


              • #8
                Contact your host and ask then to check the error logs. If you followed all those instructions, then this is a server issue.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  I've contacted the host, they tell me the following. I'm still getting this error, what should I do?

                  The error message doesn't say anything about a memory
                  limit problem. However, it could be if you're working with a very
                  large dataset. If you'd like, raise your memory_limit setting in your
                  site's php.ini file, wait 5 minutes for it to kick in, then try again.

                  It's likely not a PHP timeout issue. If it were you'd get a white
                  page with something like "Internal server error" rather than a
                  backtrace produced by your app.

                  Comment


                  • #10
                    My ini_set instructions also covered the PHP timeout issue. What is max_execution_timeout set to on this server?
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      max_execution_time = 60
                      max_input_time = 90

                      Comment


                      • #12
                        Then your host did not change those settings.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          OK, now the php.ini file is showing:

                          max_execution_time = 2880
                          max_limit = -1

                          Still getting the error. What now?

                          Comment


                          • #14
                            Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

                            Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              ...

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X