Announcement

Collapse
No announcement yet.

Error during Upgrade to 4.01 pl2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Ok, deleted everything ... but same error

    Code:
    http://www.hardwaregame.org/forum/install/upgrade.php
    Code:
    internal error on line 426 in /var/www/virtual/hardwaregame.org/htdocs/forum/includes/class_upgrade_product.php
    #0 /var/www/virtual/hardwaregame.org/htdocs/forum/includes/class_upgrade_product.php(488): vB_Upgrade_Product->import_dependencies()
    #1 /var/www/virtual/hardwaregame.org/htdocs/forum/install/includes/class_upgrade_vbblog.php(78): vB_Upgrade_Product->verify_install('vbblog')
    #2 /var/www/virtual/hardwaregame.org/htdocs/forum/install/includes/class_upgrade.php(358): vB_Upgrade_vbblog->__construct(Object(vB_Registry), Array, '4.1.0')
    #3 /var/www/virtual/hardwaregame.org/htdocs/forum/install/includes/class_upgrade_ajax.php(312): vB_Upgrade_Abstract->load_script('vbblog')
    #4 /var/www/virtual/hardwaregame.org/htdocs/forum/install/includes/class_upgrade_ajax.php(176): vB_Upgrade_Ajax->begin_upgrade('410b1', 0)
    #5 /var/www/virtual/hardwaregame.org/htdocs/forum/install/includes/class_upgrade.php(298): vB_Upgrade_Ajax->init(NULL)
    #6 /var/www/virtual/hardwaregame.org/htdocs/forum/install/includes/class_upgrade_ajax.php(80): vB_Upgrade_Abstract->__construct(Object(vB_Registry), Array, 'upgrade')
    #7 /var/www/virtual/hardwaregame.org/htdocs/forum/install/includes/class_upgrade.php(49): vB_Upgrade_Ajax->__construct(Object(vB_Registry), Array, 'upgrade', NULL)
    #8 /var/www/virtual/hardwaregame.org/htdocs/forum/install/upgrade.php(44): vB_Upgrade::fetch_library(Object(vB_Registry), Array, '', true)
    #9 {main}
    
    
    [B]Fatal error[/B]: internal error on line 426 in /var/www/virtual/hardwaregame.org/htdocs/forum/includes/class_upgrade_product.php in [B]/var/www/virtual/hardwaregame.org/htdocs/forum/vb/vb.php[/B] on line [B]287[/B]
    Italians Videogames Community

    Comment


    • #17
      Then reupload totally default files. You honestly cannot be having the script try to call the vbseo.php file unless something is making it call it (and default vbulletin does not call that file). Or, you have a different error than what you posted in the first post.

      Please don't PM or VM me for support - I only help out in the threads.
      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
      Want help modifying your vbulletin forum? Head on over to vbulletin.org
      If I post CSS and you don't know where it goes, throw it into the additional.css template.

      W3Schools <- awesome site for html/css help

      Comment


      • #18
        I uploaded all the files in the root of my forum, unfortunately always the same error ......sigh
        Italians Videogames Community

        Comment


        • #19
          The installer is attempting to tell you that some dependancy has not been met, it appears to be crashing when it tries to display the error message(s).

          What else is being displayed ?
          Baby, I was born this way

          Comment


          • #20
            Nothing else. Blank page with what is written above
            Italians Videogames Community

            Comment


            • #21
              Then without a bit of debugging, its hard to see what dependency you are failing on.

              If you are confident at editing files - edit your class_upgrade_product.php

              at line 425, change print_dots_stop(); to print_dots_stop(); print_r($dependency_errors); exit;

              Upload the modified version and run the upgrade - it should list the errors array and then exit.
              Baby, I was born this way

              Comment


              • #22
                Originally posted by Paul M View Post
                Then without a bit of debugging, its hard to see what dependency you are failing on.

                If you are confident at editing files - edit your class_upgrade_product.php

                at line 425, change print_dots_stop(); to print_dots_stop(); print_r($dependency_errors); exit;

                Upload the modified version and run the upgrade - it should list the errors array and then exit.
                Ok Paul,
                now this error:
                Code:
                 
                This product is not compatible with version 4.0.8 of vBulletin. (Compatible starting with 4.1.0 Beta 1 / Incompatible with 4.2.0 Alpha 1 and greater)
                Italians Videogames Community

                Comment


                • #23
                  Well its complaining that the vbblog xml file dependancies are outside of the version you have installed. Which seems to be the case since its saying you have 4.0.8 and the XML is for 4.1.0.

                  Im afraid I dont have enough knowledge of how the new upgrader works in detail to know why it would be checking this at this point, since it seems its bound to fail. You probably need Freddies help as he did most of the work on it.
                  Baby, I was born this way

                  Comment


                  • #24
                    Thanks,
                    I have to open a ticket or continue in this post?
                    Italians Videogames Community

                    Comment


                    • #25
                      Id suggest a ticket.
                      Baby, I was born this way

                      Comment


                      • #26
                        I opened a ticket but still we did not find solution
                        Italians Videogames Community

                        Comment


                        • #27
                          In your ticket every error you've reported so far has been due to an add-on, specifically vBSEO. I am waiting for you to disable GZIP as per my reply yesterday so I can investigate this further.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #28
                            I solved the problem. It was not vBSEO plugin but permission problems on the server.

                            Thanks anyway to all
                            Italians Videogames Community

                            Comment


                            • #29
                              Does anyone happen to know what his/her permission error was exactly? I'm having the same issue here and trying to solve it!

                              Comment


                              • #30
                                Check your server's error logs as any permission problems should be reported there.
                                Vote for:

                                - *Admin Settable Paid Subscription Reminder Timeframe*
                                -
                                *PM - Add ability to reply to originator only*
                                - Add Admin ability to auto-subscribe users to specific channel(s)
                                - "Quick Route" Interface...

                                Comment

                                Related Topics

                                Collapse

                                Working...
                                X