Announcement

Collapse
No announcement yet.

Upgrading from 4.0.2 to 4.0.4 - Should I DO It?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Suite] Upgrading from 4.0.2 to 4.0.4 - Should I DO It?

    Hello,

    I'm running 4.0.2 still. I upgraded a test site to 4.0.3, but ran into SO MANY bugs that I decided to skip that release on my live environment.

    I know that 4.0.4 has just been out for a couple of days, but it sounds really cool from what I've read. I just want to make sure I'm not going to step into the mud again.

    I'd really like to hear from those who already HAVE upgraded to 4.0.4. SHOULD I do it? Do the pros outweigh the cons? Or is this another really buggy release?

    Thanks for the feedback.
    Jeff
    18
    YES
    33.33%
    6
    NO
    66.67%
    12

  • #2
    Nope! I just tried to upgrade from 4.0.2 to 4.0.4 and it got stuck at Step 4 and hasn't progressed from it. I've opened a support ticket.

    Not good!

    Comment


    • #3
      Run the update on a test site and see how it goes for you.

      I've updated a few sites to 4.0.4 without any issue, but there are some others with particular configurations that running into problems.

      We're generally happy with the 4.0.4 release so far, but I really recommend you to test it first on your own and then decide if it's ready for your live environment.

      (It goes without saying, backup your site before upgrading...)
      To be updated...

      Comment


      • #4
        I've upgraded from 4.02 to 4.04 and did the upgrade myself for the first time, and I am pleased with it, seems so much faster and well pleased with the bug fixes, some of which were in 4.03.

        I posted this on another thread:

        My biggest problem is that many of my CMS articles included HTML line-breaks for the article previews as before the preview never took account of normal line-breaks (carriage returns), which they do now. The fall out has been the various <br> code suddenly showing up as text in the preview and I've had to edit all those articles.

        Also the work-a-round I used before to stop 'youtube' clips appearing twice in the preview is broken by the bug-fix, so now no videos show in the preview - again I am having to edit all those articles to repair it.

        I think these issues actually came up with 4.03, but I didn't bother with that upgrade - it's been a right pain, but despite that I am pleased that these things are fixed in the software as it's going to make life a lot easier for now on.


        testing 1..2..3

        Comment


        • #5
          Originally posted by ENF View Post
          Run the update on a test site and see how it goes for you.

          I've updated a few sites to 4.0.4 without any issue, but there are some others with particular configurations that running into problems.

          We're generally happy with the 4.0.4 release so far, but I really recommend you to test it first on your own and then decide if it's ready for your live environment.

          (It goes without saying, backup your site before upgrading...)
          I second this as well.

          Comment


          • #6
            Wow, the poll is running 50/50. There doesn't seem to be a consensus. That's a little intimidating!

            Thanks for the feedback everyone!

            Comment


            • #7
              Originally posted by NashChristian View Post
              Wow, the poll is running 50/50. There doesn't seem to be a consensus. That's a little intimidating!

              Thanks for the feedback everyone!
              My advice to you, if I may, is to always keep your forum and any other softwares you might have installed in your server space, up to date with the latest versions. Security-wise, it will save you a lot of head ache.

              Comment


              • #8
                My opinion is No.I feel more problem in vb 4.0.4.I m running on my forum but missing publish to facebook,showing signature option,was problem in profile and may be much more.I tried every sol about publish to facebook and signature option but failed.so I think 4.0.2 was good one.
                www.hostsaller.com Hosting Service
                www.forum4phone.com Gsm Community
                http://kholamon.com Bangla Blog

                Comment


                • #9
                  After upgrading to 4.0.4, all attachments missing. That's not good at all~!!!

                  Comment


                  • #10
                    Are there fewer bugs in 4.0.4 than 4.0.2? Probably. But the problem is that there are worse bugs in 404, and a lot of stress, downtime and handwork to get 404 working. So if the question were phrased differently; 'would you recommend upgrading from 402 to 404?' then the answer is a definite NO.

                    Comment


                    • #11
                      Dang! This seems to be heading downhill!

                      So ALL attachments disapper in 4.0.4?

                      Comment


                      • #12
                        .... we didn't lose any attachments on site using 4.0.4 -- I don't know the circumstances under which others lost attachments.

                        ALWAYS test before upgrading a live site.
                        To be updated...

                        Comment


                        • #13
                          Originally posted by ENF View Post
                          ALWAYS test before upgrading a live site.
                          I'm going to do that! Trust me! That is what stopped me from upgrading my live site to 4.0.3. I spent about 24 hours pulling my hair out and then decided... ENOUGH!

                          Comment


                          • #14
                            "sigh" Hard to know what to do

                            Comment


                            • #15
                              Yes, it disappeared for me.

                              Originally posted by NashChristian View Post
                              Dang! This seems to be heading downhill!

                              So ALL attachments disapper in 4.0.4?

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X