Announcement

Collapse
No announcement yet.

Upgrade to v4 produces database errors... forum broke down!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JamesAB
    replied
    Originally posted by ShackMaster View Post
    ...
    No errors, however I did get the notice that blog and cms may have been installed and had to go to phpmyadmin and delete all blog and cms entries... upgraded continued with no issues from there... until this one.
    ...
    I hate to back paddle, but I'm concerned that something went wrong there.

    When you look at the database in phpMyAdmin now, do you have the cms_node and cms_permissions tables?

    Leave a comment:


  • ShackMaster
    replied
    Clicking on CMS Conten Manager gets me this:

    Database error in vBulletin 4.0.3:

    Invalid SQL:
    SELECT nodeid,
    MAX(permissions & 1) AS canview, MAX(permissions & 2) AS cancreate , MAX(permissions & 4) AS canedit,
    MAX(permissions & 8) AS canpublish, MAX(permissions & 16) AS canusehtml, MAX(permissions & 32) AS candownload
    FROM cms_permissions p
    WHERE usergroupid IN (6)
    GROUP BY nodeid;;

    MySQL Error : Table 'bible4u_forum.cms_permissions' doesn't exist
    Error Number : 1146
    Request Date : Thursday, May 13th 2010 @ 02:55:17 AM
    Error Date : Thursday, May 13th 2010 @ 02:55:18 AM
    Script : http://www.bibletruthforums.com/admi...in.php?do=list
    Referrer : http://www.bibletruthforums.com/admi...dex.php?do=nav
    IP Address : 75.120.77.51
    Username : broSonnie
    Classname : vB_Database_MySQLi
    MySQL Version : 5.0.90-community

    Leave a comment:


  • ShackMaster
    replied
    This is just plain ridiculous. Absolutely ridiculous.

    Leave a comment:


  • ENF
    replied
    Hmm, Yes, I see the errors again.

    Leave a comment:


  • ENF
    replied
    Originally posted by ShackMaster View Post
    No... I have all plugins disabled via config.php
    And if you activate them again, the errors come back?

    Leave a comment:


  • ShackMaster
    replied
    No... I have all plugins disabled via config.php

    Leave a comment:


  • ENF
    replied
    According to what I see:

    1) The CMS appears to not be installed correctly, at least from the database side. When accessing the site without /forum.php -- that's what I see below.

    Code:
    Database error in vBulletin 4.0.3:
    Invalid SQL:
    SELECT node.nodeid , (node.nodeleft = 1) AS isroot, node.contenttypeid, node.contentid, node.url, node.parentnode,
                    (CASE WHEN node.contenttypeid = 20 THEN node.styleid ELSE parent.styleid end ) AS styleid, node.userid,
                        (CASE WHEN node.contenttypeid = 20 THEN node.layoutid ELSE parent.layoutid end ) AS layoutid,
                        node.publishdate, node.setpublish, node.issection, node.permissionsfrom, node.nodeleft, node.noderight,
                        node.userid, node.showtitle, node.showuser, node.showpreviewonly, node.lastupdated, node.showall, node.showrating,
                        node.showupdated, node.showviewcount, node.showpublishdate, node.settingsforboth, node.includechildren, node.editshowchildren,
                        parent.permissionsfrom as parentpermissions, node.publicpreview, node.comments_enabled, node.shownav,
                        node.hidden, node.nosearch , info.description, info.title, info.html_title, info.viewcount, info.creationdate, info.workflowdate, info.keywords,
                        info.workflowstatus, info.workflowcheckedout, info.workflowlevelid, info.associatedthreadid, info.creationdate, node.showrating,
                        info.ratingnum, info.ratingtotal, info.rating,
                        user.username, thread.replycount, sectionorder.displayorder 
                        
                    FROM cms_node AS node
                    INNER JOIN cms_nodeinfo AS info ON info.nodeid = node.nodeid
                    LEFT JOIN user AS user ON user.userid = node.userid
                    LEFT JOIN thread AS thread ON thread.threadid = info.associatedthreadid
                    LEFT JOIN cms_sectionorder AS sectionorder ON sectionorder.sectionid = node.parentnode
                        AND sectionorder.nodeid = node.nodeid
                    LEFT JOIN cms_node AS parent ON parent.nodeid = node.parentnode 
                    
                    WHERE node.nodeid = 1;
    
    MySQL Error   : Table 'bible4u_forum.cms_node' doesn't exist
    Error Number  : 1146
    Request Date  : Thursday, May 13th 2010 @ 02:41:55 AM
    Error Date    : Thursday, May 13th 2010 @ 02:41:55 AM
    Script        : http://www.bibletruthforums.com/index.php
    Referrer      : 
    IP Address    : XXX.XXX.XXX.XXX
    Username      : Unregistered
    Classname     : vB_Database_MySQLi
    MySQL Version : 
    -->
    2) I don't see same errors I was seeing before...

    I was wondering, do you have the CMS enabled in the product manager?

    The forum itself appears to be running smoothly.

    Leave a comment:


  • ShackMaster
    replied
    Ughhhh... more issues. Trying to access a thread and get the following error:

    Database error in vBulletin 4.0.3:

    Invalid SQL:
    SELECT nodeid,
    MAX(permissions & 1) AS canview, MAX(permissions & 2) AS cancreate , MAX(permissions & 4) AS canedit,
    MAX(permissions & 8) AS canpublish, MAX(permissions & 16) AS canusehtml, MAX(permissions & 32) AS candownload
    FROM cms_permissions p
    WHERE usergroupid IN (6)
    GROUP BY nodeid;;

    MySQL Error : Table 'bible4u_forum.cms_permissions' doesn't exist
    Error Number : 1146
    Request Date : Thursday, May 13th 2010 @ 02:41:43 AM
    Error Date : Thursday, May 13th 2010 @ 02:41:43 AM
    Script : http://www.bibletruthforums.com/show...-way-RIGHT-NOW!
    Referrer : http://www.bibletruthforums.com/foru...ers-Discussion
    IP Address : 75.120.77.51
    Username : broSonnie
    Classname : vB_Database_MySQLi
    MySQL Version : 5.0.90-community

    Does it ever end?

    Leave a comment:


  • ShackMaster
    replied
    Actually all is not good.

    I removed the define('DISABLE_HOOKS', true); code and all worked fine for about 15 minutes and then the database error came back.

    I have no old code that I can find... have reuploaded all new v4 files and double checked them... no suspect file versions... just not sure what could be going on.

    Another issue I am having is I cannot access the site using www.bibletruthforums.com but have to use www.bibletruthforums.com/forum.php

    Leave a comment:


  • ShackMaster
    replied
    All is good... thank you both.

    Leave a comment:


  • ENF
    replied
    I see that the errors disappeared from your home page, so please follow up with any plugins or old code that may be lingering. (Through the product manager as well..)

    Also, note what James said about the old code. Make sure that all of your files are correctly uploaded and you are not using any 3.8 material. That can usually be found through the "Suspect File Versions" I noted above.

    Good Luck.

    Leave a comment:


  • ShackMaster
    replied
    That got me in...

    Funny thing is that I went through and deleted all files associate with any plugins, which we only had a few to begin with on that site.

    Thanks! I am feeling better now.

    Leave a comment:


  • JamesAB
    replied
    You still have some 3.8 code that is running after the upgrade.

    Either the new vBulletin files did not all upload correctly (replacing the vB3.8 files) or some modification is causing that mySQL error.
    • Disable the plugin system as ENF suggested.
    • If the problem persists, re-upload the new vB4 files to your server.

    Leave a comment:


  • ENF
    replied
    I did a bit of digging about the history of your site and it appears that you did have some plugins at one-time, so I would like for you to disable the plug-in system via your config.php. This is only a troubleshooting step to avoid any possible problems that may be coming from old plug-in material that may be still lingering around.

    Please add this line to your config.php: (right under <?php)

    define('DISABLE_HOOKS', true);

    Please try this and see if makes any difference.

    btw, can you access the AdminCP at all? If you can, also run a file check:

    AdminCP -> Maintenance -> Diagnositcs -> Suspect File Versions

    Leave a comment:


  • ShackMaster
    replied
    The instructions are pretty simple and I followed them to a tee, just like most others have, but have still had issues.

    None the less...

    PHP 5.2.12

    No errors, however I did get the notice that blog and cms may have been installed and had to go to phpmyadmin and delete all blog and cms entries... upgraded continued with no issues from there... until this one.

    Yes... all files other than image files are uploaded correctly.

    Thanks!

    Leave a comment:

Related Topics

Collapse

Working...
X