Announcement

Collapse
No announcement yet.

Lost my SideBar when upgrading to v4.0.3

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Suite] Lost my SideBar when upgrading to v4.0.3

    Hi there,

    Need some advice, as the title says I lost my SideBar during the upgrade, the blocks were working fine before the upgrade from v4.0.2PL4.

    The settings are correct in AdminCP Options, also the block templates are still there and they have been cached. There are active blocks in the Forum Blocks Manager, and I purged the cache as well.

    When I did a var_dump on $sidebar I get an empty string. Also, a var_dump on $show['sidebar'] is coming up as false even though Enable Forum Sidebar is set to Yes in the AdminCP (and, no I am not using IE6).

    It seems to be the only issue I have come across so far.

    Any suggestions?

    Regards,

    Mosh.
    -- Wolfshead Solutions - Closed down permanently as of 1/7/2013.
    -- As of 1/7/2013, due to medical reasons I no longer support my vbulletin.org hacks as I have left the vBulletin community.
    -- My Free vBulletin.org Hacks

  • #2
    OK, after further testing it is all the custom blocks that I created that do not display, the provided blocks display fine .... what have the developers changed between v4.0.2 and v4.0.3 that is causing my custom blocks to not display?
    -- Wolfshead Solutions - Closed down permanently as of 1/7/2013.
    -- As of 1/7/2013, due to medical reasons I no longer support my vbulletin.org hacks as I have left the vBulletin community.
    -- My Free vBulletin.org Hacks

    Comment


    • #3
      Mosh,

      Add this line to the bottom of your custom blocks:
      Code:
          return true;

      Please don't PM or VM me for support - I only help out in the threads.
      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
      Want help modifying your vbulletin forum? Head on over to vbulletin.org
      If I post CSS and you don't know where it goes, throw it into the additional.css template.

      W3Schools <- awesome site for html/css help

      Comment


      • #4
        Hi Lynne,

        That worked a treat

        All blocks work now, and I am happy

        So, Steve can close the support ticket I lodged as well.

        Regards,

        Mosh.
        -- Wolfshead Solutions - Closed down permanently as of 1/7/2013.
        -- As of 1/7/2013, due to medical reasons I no longer support my vbulletin.org hacks as I have left the vBulletin community.
        -- My Free vBulletin.org Hacks

        Comment


        • #5
          OK, I upgraded to vBulletin 4.0.4 and they broke again ...... how do I fix it this time???
          -- Wolfshead Solutions - Closed down permanently as of 1/7/2013.
          -- As of 1/7/2013, due to medical reasons I no longer support my vbulletin.org hacks as I have left the vBulletin community.
          -- My Free vBulletin.org Hacks

          Comment


          • #6
            I think it is a caching issue, has Sidebar caching changed with vBulletin 4.0.4? is there any way to get around this?
            -- Wolfshead Solutions - Closed down permanently as of 1/7/2013.
            -- As of 1/7/2013, due to medical reasons I no longer support my vbulletin.org hacks as I have left the vBulletin community.
            -- My Free vBulletin.org Hacks

            Comment


            • #7
              Yes, it changed again (grumble, grumble, grumble). I'm not exactly sure what was changed. I took a look at what Paul M changed in his from the last version and then kinda did something similar to mine and it worked. Yes, I cheated like that, but it was quicker than figuring it out myself.

              Please don't PM or VM me for support - I only help out in the threads.
              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
              Want help modifying your vbulletin forum? Head on over to vbulletin.org
              If I post CSS and you don't know where it goes, throw it into the additional.css template.

              W3Schools <- awesome site for html/css help

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X