Announcement

Collapse
No announcement yet.

Fatal error: Out of memory Step 9 going from 3.8.4 to 4.0.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Suite] Fatal error: Out of memory Step 9 going from 3.8.4 to 4.0.2

    I am testing an upgrade for a site that was running 3.8.4 -- trying to move it to 4.0.2 in test before I do it in production. I have also submitted a support ticket on this. It is dying at step 9. (albums/pictures)

    I am getting the following error at step 9.

    Step 9) Albums System Alterations

    Moving picture 1045 into the Attachment System


    Fatal error: Out of memory (allocated 8126464) (tried to allocate 2813197 bytes) in /home/davidan/public_html/vbtest/forums/includes/class_core.php on line 2298


    I have followed every piece of information I have been able to find on the forums to solve this with no luck. The good news is I am doing this on a test bed right now as we have a 800 MB DB and a high volume site that I want to make sure this works in test before doing production. Max memory in PHP on the server (Hostgator) is 64 MB ... I cannot make it any higher than that. I have disabled all hacks in the config.php file with the following

    define('DISABLE_HOOKS', true);

    I also disabled all hacks as well prior to starting from the admin control panel.
    I restart the script and it still gets error at this same spot ...



    any ideas?

  • #2
    I think you are going to need more memory. 64MB, really? Wow.

    Maybe someone that uses Hostgator can chime in on this one.

    Otherwise, you could do the test on your local machine by downloading a backup copy of your DB and forum folder. The installing a local test bed on your local PC. Thus, you can control the memory amount for PHP more precisely. There are a few tutorials on setting up a local test bed floating around if you don't know how.

    Maybe downloading your database may prove to be tricky though... I'm just not familiar with Hostgator. Sorry.
    To be updated...

    Comment


    • #3
      try

      If you have a root

      pico /usr/local/lib/php.ini

      then

      memory_limit = 64M
      change it to 128M or 256M

      - then restart Apache

      or contact with your web-hosting

      or try with
      public_html/.htaccess
      public_html/vbtest/forums/.htaccess
      PHP Code:
      php_value memory_limit 200M 
      Regards,
      Last edited by TECH4C; Wed 24 Feb '10, 12:16am.

      Comment


      • #4
        unfortunately none of this has worked, tried each of these suggestions thank you for posting. I have also called the webhost (hostgator) and confirmed that I have 64M of memory for PHP to run, I then validated that in the PHP.ini as well as cpanel on the site. I tried these .htaccess and still no luck. I started over, making sure this time that not only had I disabled all mods and hacks from the original DB but I totally uninstalled each of them ... and disabled any hooks from running in config.php. Still not working. IT seems to be bombing as it's trying to move pictures within the DB to some sort of new part of the attachment system.

        Any other ideas, I can't increase the memory any more with my host without getting a dedicated server = lots of money
        what are my other options?

        can I skip a step, do I need to try to move pictures or something from galleries out of the DB?

        by the way at least the error is consistent, it is failing exact same place.
        and the response I got from vBulletin support so far was tell the host I need more than 8 M of memory
        I already have 64 as stated via confirming that with them -- so what gives?

        Step 9) Albums System Alterations

        Moving picture 1045 into the Attachment System


        Fatal error: Out of memory (allocated 8126464) (tried to allocate 2813197 bytes) in /home/davidan/public_html/vbtest/forums/includes/class_core.php on line 2298

        Comment


        • #5
          8 126 464 bytes = 7.75 megabytes

          Something is wrong with your server, that is not 64mb.

          Comment


          • #6
            go to

            www/.httaccess

            add

            PHP Code:
             <IfModule mod_php4.c>  
            php_value max_execution_time  1000  
            </IfModule
            Last edited by TECH4C; Thu 25 Feb '10, 3:52am.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X