Announcement

Collapse
No announcement yet.

I can upgrade from 3.4.8 to 4.0.0 becaous cant get my vb version by upgrade.php file!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Suite] I can upgrade from 3.4.8 to 4.0.0 becaous cant get my vb version by upgrade.php file!

    Hello

    I have vb 3.4.0 PL1 and want upgrade to 4.0.0 but i get this problem.

    - I take DB backup.

    - Downlode the [vBulletin 4.0 Publishing Suite] from member eara and uplode the .zip file to my website.

    - I change the config.php to new information by DBname, user and pass.... and disable Hook by adding [define('DISABLE_HOOKS', true);] in the file.

    - when try to loggin to /forum/install/upgrade.php i get whait page with this is:

    Your vBulletin version does not appear to match with the version for which this script was created (version 3.6.0 Release Candidate 3).
    Please ensure that you are attempting to run the correct script.
    If you are sure this is the script you would like to run, click here.

    - if i try to loggin in /forum/install/install.php it will try to install new vb forum !!

    Welcome to vBulletin version 4.0

    You are about to perform an install.

    Clicking the [Next Step] button will begin the installation process on your database.

    In order to prevent possible browser crashes during this script, we strongly recommend that you disable any additional toolbars you may be using on your browser, such as the Google toolbar etc.

    How can upgrade
    Last edited by omanmoon.net; Thu 24 Dec '09, 12:48am.

  • #2
    Are you sure you downloaded the vb4 files? I can't read the language on that forum to be able to see what version you currently have running.
    s.molinari - I would like to ask all customers to definitely feedback issues with the software and be specific with the issues, but to basically suck-up what happened in the past and try to just look forward.

    Comment


    • #3
      Given that you are running a significantly older version of vB, I'd recommend that you do this in two stages:

      - Upload the 3.8.4 files then upgrade to this version first
      - Once complete, backup your database again, upload the 4.0 files then upgrade again.
      Vote for:

      - *Admin Settable Paid Subscription Reminder Timeframe*
      -
      *PM - Add ability to reply to originator only*
      - Add Admin ability to auto-subscribe users to specific channel(s)
      - "Quick Route" Interface...

      Comment


      • #4
        Originally posted by s0lidgr0und View Post
        Are you sure you downloaded the vb4 files? I can't read the language on that forum to be able to see what version you currently have running.
        Yes sure bro
        i am not download [forum 4.0.0] ,, am download [vBulletin 4.0 Publishing Suite]
        and upload vbulletinsuite_4-0-0_Patch_Level_1.zip to my website and extract it then change name [upload] to [forum]
        but i guss it can upgrade forum to suit.
        The language is Arabic and my version is vBulletin 3.8.4 Patch Level 1


        Originally posted by Trevor Hannant View Post
        Given that you are running a significantly older version of vB, I'd recommend that you do this in two stages:

        - Upload the 3.8.4 files then upgrade to this version first
        - Once complete, backup your database again, upload the 4.0 files then upgrade again.
        It's not old !!
        my forum use vBulletin 3.8.4 Patch Level 1

        http://www.omanmoon.net/vb

        Comment


        • #5
          Originally posted by omanmoon.net View Post
          It's not old !!
          my forum use vBulletin 3.8.4 Patch Level 1

          http://www.omanmoon.net/vb
          Based on your original post (I can see this is a typo now):

          I have vb 3.4.0 PL1
          Have you previously tested the upgrade of your forum on that domain and database?
          Vote for:

          - *Admin Settable Paid Subscription Reminder Timeframe*
          -
          *PM - Add ability to reply to originator only*
          - Add Admin ability to auto-subscribe users to specific channel(s)
          - "Quick Route" Interface...

          Comment


          • #6
            Originally posted by Trevor Hannant View Post
            Based on your original post (I can see this is a typo now):



            Have you previously tested the upgrade of your forum on that domain and database?
            Sorry i edit my post after your replay also i see now my wrong title ,, i mean [i can't upgrade] not [i can upgrade] :s

            any way this not first time upgrade my forum am use vBulletion from v2.x.x and use this domain from 5 years later

            Comment


            • #7
              Exactly what steps did you take for doing your upgrade from vB2 to where you are now? Did you back up at various stages along the way?
              Vote for:

              - *Admin Settable Paid Subscription Reminder Timeframe*
              -
              *PM - Add ability to reply to originator only*
              - Add Admin ability to auto-subscribe users to specific channel(s)
              - "Quick Route" Interface...

              Comment


              • #8
                Originally posted by Trevor Hannant View Post
                Exactly what steps did you take for doing your upgrade from vB2 to where you are now? Did you back up at various stages along the way?
                Sorry but i think the broplem not from vB2
                I not meannig by am useing vB2 am upgeade naw
                AM mean use vB2 from many years till vB3 and now i want upgrade to vB4

                Thats mean am try all vB3 version from the biginng vb3.0.0 to last one vb3.8.4
                and all the time upgrade easy without any problem

                But now i dont know what hapinng when i try to use link:
                /forum/install/upgrade.php
                It's automatic change to:
                /forum/install/upgrade_360.php
                and show thats msg am write it above

                whay it's not change for example to:
                /forum/install/upgrade_380.php
                Becuase my vBulliton is 3.8.4.!

                Comment


                • #9
                  First think you'll need to do is disable all your plugins on your site. it's possible that something else is causing this as the script should recognise that you're running 3.8.4 just now and move on to the next version up from that.
                  Vote for:

                  - *Admin Settable Paid Subscription Reminder Timeframe*
                  -
                  *PM - Add ability to reply to originator only*
                  - Add Admin ability to auto-subscribe users to specific channel(s)
                  - "Quick Route" Interface...

                  Comment


                  • #10
                    Originally posted by Trevor Hannant View Post
                    First think you'll need to do is disable all your plugins on your site. it's possible that something else is causing this as the script should recognise that you're running 3.8.4 just now and move on to the next version up from that.
                    It's not enough put [define('DISABLE_HOOKS', true);] in the config.php to disable plugins?
                    or it's necessary upgrade to vBulletin 3.8.4 Patch Level 2 befor upgrade to vB 4?

                    Comment


                    • #11
                      The best course of action is to uninstall all of them prior to the upgrade as none will work in their current form anyway. There are some that have been updated for vB4 but they will need to be reinstalled after you upgrade.
                      Vote for:

                      - *Admin Settable Paid Subscription Reminder Timeframe*
                      -
                      *PM - Add ability to reply to originator only*
                      - Add Admin ability to auto-subscribe users to specific channel(s)
                      - "Quick Route" Interface...

                      Comment


                      • #12
                        When you get to this screen ;

                        Your vBulletin version does not appear to match with the version for which this script was created (version 3.6.0 Release Candidate 3).
                        Please ensure that you are attempting to run the correct script.
                        If you are sure this is the script you would like to run, click here.
                        What happens if you simply carry on (i.e click on the bit in red).
                        Baby, I was born this way

                        Comment


                        • #13
                          Originally posted by Trevor Hannant View Post
                          The best course of action is to uninstall all of them prior to the upgrade as none will work in their current form anyway. There are some that have been updated for vB4 but they will need to be reinstalled after you upgrade.
                          Ok
                          I will try to uninstall all of them in other forum only for test
                          If it's work i will do in the orginal forum

                          Comment


                          • #14
                            Originally posted by Paul M View Post
                            When you get to this screen ;



                            What happens if you simply carry on (i.e click on the bit in red).
                            The link in red line is:

                            forum/install/upgrade_360.php?step=1
                            Am don't try click on it because my VB version is 3.8.4 then ther will problem abear actual

                            Comment


                            • #15
                              Originally posted by omanmoon.net View Post
                              The link in red line is:



                              Am don't try click on it because my VB version is 3.8.4 then ther will problem abear actual
                              same here :s
                              Trying to upgrade from 3.8.4 PL2 and got the same " (version 3.6.0 Release Candidate 3)." message.
                              did you manage to solve it?

                              Upgrade Log
                              Click image for larger version

Name:	upgrade-log..png
Views:	1
Size:	71.8 KB
ID:	3678170
                              Last edited by foxfirediego; Thu 25 Feb '10, 3:34pm. Reason: Include upgrade log image

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X