Announcement

Collapse
No announcement yet.

Slow Member List lookup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Slow Member List lookup

    Last issue on my migration and upgrade list... Site is running fine except for the Member List lookup.

    Clicking on Member List takes 60 seconds to return 30 rows... it's the ONLY thing on the site misbehaving. Navigating forums, threads, admin/config, etc. all run ricky tick. If I query the database directly (not sure exactly what query vb is using to get the member list), but select * from icu_Users returns 399 rows in under a second. MySQL Performance reports do not show anything out of the ordinary.

    Site is a migration from one hosting co to another... upgraded from (shame) 3.7.something to 3.8.6 initially now up to 3.8.11. PHP Version 5.6.31, MySQL 5.7.21. Pretty plain Jane install.

    Any ideas?

  • #2
    Do you include custom profile fields on your member list? These require joins that eat up resources and add time.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Yeah... i took what is displayed down to bare bones...just the name. Same result, 2 seconds per name to fill the page, although the SQL query runs faster that MySQL can record the time for it. I can see however, that the connection to the database is open that entire time. So I'm guessing that php code is looping through the results one row at a time?

      Avatars et al moved to file store; that didn't help. And... we're talking about a pretty small system... < 300 user records. I'm convinced it is a PHP memory/performance thing, I don't think it is in the database nor the query being issued. However, my knowledge of PHP is pretty much limited to being able to spell the acronym correctly.

      Comment


      • #4
        I'm at a complete loss on what to do. Everything about the site is super responsive... Except for that member list lookup... 2 seconds per row. I've reduced the display options to just the name, no fancy stuff... still 2 seconds... Moved images to the file system, still 2 seconds per row. I've reverse engineered the SQL in MemberList.php, run that against MySQL, blazingly fast.

        I could sure use some help...

        Comment


        • #5
          Please disable plugins and hooks globally using the below instructions:

          To disable the plugin/hook system open your config.php which can be found in your forumroot/includes directory

          Just below
          Code:
          <?php
          enter
          Code:
          define('DISABLE_HOOKS', true);
          and save the file.

          Do you still have the same problem?
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.6.4 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #6
            Thank you Mark, and thank you Joe D... it was my Yet another Award System plugin. I'm so embarrassed I didn't even THINK about the plugins. This board has been so stable and rock solid, I've forgotten most of the setup bits I did in 2009 when I first deployed.

            I did upgrade YaAS... but that didn't help. Getting into YaAS config and turning off the option to display awards on the member list solves the problem. (And since the awards don't show anyway... no loss at this point).

            Thank you for your time guys. I really appreciate the rescue (and education).

            Comment

            Related Topics

            Collapse

            Working...
            X