Announcement

Collapse
No announcement yet.

Fatal error: Call to undefined function mysqli_init()

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fatal error: Call to undefined function mysqli_init()

    Hey,

    I had a problem with my host which was resolved, now Im getting this error:

    Fatal error: Call to undefined function mysqli_init() in /home/northwes/public_html/site/daold/includes/class_core.php on line 1140

    I searched here and someone wrote the myqli module wasnt installed but just host just confirmed it is.

    Anyone know what is causing this?

    Thanks
    John Diver

  • #2
    Check your php.info

    Comment


    • #3
      That still indicates that it isn't - although the module is installed, has the relevant php.ini file been updated to make sure it's active and being used/called?
      Vote for:

      - *Admin Settable Paid Subscription Reminder Timeframe*
      -
      *PM - Add ability to reply to originator only*
      - Add Admin ability to auto-subscribe users to specific channel(s)
      - "Quick Route" Interface...

      Comment


      • #4
        mysqli

        Client API library version mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $
        Active Persistent Links 0
        Inactive Persistent Links 0
        Active Links 0
        mysqli.allow_local_infile On On
        mysqli.allow_persistent On On
        mysqli.default_host no value no value
        mysqli.default_port 3306 3306
        mysqli.default_pw no value no value
        mysqli.default_socket /var/lib/mysql/mysql.sock /var/lib/mysql/mysql.sock
        mysqli.default_user no value no value
        mysqli.max_links Unlimited Unlimited
        mysqli.max_persistent Unlimited Unlimited
        mysqli.reconnect Off Off
        mysqli.rollback_on_cached_plink Off Off
        John Diver

        Comment


        • #5
          That is a function native to PHP. If it is reported as undefined, something is wrong in the PHP installation.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #6
            Hey,

            Is there any other way to test this?

            Not sure if this helps but this is the file from the MultiPHP editor in cPanel:

            ; cPanel-generated php ini directives, do not edit
            ; Manual editing of this file may result in unexpected behavior.
            ; To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
            ; For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)

            allow_url_fopen = On
            allow_url_include = Off
            asp_tags = Off
            display_errors = On
            enable_dl = Off
            file_uploads = On
            max_execution_time = 90
            max_input_time = -1
            max_input_vars = 1000
            memory_limit = 128M
            post_max_size = 8M
            safe_mode = Off
            session.gc_maxlifetime = 1440
            session.save_path = "/tmp"
            upload_max_filesize = 2M
            zlib.output_compression = Off


            --------------------------------------


            Thanks again
            John Diver

            Comment


            • #7
              This is server configuration, and it is outside the scope of our support. We are not server configuration experts, and cannot possibly know the intricacies and limitations of your set up.

              You should speak to your hosts about this.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.6.4 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #8
                |Hey,

                The PHP version was changed but now I'm getting these errors:

                Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/northwes/public_html/deuceace.com/daold/includes/functions.php(5404) : eval()'d code on line 3

                Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/northwes/public_html/site/daold/includes/functions.php(5487) : eval()'d code on line 3

                Parse error: syntax error, unexpected T_STRING in /home/northwes/public_html/site/daold/global.php(603) : eval()'d code on line 1

                Fatal error: Class 'vB_Template_Runtime' not found in /home/northwes/public_html/site/daold/global.php(604) : eval()'d code on line 6
                John Diver

                Comment


                • #9
                  What did you change it to and what version of vB3 are you running?

                  Please note that as well as making sure the version of vBulletin you're running is compatible with the version of PHP on your server, you will need to make sure any plugins and products you have installed are also.

                  vBulletin 3.8.11 requires PHP 5.6.0+ and MySQL 5.5.8+.
                  vBulletin 3.8.10 requires PHP 5.5.x and MySQL 5.0.0+.
                  vBulletin 3.8.9 requires PHP 5.3.x and MySQL 4.1.0+.

                  vBulletin 3.8.11+ supports PHP 7.0 and PHP 7.1 (NOT PHP7.2)
                  Vote for:

                  - *Admin Settable Paid Subscription Reminder Timeframe*
                  -
                  *PM - Add ability to reply to originator only*
                  - Add Admin ability to auto-subscribe users to specific channel(s)
                  - "Quick Route" Interface...

                  Comment


                  • #10
                    I think its 3.8.8 - I know its on PHP 5.3 now
                    John Diver

                    Comment


                    • #11
                      I recommend upgrading to at least PHP 5.6.0 and upgrading vBulletin to 3.8.11.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud demonstration site.
                      vBulletin 5 API

                      Comment


                      • #12
                        Hey Wayne,

                        Thanks for the reply.

                        My developer changed to 3.8.11 and its on 5.6 but now I'm just getting an internal 500 error.

                        Id upgrade to vb4 but Ive a very custom design I want to keep.

                        I don't know whats going on.. it was working fine before.

                        Thanks again
                        John Diver

                        Comment


                        • #13
                          When you say "changed"....how was this done? It requires all new files and running the upgrade script.
                          MARK.B | vBULLETIN SUPPORT

                          TalkNewsUK - My vBulletin 5.6.4 Demo
                          AdminAmmo - My Cloud Demo

                          Comment


                          • #14
                            Hey Mark,

                            It was a fresh install in a different directory to test it.

                            He just tried in the current directory with the upgrade script but now its giving another error

                            vB_Database_MySQLi::db_connect(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.
                            /home/northwes/public_html/site/daold/includes/class_core.php on line 1200
                            John Diver
                            Senior Member
                            Last edited by John Diver; Sat 24 Mar '18, 10:09pm.
                            John Diver

                            Comment


                            • #15
                              Originally posted by John Diver View Post
                              Hey Mark,

                              It was a fresh install in a different directory to test it.

                              He just tried in the current directory with the upgrade script but now its giving another error
                              That’s a server error. Th fix is right there in the error text. Your host or server admin needs to sort this.
                              MARK.B | vBULLETIN SUPPORT

                              TalkNewsUK - My vBulletin 5.6.4 Demo
                              AdminAmmo - My Cloud Demo

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X