No announcement yet.

vBulletin 3.8.11

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    If your long term plans are to upgrade to VB 5.x you should upgrade MySQL 5.6.10 or higher (or MariaDB 10.0.0 or higher). MySQL 5.5.8 is the official minimum for VB 3.8.11, we can't support it on versions lower than that.


    • #47
      Originally posted by Joe D. View Post
      VB 3.8.11 requires PHP 5.6.x minimum and 7.1.x maximum.

      Upgrade your PHP first and then you can upgrade to 3.8.11. You don't need to be compatible with the old version to upgrade to 3.8.11 however if you are in a situation where you have two separate forums on one server PHP 5.6.x should work for both 3.8.9 and 3.8.11.
      Thanks Joe !!

      I have updated my forum to vb. 3.8.11 correctly, but with php 7.0 I receive the following error:
      ParseError: syntax error, unexpected 'new' (T_NEW) in ..../includes/class_activecache.php on line 35

      with php 5.6.4 it works, but with php 7 it gives me that error.
      Any ideas?
      Thank you very much!!


      • #48

        class_activecache.php is not a vBulletin file, it is from a 3rd party script, obviously one too old to work with the newer PHP version. A quick Google search makes it look like it might be from the mod [DBTech] vB Optimise 2.0.1 (Lite), if that looks familiar, though it could be from any mod.

        You can disable mods by adding the following line to the /includes/config.php file to temporarily disable add-ons. This will allow you to uninstall add-ons that are incompatible.

        Line to add to config.php:

        define('DISABLE_HOOKS', true);
        Add it just below the first line, <?php anf then try to load the page again.


        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.