Announcement

Collapse
No announcement yet.

I'm getting a white screen after upgrading my OS from Ubuntu 12.04 to 16.04

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I'm getting a white screen after upgrading my OS from Ubuntu 12.04 to 16.04

    Can someone tell me where to locate a "vb_test.php" for version vb3? This might help me to identify the problems.

    -- L. James

    --
    L. D. James
    [email protected]
    www.apollo3.com/~ljames

  • #2
    There isn't a test file for vB3.

    What version of vB3 are you running?
    What version of php is on the server?
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.3 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      I don't know how to check the version level when it's not running. The last file I downloaded before vb5 was vbulletin_3-8-6_Patch_Level_1_VBFA3A26C0.zip, back in 2011. I'm sure I performed the patch. Not sure if there were other upgrades that didn't involve an actually download... but probably not.

      The last was I downloaded was vbulletin_3-8-6_Patch_Level_1_VBFA3A26C0.zip.
      phpinfo() = PHP Version 5.6.24-1
      mysql version: 5.7.13


      The caccess.log shows:
      Code:
      poseidon.apollo3.com - - [30/Jul/2016:08:50:18 -0400] "GET /mytestphpinfo.php HTTP/1.1" 404 515 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36"
      poseidon.apollo3.com - - [30/Jul/2016:08:50:43 -0400] "GET /myapophpinfo.php HTTP/1.1" 200 25771 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36"
      poseidon.apollo3.com - - [30/Jul/2016:08:53:46 -0400] "GET / HTTP/1.1" 304 179 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36"
      poseidon.apollo3.com - - [30/Jul/2016:08:53:46 -0400] "GET /favicon.ico HTTP/1.1" 200 1378 "http://forum.apollo3.com/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36"
      Nothing shows in the error.log

      -- L. James

      --
      L. D. James
      [email protected]
      www.apollo3.com/~ljames
      Last edited by apollothethird; Sat 30 Jul '16, 5:34am.

      Comment


      • #4
        you should generally upgrade to latest vb3, THEN vb4.2.4 beta2, THEN vb5 making backups all along the way...

        do you have a backup from before you started the recent vb upgrade? i would probly try re upload old site files and db restore, being sure its not using php7...

        then if you can restore the initial state, then proceed more along a path like this

        Comment


        • #5
          Yes. I do have backups the working version backups. I'll look for the versions you mentioned.

          -- L. James

          --
          L. D. James
          [email protected]
          www.apollo3.com/~ljames

          Comment


          • #6
            vB 3.8.6 is not compatible with php 5.6.

            Therefore your first step should ideally be, downgrade php to 5.3 to see if the site then works.
            If it doesn't, we'll need to know what errors you are getting.

            An alternative would be to upgrade vB to 3.8.10 which will add in the required php compatibility. Again, if there are still errors after this, we need to know what they are.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.6.3 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Ok.

              -- L. James

              --
              L. D. James
              [email protected]
              www.apollo3.com/~ljames

              Comment


              • #8
                Originally posted by Mark.B View Post
                vB 3.8.6 is not compatible with php 5.6.

                Therefore your first step should ideally be, downgrade php to 5.3 to see if the site then works.
                If it doesn't, we'll need to know what errors you are getting.

                An alternative would be to upgrade vB to 3.8.10 which will add in the required php compatibility. Again, if there are still errors after this, we need to know what they are.
                So far I'm getting the same. I have done as you suggested:

                OS Ubuntu 12.04
                php version 5.3.10
                myql version 5.5.50

                I get the same blank screen. There's nothing in the error log file.

                The caccess log shows one line when being accessed:
                Code:
                poseidon.apollo3.com - - [31/Jul/2016:09:03:58 -0400] "GET / HTTP/1.1" 304 208 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36"
                -- L. James

                --
                L> D. James
                [email protected]
                www.apollo3.com/~jlames

                Comment


                • #9
                  Upload the standard vb_test.php and try to load it in your browser. Doesn't matter about entering any details, nor what version it is for, just try to load it. Does it load ok?
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.6.3 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #10
                    It works with everything passing except for "GD".

                    -- L. ljames

                    --
                    L. D. James
                    [email protected]
                    www.apollo3.com/~ljames

                    Comment


                    • #11
                      Need to see what's in the error logs. Blank pages generally mask php errors, these should be in the server error logs.
                      MARK.B | vBULLETIN SUPPORT

                      TalkNewsUK - My vBulletin 5.6.3 Demo
                      AdminAmmo - My Cloud Demo

                      Comment


                      • #12
                        Originally posted by Mark.B View Post
                        Need to see what's in the error logs. Blank pages generally mask php errors, these should be in the server error logs.
                        caccess.log:
                        Code:
                        poseidon.apollo3.com - - [31/Jul/2016:09:39:21 -0400] "GET /vb_test.php HTTP/1.1" 200 1050 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36"
                        poseidon.apollo3.com - - [31/Jul/2016:09:39:46 -0400] "POST /vb_test.php HTTP/1.1" 200 1393 "http://forum2.apollo3.com/vb_test.php" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36"
                        poseidon.apollo3.com - - [31/Jul/2016:09:39:57 -0400] "GET /vb_test.php HTTP/1.1" 200 1050 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36"
                        poseidon.apollo3.com - - [31/Jul/2016:09:40:27 -0400] "POST /vb_test.php HTTP/1.1" 200 1322 "http://forum2.apollo3.com/vb_test.php" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36"
                        poseidon.apollo3.com - - [31/Jul/2016:10:47:55 -0400] "GET / HTTP/1.1" 304 208 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36"
                        error.log:
                        Code:
                        [Sun Jul 31 09:39:32 2016] [error] [client 50.75.184.39] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in /home/web/apoforum/www/vb_test.php on line 21
                        [Sun Jul 31 09:39:46 2016] [error] [client 50.75.184.39] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in /home/web/apoforum/www/vb_test.php on line 21, referer: http://forum2.apollo3.com/vb_test.php
                        [Sun Jul 31 09:39:57 2016] [error] [client 50.75.184.39] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in /home/web/apoforum/www/vb_test.php on line 21
                        [Sun Jul 31 09:40:27 2016] [error] [client 50.75.184.39] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in /home/web/apoforum/www/vb_test.php on line 21, referer: http://forum2.apollo3.com/vb_test.php
                        As you can see earlier I ran the test script. I just clicked on the board and there is an entry in the caccess.log, but the error.log is blank.

                        When access the board, nothing comes in the error log.

                        By the way, the time now is 10:55AM.

                        -- L. James

                        --
                        L. D. James
                        [email protected]
                        www.apollo3.com/~ljames

                        Comment


                        • #13
                          Just a thought, but are the forum files still actually present on the server?
                          Is every page broken? What happens if you go to other pages, such as /online.php
                          MARK.B | vBULLETIN SUPPORT

                          TalkNewsUK - My vBulletin 5.6.3 Demo
                          AdminAmmo - My Cloud Demo

                          Comment


                          • #14
                            I'm just noticing that other pages works on the new computer. Only the root page fails. There wasn't any activity or traffic on the new computer to notice that the other pages were working.

                            On the production computer, other pages brings up mysql errors.

                            I renamed the index.html file and now the new installation on the new computer works as it's been working for 10 years.

                            It might have something to do with the new apache ignoring other indexes when there is an index html file. If you have any idea how to address it and leave blank index.html, I'll try to fix it. Otherwise I have a working system at present.

                            By the way, I'll check the for discrepancies in the mysql configuration to see why it fails no the production computer.

                            Thank you very much for your devoted attention to this.

                            -- L. James

                            --
                            L. D. James
                            [email protected]
                            www.apollo3.com/~ljames

                            Comment


                            • #15
                              You don't need an index.html file, the root should pick up index.php and go straight to that, if the server is correctly configured.

                              If there are MySQL errors, post the full actual error up and we can take a look.
                              MARK.B | vBULLETIN SUPPORT

                              TalkNewsUK - My vBulletin 5.6.3 Demo
                              AdminAmmo - My Cloud Demo

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X