Announcement

Collapse
No announcement yet.

Failed upgrade to 3.8.9 - Forum still down

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mark.B
    replied
    php warnings should always be supressed on a production server anyhow.

    Leave a comment:


  • kh99
    replied
    I believe it's the error handler that changed, so that the issue always existed, but in vb3.8.7 you weren't seeing the warning displayed. It could be that it's not really a problem, but it does mean there's a place in the code where it's expecting an array and it doesn't have one, which is usually a bug.

    Leave a comment:


  • aciurczak
    replied
    Yes - it probably is a plug-in of some sort. But I'm at PHP 5.4 on another site with 3.8.7 PL5, and the warning isn't showing up, so it is a change to 3.8.9 that appeared to trigger the warning. For now I suppressed the warning, but will come back to it when I have some more free time. Site seems functional at this point.

    Leave a comment:


  • kh99
    replied
    That "illegal string offset" warning is a problem from a plugin. You could temporarily disable your products one at a time until it goes away to figure out which one it is, then contact the developer to see if you can get it fixed.

    Leave a comment:


  • aciurczak
    replied
    Interesting. Once it successfully said 5.4, then I was able to continue the install, sort of. It would fail, but then with a shift refresh, it would work. But at the next step it would fail again, without shift refreshing along the way. It appeared to work all the way through. But then when going back to the admin panel, it would still periodically give that error. But shift-refreshing would usually fix it.

    In the forum as well, I was able to turn it on and start posting, but would sometimes get errors. And even if it worked without a failure, it still showed a PHP warning at the top of each screen after posting:

    PHP Warning: Illegal string offset 'type' in ..../includes/class_postbit.php(294) : eval()'d code on line 59

    Googling that illegal string offset warning, it appears that a number of people fixed it by going back to PHP 5.3 rather than 5.4. I just made that config change, but will have to wait a little while again to see if that takes care of the warning or if I need to do something more drastic.

    Leave a comment:


  • aciurczak
    replied
    On the download page it says 5.3 or greater, but going to 5.4 anyway as there doesn't seem to be much downside. I've updated it on the host, but the vbulletin php status page is still showing 5.2, so it may take a little while to kick in. Once it shows 5.4 successfully, will retry and hope for the best.

    From the vb download site:
    Notes
    vBulletin 3.6.0 - 3.8.6 requires PHP 4.3.3 or greater, and MySQL 4.0.16 or greater.
    vBulletin 3.8.7 - 3.8.8 requires PHP 5.2.0 or greater, and MySQL 4.0.16 or greater.
    vBulletin 3.8.9 requires PHP 5.3.0 or greater, and MySQL 4.1.0 or greater, and cURL to be installed.

    vBulletin 4.0.0 - 4.2.2 requires PHP 5.2.0 or greater, and MySQL 4.1.0 or greater, 4.2.2 requires cURL to be installed.
    vBulletin 4.2.3 requires PHP 5.4.0 or greater, and MySQL 4.1.0 or greater, and cURL to be installed.

    vBulletin 5.0.x requires PHP 5.3.0 or greater, and MySQL 5.1.5 or greater.

    vBulletin 5.1.0 - 5.1.6 requires PHP 5.3.7 or greater, MySQL 5.1.5 or greater, and cURL to be installed.
    (Facebook features require PHP 5.4.0 or greater.)

    vBulletin 5.1.7 requires PHP 5.4.0 or greater, MySQL 5.1.5 or greater, and cURL to be installed.

    vBulletin 5.1.8 supports MariaDB 5.1.5 onwards.
    To submit a bug or receive support, please visit the community forums.
    Click here for vBulletin 2 upgrade instructions.


    Leave a comment:


  • Mark.B
    replied
    The minimum recommended version for 3.8.9 is 5.4.

    Leave a comment:


  • aciurczak
    replied
    Hmmm.... looks like it still might have been on PHP 5.2, which may be causing this issue. Pushing it to PHP 5.4, and will give it another shot...

    Leave a comment:


  • aciurczak
    replied
    I have a full db backup and file system backup, so with time I would be able to get it back up under 3.8.7. But are there any ideas about why it might be failing on line 966?

    Leave a comment:


  • aciurczak
    started a topic Failed upgrade to 3.8.9 - Forum still down

    Failed upgrade to 3.8.9 - Forum still down

    Attempted to update my 3.8.7 PL5 forum to 3.8.9. It steps through all pieces, until it gets to the last portion of the install, and on Step 2 it shows this error:
    Step 2) Import latest admin help
    Importing vbulletin-adminhelp.xml
    Parse error: syntax error, unexpected T_FUNCTION in /home/content/XX/XXXXXXX/html/forums/includes/adminfunctions_language.php on line 966


    If I put in the argument to get to Step 3, it shows the same error. If I put in the argument to jump to Step 4, it succeeds, and Step 5 also succeeds. I wasn't sure if step 2 and step 3 were critical, but sadly they appear to be. Now when I go into the control panel, I am unable to bring up the option to even turn my forum back on, as it shows the same error:
    Parse error: syntax error, unexpected T_FUNCTION in /home/content/37/3586737/html/forums/includes/adminfunctions_language.php on line 966



Related Topics

Collapse

Working...
X