Announcement

Collapse
No announcement yet.

Cookies/Log-In Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by Kajouka View Post
    Thank you Zachery! I will take what you have said to my webhost and see if they can resolve it. Appreciated!

    I just started having the same problem today. Let me know what you find out. I also noticed something with "New Posts" not showing up unless I refresh the browser.

    Comment


    • #32
      Originally posted by Mike Corrian View Post
      I just started having the same problem today. Let me know what you find out. I also noticed something with "New Posts" not showing up unless I refresh the browser.
      I will! I'm sitting waiting for a webchat with my host.

      Control + F5 hard refresh will definitely bring up the right page. I am wondering if we all aren't using the same host or servers or something. It's just too odd to be a coincidence.

      Comment


      • #33
        Bluehost here.

        Comment


        • #34
          I'm with hostmonster

          Comment


          • #35
            Wow... I am not alone with this issue.
            nemotorsport.com is having the very same issues as you all are.
            You login, vbulletin message says you are logged in, after page refreshes you not logged in. If any link is clicked in navbar, you logged in.
            When creating a post, new post is not updating. You go to the page you made the post & its not there until you refresh...

            This is NOT plugin related. It is Not .htaccess related. It is NOT browser related.( My host (BH) does not cache HTML.) It IS vbulletin related.



            I have been with vbulletin for many years & it seems that all issues we have with our sites is plugin related in your eyes. I think with as many people that are posting the same issue it is not any of the reasons I stated above.

            Please look into this for all of us that posted in this thread & for the many more that will be showing up here to post similar issues.

            Comment


            • #36
              I've looked at all of the sites people have been talking about. All of their webservers are sending expires headers in the future for some period of time, from 1 day to 1 year. This is a webhosting configuration issue.

              Comment


              • #37
                Originally posted by Zachery View Post
                I've looked at all of the sites people have been talking about. All of their webservers are sending expires headers in the future for some period of time, from 1 day to 1 year. This is a webhosting configuration issue.
                HI Zach! Can you tell me what 'sending expires headers' means? I have put in a ticket with my webhost for them to look at this issue and any information would be great!

                Edit: Also, why would this hit all these different sites/hosts all one day? Everyone has reported this just suddenly happening starting yesterday
                Last edited by Kajouka; Wed 5 Dec '12, 8:14pm.

                Comment


                • #38
                  Might have been included in cpanel security updates, a number of which were just pushed out.

                  Comment


                  • #39
                    Originally posted by Zachery View Post
                    Might have been included in cpanel security updates, a number of which were just pushed out.
                    I just read this whole thread and was just about to mention that all hosts using cpanel had two sucessive updates due to security issues and this may be the case.

                    EDIT: If you have access it could either be in cpanel configuration (WHM) for Cookie IP security or in cPanel Web Services Configuration where the cipher is kept, i've not had the issue that you're all facing but if it helps my cipher there is ALL:!ADH:+HIGH:+MEDIUM:-LOW:-SSLv2:-EXP
                    Last edited by Simon Lloyd; Thu 6 Dec '12, 1:46am. Reason: added info
                    Kind regards,
                    Simon
                    Microsoft Office Discussion

                    Comment


                    • #40
                      Originally posted by Kajouka View Post
                      I'm with hostmonster
                      I am too

                      Comment


                      • #41
                        Someone on bluehost support forum posted this:

                        Hello,

                        I have a vBulletin forum hosted by bluehost and as of yesterday, some strange new behavior has cropped up. First, let me state up front that nothing on my end has changed. No files, configs, etc, in at least a month.

                        vBulletin does redirects for lots of things like search results, what's new, posts, etc. These redirects no longer return the latest information anymore. For example, performing a search normally results in a redirect to a URL with a ?searchid=xxxxx in the url. EACH search used to result in a unique searchid. As of yesterday sometime, this no longer happens. Now, many of my users' browsers (all makes, all versions, it's not a browser problem) are being sent to the same URL each time - as if the redirect has been cached.

                        In fact, the only way to restore the previous behavior is to have the user clear their cache between each and every post, search, etc. This is absolutely not an option so I'm a little stuck. I sent a support request to bluehost last night and haven't heard back yet so I thought I'd check with you guys.

                        Incidentally, a fellow vBulletin forum that I'm friendly with is also experiencing the same issue.

                        For now, the only fix I've found that I can do on the server is to add the following to our .htaccess:

                        Code:

                        Code:
                        # Turn on Expires and set default to 0
                        ExpiresActive On
                        ExpiresDefault A0
                        
                        # Force no caching for dynamic files
                        <FilesMatch "\.(php|cgi|pl|htm|html)$">
                        ExpiresActive Off
                        Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform
                        "Header set Pragma "no-cache"
                        </FilesMatch>


                        Which is VERY VERY heavy handed. It works without forcing my 700+ users to clear their cache everytime they want to do something on my forum. But it's absolutely the wrong solution and I want to know if there's anything else I can do (besides wait for bluehost to fix whatever they broke) to get this fixed ASAP.

                        Thanks!

                        Comment


                        • #42
                          wow, I'm on Hostmonster too. Still waiting to hear back from a service ticket I opened with them.

                          - - - Updated - - -

                          Originally posted by Mike Corrian View Post
                          Someone on bluehost support forum posted this:
                          I just tried using that code and received a massive error. Where do you exactly put that in the .htaccess file?

                          Comment


                          • #43
                            Blue Host & Host Monster are the same company. So.... I submitted a ticket & yet to hear back.

                            Comment


                            • #44
                              This is the reply I received

                              Hello,

                              Have you tried setting turning off the content cache in vbulletin itself?
                              AdminCP > Settings > Options > Server Settings and Optimization Options > Disable Content Caching > Yes

                              In addition, you should be able to disble caching through your headers. For example:

                              Header set Expires "Thu, 19 Nov 1981 08:52:00 GM"
                              Header set Cache-Control "no-store, no-cache, must-revalidate, post-check=0, pre-check=0"
                              Header set Pragma "no-cache"

                              Unfortunately the apache module mod_cache cannot be disabled on our servers, due to our server configuration not allowing CacheDisable in the .htaccess files.

                              Please let us know if you have further questions or concerns.

                              Thank you,
                              Derek
                              Level II Site/Script Compatibility
                              1. I couldn't find the option they referred to.
                              2. I tried pasting that into my headers and nothing changed.

                              Comment


                              • #45
                                I also do not have that path to that specific option in my admincp. arghhghg

                                - - - Updated - - -

                                Also tried to paste that into my header and unless I'm missing some code, all that does is display that text above/below my header image.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X