Announcement

Collapse
No announcement yet.

Paid subscription problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zachery
    replied
    Sorry, start a support ticket with my attention and include ftp and AdminCP access please.

    Leave a comment:


  • Ludachris
    replied
    Just to reiterate, cURL SSL is installed and working on the server. Anything else I can check or am I just destined to not be able to use the Paid Memberships feature in vB?

    Leave a comment:


  • Ludachris
    replied
    Any other ideas?

    Leave a comment:


  • Ludachris
    replied
    Originally posted by Zachery View Post
    Ask your webhost if curl with SSL is enabled.
    Will do, thanks!

    Again though, would this explain why the Paypal option for payment is not showing up at all on the ordering page in the screenshot above?

    - - - Updated - - -

    I was told cURL SSL is installed, enabled, and working properly.

    Leave a comment:


  • Zachery
    replied
    Ask your webhost if curl with SSL is enabled.

    Leave a comment:


  • Ludachris
    replied
    Originally posted by Zachery View Post
    Check your phpinfo, and see fi curl and or curl with SSL is available.
    Also check for any disabled functions.
    cURL is installed, not sure about cURL with SSL. Virtual Directory Support and Thread Safety are disabled.

    - - - Updated - - -

    Originally posted by Zachery View Post
    Double check your payment api for paypal as well, make sure that your email addresses are listed correctly.
    They are correct. I've even tried changing the primary account email in Paypal and updating it in vB just to see if that had any effect. Nope.

    - - - Updated - - -

    Originally posted by Trevor Hannant View Post
    I know this sounds silly, but check with Firebug (or similar) and see if the image file call is there but the image is missing or can't be loaded
    Would I be doing this when I click Test Communication? or when?

    Leave a comment:


  • Zachery
    replied
    Double check your payment api for paypal as well, make sure that your email addresses are listed correctly.

    Leave a comment:


  • Trevor Hannant
    replied
    Originally posted by Ludachris View Post
    The link works, but there is no checkmark in the circle when I do the test, so it looks like the site isn't communicating with Paypal. I'm checking with Paypal to see if they can help. I've confirmed all my settings are correct after checking all the suggestions in the forums and in the docs. My host can't find anything in the firewall settings or server config.

    Should failed communication with Paypal cause that ordering button to not show up?
    I know this sounds silly, but check with Firebug (or similar) and see if the image file call is there but the image is missing or can't be loaded

    Leave a comment:


  • Zachery
    replied
    Check your phpinfo, and see fi curl and or curl with SSL is available.
    Also check for any disabled functions.

    Leave a comment:


  • Ludachris
    replied
    The link works, but there is no checkmark in the circle when I do the test, so it looks like the site isn't communicating with Paypal. I'm checking with Paypal to see if they can help. I've confirmed all my settings are correct after checking all the suggestions in the forums and in the docs. My host can't find anything in the firewall settings or server config.

    Should failed communication with Paypal cause that ordering button to not show up?

    Leave a comment:


  • Zachery
    replied
    The test communication link isn't working?

    Leave a comment:


  • Ludachris
    replied
    It looks a little different in 3.8.X but it's the Order Using Paypal button that's missing. I had disabled all hooks and tried viewing in a stock style over the weekend with no changes. Would this have anything to do with the site not being able to communicate with Paypal (the Test Communication link isn't passing). I wouldn't think so. I've confirmed the Paypal API is acting in admincp.

    Click image for larger version

Name:	Screen shot 2012-11-05 at 3.56.52 PM.png
Views:	1
Size:	60.1 KB
ID:	3690648

    Leave a comment:


  • Zachery
    replied
    There has never been a buy it now or buy it button.


    Click image for larger version

Name:	2012-11-05_18h40_34.png
Views:	1
Size:	25.7 KB
ID:	3690646
    Click image for larger version

Name:	2012-11-05_18h41_25.png
Views:	1
Size:	28.3 KB
ID:	3690647

    There are only two new areas for paid subscriptions when its enabed. A link under the User's Control Panel / Settings page, and the page itself.

    Leave a comment:


  • Ludachris
    replied
    Here's a quick question that any developer should be able to easily answer - if there is a communication problem between my server and Paypal, would that cause the Paypal "purchase" option to disappear on the Payment Method page (payments.php?do=order) for the subscription? Meaning, I can see all of the active subscriptions for the site. But when I choose the subscription and click Order, it takes me to the ordering page and it shows the pricing info but now button to actually purchase. If Paypal is the only method that's active and there is a problem with Paypal communication, would that "buy it" button not appear? Or is this a separate issue?

    Leave a comment:


  • Ludachris
    replied
    Still can't get Paypal to communicate with the server. I disabled all hooks, set default templates to a stock style, and tried to Test Communication. It is not passing. I've contacted the host to see if there is something preventing the communication between the server and Paypal. I logged into the server and tried pinging Paypal and get no data back. Not sure what to check next. I've sent Paypal a note to see if they can help. Our host hasn't found anything wrong with the server config. Anyone have any suggestions?

    Leave a comment:

Related Topics

Collapse

Working...
X