Announcement

Collapse
No announcement yet.

Deprecated: Assigning the return value of new by reference is deprecated in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Deprecated: Assigning the return value of new by reference is deprecated in

    I'm running 3.8.1. From reading other threads the resolution is to update to 3.8.5. This isn't an option since my support ended with the final version available to me being 3.8.1. What other options do I have other than paying for a full upgrade?

  • #2
    You would need to purchase an upgrade and then I recommend upgrading to 3.87 PL2.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Thanks. Look's like there is a workaround which seems to resolve these errors.

      Comment


      • #4
        You can go that route if you wish. It isn't something we can support.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment


        • #5
          That does work but as stated it will invalidate your support and make upgrading a pain -not that you'll be upgrading though else it wouldn't be an issue.

          Frankly the best bet is to save up and invest in a vB4 licence so you're not stuck in the dark ages. You'll possibly get security issues in 3.8.1 and I'm not sure if the 3.8.7 patches are "back ported" to earlier versions like they are with 4.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.6.3 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #6
            My issue is really the forum is not used any more. I think its seen maybe 2 posts in 4 years. I should close it really but an old member contacted me to say they still use the Arcade on the forum and noticed it was down.

            Comment


            • #7
              Best off disabling warnings just for that domain maybe? They are just warnings not errors anyway.

              You can do that in php.ini like so:
              Code:
              error_reporting = E_ALL & ~E_DEPRECATED
              Obviously ultimately you should solve the underlying problem but...

              Comment

              Related Topics

              Collapse

              Working...
              X