Announcement

Collapse
No announcement yet.

new install doesnt work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • new install doesnt work

    Hi,

    I just re-installed into a new DB on a new server so that its a blank installation.

    In FireFox when I go to the admin page it is blank with a PHP depricated warning
    Deprecated: Assigning the return value of new by reference is deprecated in /var/www/vhosts/domain.com/httpdocs/forums/includes/init.php on line 49

    In IE it shows
    Internet Explorer cannot display the webpage
    ^^ Fidler shows some wierd content that doesnt look english in the response


    Chrome (after being able to login) shows me
    This webpage is not available
    The webpage at http://www.domain.com/forums/login.php?do=login might be temporarily down or it may have moved permanently to a new web address.
    Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.

    My host has APC installed, and I have tried to disable plugins and gzip by setting the following in the top of the config.php - I have also tried it on a non APC server, one that uses eAccelerator and same problem.

    ini_set('memory_limit', -1);
    DEFINE('NOZIP', 1);
    define('DISABLE_HOOKS', true);

    It appears to be related to content encoding/compression

    Content Encoding Error
    The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.
    Please contact the website owners to inform them of this problem.
    if I specify content encoding then it just comes back as jibberish and is broken
    wget --header "Accept-Encoding: gzip,deflate" http://www.domain.com
    However if I dont specify that, then it works fine
    wget --header "" http://www.domain.com
    I tried going into the DB and modifying the setting for gzip (since I cant get into the admin) and that didnt seem to help.

    UPDATE `db`.`setting` SET `value` = '0' WHERE `setting`.`varname` = 'gzipoutput';
    UPDATE `db`.`setting` SET `value` = '0' WHERE `setting`.`varname` = 'gzipsetting';

    I am at a loss and don't know where else to look - any help would be appreciated.
    Last edited by taheri6; Thu 8th Mar '12, 3:34pm.

  • #2
    That deprecated error is certainly coming up a lot lately, check this thread...

    https://www.vbulletin.com/forum/show...in-3-8-problem
    Lats...

    Comment


    • #3
      unfortunately for me I downloaded and installed the latest 3.8.5 PL2 from the members area already when I got this error, so the mention there to update to the latest version wouldnt apply to me.

      Comment


      • #4
        What version of php are you running on the server?

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help

        Comment


        • #5
          Hi,

          we run 5.3.10, with the necessary suhosin modifications

          PHP 5.3.10 (cli) (built: Feb 3 2012 08:20:28)
          Copyright (c) 1997-2012 The PHP Group
          Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
          with the ionCube PHP Loader v4.0.10, Copyright (c) 2002-2011, by ionCube Ltd., and
          with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies
          with Suhosin v0.9.33, Copyright (c) 2007-2012, by SektionEins GmbH

          Comment


          • #6
            vB3.8.5 will give errors if you use php5.3. If you want to use php5.3, you will need to upgrade to vB3.8.7

            Please don't PM or VM me for support - I only help out in the threads.
            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
            Want help modifying your vbulletin forum? Head on over to vbulletin.org
            If I post CSS and you don't know where it goes, throw it into the additional.css template.

            W3Schools <- awesome site for html/css help

            Comment


            • #7
              I only have the option to download 3.8.2 as the latest version in the members area

              it says
              "Latest Stable Version: 3.8.7 Patch Level 2"
              but then it only allows me to download D

              ownload Latest Version 3.8.2
              (Only the latest stable version is supported.)

              Last edited by taheri6; Fri 9th Mar '12, 9:59am.

              Comment


              • #8
                Originally posted by taheri6 View Post
                I only have the option to download 3.8.2 as the latest version in the members area
                Then how did you install version 3.8.5?
                Originally posted by taheri6 View Post
                unfortunately for me I downloaded and installed the latest 3.8.5 PL2 from the members area already when I got this error, so the mention there to update to the latest version wouldnt apply to me.
                You will either need to downgrade your PHP to PHP5.2 or purchase an upgrade for your vbulletin in order to upgrade to 3.8.7

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools <- awesome site for html/css help

                Comment


                • #9
                  I appologize for the mistype, I actually just noticed with that last post that the latest version available that it told me was not the latest version that it allowed me to download when I thought they would be the same - my appologies on the confusion. We additionally do not have the option of downgrading php as its a shared hosting company. Im hesitant to pay to upgrade when I cant get the one I have to work - I do ultimately want to upgrade but first I need to ensure that the current one actually works and I can modify settings accordingly, etc - as it stands right now I cant even get into the admin panel to turn the BB off (just get that blank page with the depricated message) and I get the invalid content error when trying to view the site. That doesnt really instill the desire to pay more (or again)

                  Comment


                  • #10
                    You could try installing MAMP on your computer (or whatever it is called on a PC - WAMP?) and seeing if it works there. I just know that if you have version 3.8.2 or 3.8.5, it is not going to work without errors if you have PHP5.3

                    Please don't PM or VM me for support - I only help out in the threads.
                    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                    Want help modifying your vbulletin forum? Head on over to vbulletin.org
                    If I post CSS and you don't know where it goes, throw it into the additional.css template.

                    W3Schools <- awesome site for html/css help

                    Comment


                    • #11
                      Im mainly concerned right now with the content encoding errors that are coming up - its basically making the site unreachable for everyone. Once that can get resolved I will look into upgrading and exporing data, etc - I can put up with the depricated errors for now, as long as I can get to the site at all!

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X