Announcement

Collapse
No announcement yet.

Deprecated File

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disasterpiece
    replied
    I had the problem that some warnings stopped the install script from working in the later steps, disabling E_WARNING helped me out.

    Here is a quick script to change all the php files if you point $basepath to the forum root (place this script outside of the forum root for obvious reasons)

    As of now (vb4.2.0 PL3) this has still not been addressed.

    PHP Code:
    <?php

    $basepath 
    "/var/www";

    function 
    cycledir($dirname) {
            
    $handle opendir($dirname);
            if (!
    $handle) {
                    echo 
    "WARN: $dirname could not be opened!\n";
                    return;
            }
            
    $dirname .= '/';
            while (
    false !== ($file readdir($handle))) {
                    if (
    $file{0} != '.') {
                            if (
    is_file($dirname.$file) && substr($file,-3) == 'php') {
                                    
    $raw file_get_contents($dirname.$file);
                                    
    $new str_replace("error_reporting(E_ALL & ~E_NOTICE)""error_reporting(E_ALL & ~E_NOTICE & ~8192 & ~2048 & ~E_WARNING)"$raw);
                                    
    file_put_contents($dirname.$file$new);
                                    echo 
    $raw == $new "wrote ".$dirname.$file."\n" "no changes: ".$dirname.$file."\n";
                            } elseif (
    is_dir($dirname.$file)) {
                                    
    cycledir($dirname.$file);
                            }
                    }
            }
    }

    cycledir($basepath);

    echo 
    "OK\n";
    ?>

    Leave a comment:


  • TECK
    replied
    Thanks, I did not know.
    Even on vBulletin 4, you have a lot of work to do in order to make the old deprecated code compatible with PHP 5.4.0. Adding the E_STRICT won't suffice.

    Leave a comment:


  • Wayne Luke
    replied
    The end of life for 3.8.7 was stated over a year ago. So, if people were going to leave for that purpose, they probably already would have done so.

    https://www.vbulletin.com/forum/show...nance-releases

    Leave a comment:


  • TECK
    replied
    Thanks for the info, Wayne. I think is a mistake not to maintain the 3.8 branch. There are tons of large forums who don't upgrade to branch 4.x due to server cost increase and performance issues. Dropping the 3.8 support will probably force them to move to a different forum software.

    Leave a comment:


  • Wayne Luke
    replied
    vBulletin 3.8.X is basically end of life. No further bug fixes will be made to this software, even to support newer versions of PHP and/or MySQL. If you continue to use this software, you will need to make sure it is up to date with the other software on your server. At the most, we will issue a security patch if we find a security issue and this isn't something that would be changed in a security patch.

    vBulletin 3.8.4 and lower will not work with PHP 5.3.0 or higher. vBulletin 3.8.7 and lower will not work with PHP 5.4.0 or higher. This is often the case with older and out of date software that is no longer being updated.

    There are several issues in the tracker to bring vBulletin 4.X and higher in compliance with PHP 5.4.0 and higher. It will most likely only be applied to versions higher than 4.1.11. We will probably not go back and retrofit older versions. If you want to speak about vBulletin 4.X issues, then you need to post in the appropriate forums for those versions.

    Leave a comment:


  • TECK
    replied
    I just tested 5.4.0 with vBulletin, it is a disaster. Stick with 5.3.x for now.
    This is obviously not PHP developer's fault.

    Personally, I fixed the issues by disabling the E_STRICT errors, but why in the world someone would do that for a product like vBulletin, instead of actually fixing the code?
    In each file, find:
    Code:
    error_reporting(E_ALL & ~E_NOTICE & ~8192);
    Replace it with:
    Code:
    if (!defined('E_DEPRECATED'))
    {
    	define('E_DEPRECATED', 8192);
    }
    if (!defined('E_STRICT'))
    {
    	define('E_STRICT', 2048);
    }
    error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT);
    Or use the lazy ass method:
    Code:
    error_reporting(E_ALL & ~E_NOTICE & ~8192 & ~2048);
    The E_DEPRECATED related code should of been fixed ages ago, slapping a 8192 int into that error reporting function is a no go in my books.

    Edit: That won't be enough. There are many things broken, like plugins, headers, etc. that don't work anymore with the new PHP version. Should be the same for vBulletin 4, adding a E_STRICT exception is not enough. Looks like the devs will have to write a lot of new code.
    Last edited by TECK; Mon 12th Mar '12, 6:23pm.

    Leave a comment:


  • TECK
    replied
    Originally posted by Wayne Luke View Post
    You need to either downgrade your PHP installation to something before PHP 5.3.0 or you need to upgrade vBulletin to 3.8.5 or higher. vBulletin 3.8.X does not support PHP 5.4.0 or higher and probably never will.

    Since you're on vBulletin 3.8.7 (according to the screenshot), you either have old out of date files or you're running an unsupported version of PHP.
    Really. There is nowhere in the vBulletin license stating that there is a limitation for new PHP versions. From the Members area:
    Note: vBulletin 3.6 and higher requires PHP 4.3.3 or greater and MySQL 4.0.16 or greater!
    vBulletin 4.0 and higher requires PHP 5.2.0 or greater and MySQL 4.1.0 or greater
    Originally posted by MGC x Pie x Mc View Post
    How do I fix this?
    Edit the files and remove the reference from each line, '=&' should become '='. Example for line 55:
    Code:
    $vbulletin = new vB_Registry();
    This trivial fix should a vBulletin developer responsibility, not ours.

    Leave a comment:


  • VbulletinItalia.
    replied
    Hi
    By the Administrative Panel of your domain or you need to ask your provider.

    Leave a comment:


  • MGC x Pie x Mc
    replied
    How do I change the PHP Installation?

    Leave a comment:


  • Wayne Luke
    replied
    You need to either downgrade your PHP installation to something before PHP 5.3.0 or you need to upgrade vBulletin to 3.8.5 or higher. vBulletin 3.8.X does not support PHP 5.4.0 or higher and probably never will.

    Since you're on vBulletin 3.8.7 (according to the screenshot), you either have old out of date files or you're running an unsupported version of PHP.

    Leave a comment:


  • MGC x Pie x Mc
    started a topic Deprecated File

    Deprecated File

    I keep getting this notification




    How do I fix this?

Related Topics

Collapse

Working...
X