Announcement

Collapse
No announcement yet.

Prune old posts, Server stopped responding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Prune old posts, Server stopped responding

    Hi,
    we have 24mm posts in our vBulletin 3.8, we tried to prune all old posts that are 6 months or older.

    The prune page in vBulletin seems to be dying before it can complete (I get server stopped responding). I tried deleting all posts from 6 months back and before, and the VM was unreachable for a few hours (later on, I tried to SSH in and couldn't). Afterwards, the VM was reachable again, but none of the posts seemed to be missing. I tried Rebuild Forum Information, but nothing seemed to happen.

    Is there some manual way to prune threads? Or command-line version would be also helpful.

    Thanks

  • #2
    So you're trying to prune a 20+ million posts? Thats going to take some serious pruning sheers. I would suggest starting with a MUCH smaller chunk of data.

    Comment


    • #3
      We managed to prune 30,000 threads at 1000 threads per minute.
      We have 2.4 million threads total, so this would take the better part of a week...

      If anybody have done any quicker ways, much appreciated.

      Comment


      • #4
        Give your VM more memory so the scripts can handle larger blocks.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          Originally posted by Wayne Luke View Post
          Give your VM more memory so the scripts can handle larger blocks.
          Thanks for the suggestion.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X