Announcement

Collapse
No announcement yet.

IE11 Won't load attachments First time, but will thereafter

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • IE11 Won't load attachments First time, but will thereafter

    When you click on attachment with IE11 it does not load, you just see a spinney thing as its going through the motions. However, click on the attachment after the failed attempt and it will load it immediately. So it's downloading it, but not displaying it. Can anyone help? Thanks

  • #2
    http://www.vbulletin.org/forum/showthread.php?t=303520

    Comment


    • #3
      Thanks Zachery, yes I'd already applied that, but its still not working. This has only started happening with the very latest version of IE. Only in the last couple of days have I had members report the the issue

      Comment


      • #4
        Clear your browser cache and cookies.

        Comment


        • #5
          Yes, still no joy. If I click on an attachment, the screen goes dark for focus, then I get the spinning curser while the image loads, but the spinning stops and nothing. Close the window and click on the attachment again and its shows it instantly.

          Comment


          • #6
            Anyone else experiencing this issue with IE11?

            Comment


            • #7
              You may need to force compatibility mode in order to get round the issue.
              3.8 is unlikely to receive updates for compatibility with IE11.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.6.3 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #8
                Thanks Mark, how do I do that?

                Comment


                • #9
                  Originally posted by jimjam View Post
                  Thanks Mark, how do I do that?
                  Add this line to the very top of your headinclude template-

                  Code:
                  <meta http-equiv="X-UA-Compatible" content="IE=9" />
                  That will tell IE to browse the site as if it was IE9.

                  Comment


                  • #10
                    I had users complaining about the same issue and a few that also claimed they could no longer scroll on my site after the IE update. Post #9 in this thread has fixed all reported issues from my users. Thank you.

                    Comment


                    • #11
                      Originally posted by Joe D. View Post

                      Add this line to the very top of your headinclude template-

                      Code:
                      <meta http-equiv="X-UA-Compatible" content="IE=9" />
                      That will tell IE to browse the site as if it was IE9.
                      I've tried this as well as the vBulletin.org fix Zachery linked to in post 2. I still have the same issue in IE 11 where attachments don't load when first clicked.

                      I've cleared my cookies and cache.

                      Any other thoughts?

                      Comment


                      • #12
                        Originally posted by oldford View Post
                        I've tried this as well as the vBulletin.org fix Zachery linked to in post 2. I still have the same issue in IE 11 where attachments don't load when first clicked.

                        I've cleared my cookies and cache.

                        Any other thoughts?
                        'Only thought is that some mod may hijack your headinclude template and insert itself above the line you added- what is the URL to your forum?

                        Comment


                        • #13
                          Originally posted by Joe D. View Post
                          'Only thought is that some mod may hijack your headinclude template and insert itself above the line you added- what is the URL to your forum?
                          http://classicbroncos.com/forums/index.php

                          Thanks!

                          Comment


                          • #14
                            It looks like the fact you have Add No-Cache HTTP Headers enabled in Cookies and HTTP Header Options is causing the problem- these lines appear at the very top of the header template and therefore push your IE compatibility line down.

                            Please try disabling this option for a bit and then re-try IE and see if you still have the problem. If the problem does go away we can figure out some work-around to move the IE line back to the top of the template where it needs to be.

                            Comment


                            • #15
                              Thank you very much! As it turns out I didn't actually have "Add No-Cache HTTP Headers" enabled but I did have "Send Internet Explorer 7 Compatibility Header" enabled. (is that a stock vBulletin option or a mod?)

                              Anyway, disabling "Send Internet Explorer 7 Compatibility Header" seems to have fixed it. Attachments now work in IE11.

                              Thanks everyone for the help!
                              Attached Files

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X